locked
Can't access VM from Lync client after migrating back to Exchange On-Prem RRS feed

  • Question

  • A few months ago we "tested" Exchange Online and determined it was not suitable for our company's requirements. I only tested with a few accounts - my own one of them. Currently, we're running Lync 2013 and Exchange 2013 on-premises without issue except that I, and only I, cannot access my voicemail. I had migrated my mailbox back to on-premises from EO and everything else Exchange-related works for me. I canaccess my VM via the subscriber access line but if I try to "Call Voice Mail" from either my Lync LPE (Polycom CX600) or client, it says I'm "unavailable or may be offline" on the client or "Call unsuccessful.  Voice Mail is unavailable right now.  Please try later." on the LPE.  When I look at the Lync server logs, it's indicating the following:

    Attempts to route to servers in an Exchange UM Dialplan failed

    No server in the dialplan [Hosted__exap.um.outlook.com__company.onmicrosoft.com] accepted the call with id [ee002254d9ab4a99c752d940a77be205].

    Cause: Dialplan is not configured properly.

    Resolution:

    Check the configuration of the dialplan on Exchange UM Servers.

    Which is telling us it's trying to call out to EO for my UM.  But I migrated my mailbox to on-premises?  If I look at my account in Exchange, it shows my mailbox on-prem and UM enabled with our on-prem UM mailbox policy and dial plan.  I've tried disabling UM and re-enabling but it doesn't change anything.  My EUM address is correct.  I looked at my AD attributes and found nothing out of the ordinary. Reviewing the Lync client logs after attempting a call to UM results in an error like below:

    <reportError xmlns="http://schemas.microsoft.com/2006/09/sip/error-reporting"><error toUri="sip:j.doe@company.com;opaque=app:voicemail" callId="93a481bc5b7c45868057fad842297441" fromTag="5dbd6e36cd" toTag="5C3A9BA30F5AC52DAE32D0D0A2674C15" contentType="multipart/alternative;boundary=&quot;----=_NextPart_000_0035_01CF2726.7DF989E0&quot;;call-type=audiovideo" responseCode="480" requestType="INVITE"><diagHeader>52086;reason="The conversation could not be established as the remote party is not available";OriginalPresenceState="0";CurrentPresenceState="0";MeInsideUser="Yes";ConversationInitiatedBy="0";SourceNetwork="0";RemotePartyCanDoIM="No"</diagHeader><progressReports><progressReport><diagHeader>13007;reason="Request was proxied to an application.";source="lyncpoolfqdn.company.COM";targetApp="voicemail";appName="InboundRouting"</diagHeader></progressReport><progressReport><diagHeader>15008;reason="Routing to UM for Subscriber Access";source="lyncpoolfqdn.company.COM";dialplan="Hosted__exap.um.outlook.com__company.onmicrosoft.com";umserver="exap.um.outlook.com";appName="ExumRouting"</diagHeader></progressReport><progressReport><diagHeader>15023;reason="Re-directing request to the destination in 303";source="BL20C00EDG02.LYNC0C001.LOCAL";Destination="sip:j.doe@uminternal.um.prod.outlook.com:5061;ms-organization=company.onmicrosoft.com;transport=Tls;ms-fe=pod51034.um.prod.outlook.com";appName="ExumRouting"</diagHeader></progressReport><progressReport><diagHeader>15621;reason="The specified mailbox is not enabled for Unified Messaging. User: j.doe@company.com. PrimarySmtpAddress: </progressReport></progressReports></error></reportError">j.doe@company.com.";source="lyncpoolfqdn.company.COM";dialplan="Hosted__exap.um.outlook.com__company.onmicrosoft.com";umserver="exap.um.outlook.com";responsecode="403";msexchsource="BY2PR01CA001.prod.exchangelabs.com";appName="ExumRouting"</diagHeader></progressReport></progressReports></error></reportError>

    Any ideas?  Thanks!

    Tuesday, February 11, 2014 5:49 PM

Answers

  • I opened a case with MS - Lync Online team.  After some fiddling, we looked at Directory Sync and determined that the attribute msExchUCVoiceMailSettings was synchronizing the wrong way (from the cloud to on-prem)!  Even though I didn't have a mailbox on EO it would always change the setting to msExchUCVoiceMailSettings=1.  This tells Lync that voicemail is hosted in the cloud which is wrong.  So I reversed the attribute flow so it sync'd from On-Prem to the cloud.  Granted this a temporary fix until we actually use EO but it's a good tip for those who might trial EO with a live account and have issues with voicemail when they migrate back to On-Prem.  Cheers.

    To change this setting,

    Open up C:\Program Files\Windows Azure Active Directory Sync\SYNCBUS\Synchronization Service\UIShell\miisclient (not the exe).

    Click on Management Agents and double click on Active Directory Connector.

    Select Configure Attribute Flow, expand Object Type:user

    Select the Data Source Attribute: msExchUCVoiceMailSettings (you'll see it's flowing FROM cloudMSExchUCVoiceMailSettings to msExchUCVoiceMailSettings)

    Take a screenshot so you can reverse the setting should you need to.

    Click the Import radio button and click Edit and then OK.

    • Marked as answer by Kyle M. Dixon Monday, April 28, 2014 6:38 PM
    Monday, April 28, 2014 6:38 PM

All replies

  • Figured it out!  My Lync user settings were showing HostedVoiceMail set to True.  I had to run the following to set it false (it wouldn't take the false config without setting it to null first).

    Set-CsUser j.doe -HostedVoiceMail $null
    Set-CsUser j.doe -HostedVoiceMail $false

    Then restarted my Lync client and phone and boom it works.
    • Marked as answer by Kyle M. Dixon Friday, February 28, 2014 6:59 PM
    • Unmarked as answer by Kyle M. Dixon Thursday, March 27, 2014 4:16 PM
    Friday, February 28, 2014 6:59 PM
  • Unfortunately the above fix only works for a short while until Lync reverts the HostedVoiceMail setting back to True.  Also using ADSI Edit to change msExchangeUCVoiceMailSettings = 1 to 0 does not keep.  I can't find where in Lync this setting keeps overriding but it's annoying as heck.
    Thursday, March 27, 2014 4:18 PM
  • May also want to delete your Lync profile(s) on your machine (may even whack the registry portions as well).

    Have you tried removing your account from Lync and adding it back in?

    You may have some data in your Exchange mailbox that is updating your AD account.

    Wednesday, April 16, 2014 3:41 PM
  • I've deleted my Lync profile and my Lync account, then readded my Lync account but no change in result.
    Wednesday, April 16, 2014 4:02 PM
  • I opened a case with MS - Lync Online team.  After some fiddling, we looked at Directory Sync and determined that the attribute msExchUCVoiceMailSettings was synchronizing the wrong way (from the cloud to on-prem)!  Even though I didn't have a mailbox on EO it would always change the setting to msExchUCVoiceMailSettings=1.  This tells Lync that voicemail is hosted in the cloud which is wrong.  So I reversed the attribute flow so it sync'd from On-Prem to the cloud.  Granted this a temporary fix until we actually use EO but it's a good tip for those who might trial EO with a live account and have issues with voicemail when they migrate back to On-Prem.  Cheers.

    To change this setting,

    Open up C:\Program Files\Windows Azure Active Directory Sync\SYNCBUS\Synchronization Service\UIShell\miisclient (not the exe).

    Click on Management Agents and double click on Active Directory Connector.

    Select Configure Attribute Flow, expand Object Type:user

    Select the Data Source Attribute: msExchUCVoiceMailSettings (you'll see it's flowing FROM cloudMSExchUCVoiceMailSettings to msExchUCVoiceMailSettings)

    Take a screenshot so you can reverse the setting should you need to.

    Click the Import radio button and click Edit and then OK.

    • Marked as answer by Kyle M. Dixon Monday, April 28, 2014 6:38 PM
    Monday, April 28, 2014 6:38 PM
  • Oh and you'll need to set the affected user's Lync attributes with:

    set-csuser j.doe -hostedvoicemail $null

    This will tell Lync that voicemail is not in the cloud.

    Monday, April 28, 2014 6:40 PM
  • I have the same issue as you described here but we are running Azure AD Connect Services 1.0.8 so instead of Managed Agents it has Connectors and doesn't show the same attribute flows as you have.  Do you know how to find this information with the new Sync Tool?

    DURP

    Tuesday, December 1, 2015 3:11 PM