locked
Prevent Taskbar stealing foucus RRS feed

  • Question

  • I am using Windows 7 on a HTPC style setup. When switching/launching between various apps in fullscreen with EventGhost sometimes the taskbar pops up and sits there with focus waiting on me to click the icon of teh new app that was just launched or switched to. How can I prevent this from happening? I don't need the taskbar telling me I switched/launched a new app.
    Friday, July 10, 2009 6:39 PM

Answers

  • Please try ShellExView.  

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Run ShellExView, in the pane sort the entries with manufacturers. Disable all non-Microsoft *.dll files, and check the result. If the issue does not occur, one of the files can be the culprit. We could narrow down it one by one.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, July 27, 2009 3:44 AM
    Wednesday, July 22, 2009 5:54 AM
  • May be incompatible add-ons would be active without any triggers.

     

    Additionally, does the issue occur with system build-in programs?

     

    You may also disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, July 27, 2009 3:44 AM
    Friday, July 24, 2009 9:57 AM

All replies

  • Is there any other process that launches automatically and make the taskbar on top? If so, you only need to disable the programs. Otherwise, if there is no background program pops up, the issue can be caused by the program EventGhost itself. In this case, we may need to wait for patches for the program, or wait for new versions. Meantime, we may set to auto hide the taskbar as workaround.
    Arthur Xie - MSFT
    Monday, July 13, 2009 9:48 AM
  • There is no other process launching and the taskbar is already set to auto hide. The problem is that the taskbar always wants to alert the user that a new program has been launched or wants attention. I don't need the taskbar telling me this.
    Monday, July 13, 2009 1:28 PM
  • Would you please capture screenshots when the issue occurs? Please submit the screenshots in SkyDrive of your Live Space.

     

    • Edited by Arthur Xie Tuesday, July 14, 2009 10:29 AM
    Tuesday, July 14, 2009 10:17 AM
  • Here is a screenshot.
    http://cid-99c726954d55730b.skydrive.live.com/self.aspx/.Public/EG.XBMC.jpg
    I pressed a button on my remote, which EventGhost receives and then launches XBMC. XBMC launches but then the taskbar insists to popup showing me XBMC has opened. You can see where the XBMC icon is highlighted.
    • Edited by kricker Friday, July 17, 2009 3:52 AM
    Friday, July 17, 2009 3:47 AM
  • This should be a software compatibility issue. It seems that XBMC is not compatible with the new feature Super Bar in Windows 7 RC.

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    You may need to wait for new updates for XBMC to resolve this issue.


    Arthur Xie - MSFT
    Monday, July 20, 2009 6:33 AM
  • I build XBMC regularly, it's not the issue. This taskbar thing also happens with SageTV, Firefox, etc.
    Monday, July 20, 2009 1:56 PM
  • Please try ShellExView.  

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Run ShellExView, in the pane sort the entries with manufacturers. Disable all non-Microsoft *.dll files, and check the result. If the issue does not occur, one of the files can be the culprit. We could narrow down it one by one.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, July 27, 2009 3:44 AM
    Wednesday, July 22, 2009 5:54 AM
  • Please try ShellExView .  

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Run ShellExView, in the pane sort the entries with manufacturers. Disable all non-Microsoft *.dll files, and check the result. If the issue does not occur, one of the files can be the culprit. We could narrow down it one by one.


    Arthur Xie - MSFT

    I don't understand. What would shell extension have to do with the taskbar showing up?
    Wednesday, July 22, 2009 1:57 PM
  • May be incompatible add-ons would be active without any triggers.

     

    Additionally, does the issue occur with system build-in programs?

     

    You may also disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, July 27, 2009 3:44 AM
    Friday, July 24, 2009 9:57 AM