locked
Problem Discovering Microsoft Windows Cluster Resource Group - Cluster Management Pack Version 10.0.6.0 RRS feed

  • Question

  • Hello!

    I'm using SCOM 2016 and I have some problems regarding discovering "Windows Server 2012 R2 Cluster Resource Group" of SQL clusters. The management pack version is 10.0.6.0

    With SCOM 2012 R2 I have this version of cluster management packs and i'm able to discover SQL resource groups perfectly fine. The management pack version is 6.0.7291.0 .

    Is there anyone here who experience the same problem with the new version of the management packs when trying discovering SQL resource groups or other resource groups?

    Summing it - with the new cluster management pack version I experience a problem discovering some resource groups.

    Will appreciate any help regarding this issue.

    Thanks!

    -Alon


    • Edited by AlonTiv Wednesday, July 12, 2017 2:51 PM
    Wednesday, July 12, 2017 2:48 PM

All replies

  • Hi,

    But , "10.0.6.0" management pack is not applied to SCOM 2016 :

    https://www.microsoft.com/en-sg/download/details.aspx?id=2268

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 13, 2017 8:38 AM
  • Hi Alon,

    are you sure you are using the correct version of the MP. there are two MPs with this version:

    1. System Center Management Pack for Windows Server Cluster

    System Center Management Pack for Windows Server Cluster

    v. 10.0.6.0

    2. Microsoft System Center Management Pack for Windows Server Cluster 2016

    Microsoft System Center Management Pack for Windows Server Cluster 2016

    You need the 2nd one. If yiu are using the first one, remove it, uninstal it and get the new one and you will be fine.

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov


    Thursday, July 13, 2017 8:45 AM
  • Hi Stoyan,

    I am using the 2nd one. The one who works with SCOM 2016.

    As I mentioned at my question, i'm having problems discovering only SQL clusters resource groups of Windows 2012 R2 but the rest works just fine. By the way the version of both MP's is 10.0.6.0. It's the version of the MP that's supports SCOM 2016.

    What i'm trying to say is that It's only some resource groups of windows server 2012 r2 that i'm experiencing problems with and with all of them.

    Is the MP " Microsoft System Center Management Pack for Windows Server Cluster 2016" is having problems with discovering Windows Server Cluster 2012 R2?

    Thanks!

    - Alon

    Thursday, July 13, 2017 2:09 PM
  • Hi Alon,

    I will start from the bottom:

    "Is the MP " Microsoft System Center Management Pack for Windows Server Cluster 2016" is having problems with discovering Windows Server Cluster 2012 R2?" - No, this should not be the case. The documentation clearly states:

    "

    This management pack requires System Center 2012 Operations Manager or later.

    The Windows Server Failover Cluster Management Pack for System Center 2012 Operations Manager supports failover clusters on the following configurations: 

    • Windows Server 2003 operating systems with Service Pack 2 (SP2), Windows Server 2003 R2 operating systems with Service Pack 2 (SP2) on 32-bit and 64-bit servers.
    • Windows Server 2008 Enterprise, Windows Server 2008 R2 Enterprise, Windows Server 2008 Datacenter, and Windows Server 2008 R2 Datacenter operating systems on 32-bit and 64-bit servers.
    • Windows Server 2012 and Windows Server 2012 R2 all editions.
    • Windows Server 2016 all editions."

    I am not quite sure I understand what you mean with:

    "What i'm trying to say is that It's only some resource groups of windows server 2012 r2 that i'm experiencing problems with and with all of them."  IF you mean you have the issue with only SOME resource groups and NOT with all, then some troubleshooting will be needed. 

    Can you please make sure your discovery has no overrides apllied?

    Please check also on your management servers if there are any events in the OperationsManager event log, which are related to the discovery. 

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    • Proposed as answer by Elton_Ji Sunday, August 13, 2017 3:16 PM
    Friday, July 14, 2017 11:29 AM