none
The user does not exist or is not unique - workflow problem RRS feed

  • General discussion

  • I am using Solution Starters Dynamic Management workflow on my Project Server 2010.  I was working fine for a year now, but today all workflows were broken when someone tried to submit them to a next stage. "Workflow terminated. An error has occurred in the workflow."

    I tried debbuging the workflow and it seems to be OK, but the problem appears when it needs to assign tasks to the approvers (they are in the Approvers group). When I remove users from the group that represents approvers (and leave that group empty), it works fine, so I am guessing that users (who need to approve the stage) are the problem. My administrators are saying that there were no updates or changes on AD machine.

    I don't have problem with users in any of people picker fields or anywhere else on the site. I am using claims auth.

    What could be the reason for this behavior??

    These are main errors from the log:

    Failed to persist workflow instance: 7dc2e035-cd02-4284-b851-a829e372a809 with error code: 5, instance data size: 29578, internal state: Running, processing id: 1e2211d2-ef7b-4416-90ef-ac041396c200    2f83db27-34da-4275-a42e-0625240af921

    The user does not exist or is not unique.

    WinWF Internal Error, terminating workflow Id# 7dc2e035-cd02-4284-b851-a829e372a809   

    System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.  Parameter name: additionalNodes     at Microsoft.Office.Workflow.Actions.OfficeTask.ProcessTaskError(Object sender, EventArgs e)     at System.Workflow.ComponentModel.ActivityExecutorDelegateInfo`1.ActivityExecutorDelegateOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.Runtime.Scheduler.Run()

      



    • Edited by SPManiac Thursday, March 27, 2014 11:18 PM
    Thursday, March 27, 2014 11:03 PM

All replies

  • It appears that this isn't the problem with users, but it is a problem with Office Tasks. This is the main error in ULS logs (same as in the previous post):

    "Specified argument was out of the range of valid values.  Parameter name: additionalNodes"

    I noticed that all content types are gone from my pwa site. Is it possible that my workflow is causing problems when adding tasks because somebody deleted all content types??



    • Edited by SPManiac Saturday, March 29, 2014 7:07 PM
    Saturday, March 29, 2014 7:01 PM
  • Ok, I'll answer my own question; Yes, deleted Content Types are the problem!
    Sunday, March 30, 2014 11:53 AM