none
hyper-v server 2012 (VM) : Configuration and joining a domain in windows server 2012 RRS feed

  • Question

  • Hi

    I need some help please

    I have installed hyper-v core server 2012 that is in a workgroup

    I have create a new virtual machine with windows server 2012

    withing windows server 2012 i add the roles : DHCP, AD DS, DNS 

    my server 2012 use a static ip adress 

    my client is win  7 pro and it's in workgroup 

    I manage to connect to my hyper v and to my Virtual machine ( win server 2012)

    I want to create a domain controler so i can join the domain in win server 2012 from my client.

    after adding the role in win server 2012 i create a domaine name: test.local

    in my client I m trying to add the domaine in system properties i am entering in domain test.local

    im receiving the error :

    An Active Directory Domain Controller (AD DC) for the domain <target DNS domain name> could not be contacted

    Ensure that the domain name is typed correctly

    I 'am connecting to the server with a wifi access.

    and for my preferred dns I put the same ip adress as the static ip 

    can someone please help?should i switch into wired instead of wireless?

    is my configuration right?

    thanks for your advice

    Monday, November 18, 2013 3:40 PM

Answers

All replies

  • ok i am replying to myself:)

    I did change from wifi to wired, it works

    also i used the same prerered dns adress on client and server.

    when trying to join the domain it's asked me the usernam and password 

    the join the host on the domain

    but the host is the hyper-v and it's not on a domain but on a workgroup

    so now everytime i want to loging to my virtual machine it's asks me 

    username and password?

    why it's asking me the host username and password when it's not on a domain?

    do i have to log on the host first before accessing the VM?

    host = worgrkoug

    VM= domain

    thanks


    • Edited by test12test Monday, November 18, 2013 5:31 PM
    Monday, November 18, 2013 4:09 PM
  • I'm not sure I am following your problem description.

    You have a Hyper-V host that is in a workgroup.  You have a VM running on the Hyper-V host, and on the VM you have created an Active Directory Domain Controller.  You joined your laptop running Windows 7 to the AD domain.

    Beyond that, I'm getting confused.  You will always need to provide username/password to get into any system, whether physical or virtual.  If you enable Remote Desktop, you can get directly to a VM without the need to first connect to they Hyper-V host.  The fact that the VM is running in a different domain than the host should not make any difference to how a machine is accessed.


    .:|:.:|:. tim

    Monday, November 18, 2013 5:52 PM
  • hi

    that right , i know i should provide username and pass

    but before activating the domain on my VMserver 2012 it's never asked me the host user and pass

    but when  I joined the domain on the VM from my client it start asking me the host user/pass to be able to access the vm(domain)

    is that normal?

    Tuesday, November 19, 2013 3:01 PM
  • Hi hkahil,

    I am not sure this is the correct answer.

    According to your description , your problem is that before the client joined into the domain there is no user/pass prompt , is that right ?

    If this is the case , you can seclect "other user" then type "user" as  

    'your computer name(not include domain name)'\'your user account'

    Hope this helps

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Tuesday, November 26, 2013 10:02 AM
    Moderator
  • In this type of configuration…….

    Could the Hyper-V Server core (which is in WORKGROUP) joining the domain test.local?

    Note that the domain Will not be available until the virtual machine is running

    Thanks,

    Wednesday, August 22, 2018 9:04 PM