locked
Windows 7 Explorer in list view moves coloumns of folders to left when you double click folder to open it RRS feed

  • Question

  • Example I am looking at a full window of folders with five coloumns of folders. If I double click on a folder in any coloumn except the far left coloumn, all of the coloumns move to the left by one coloumn space. Reseting file and view settings does not fix the problem. I have seen this on Windows 7 Ultimate, Windows 7 Professional, and Windows 7 Enterprise. It does not matter if it is on a domain or not or if a group policy is setting the home page.

    This means I have to click twice as many times to open a folder in list view and that is the view I really want to use. Clicking twice as many times is also not good for carpel tunnel. This happens on my home and work computers and I have seen it on other Windows 7 computers. Neither does the reg hack for MIUs or something similiar to that.

    Tuesday, April 5, 2011 4:46 PM

Answers

  • Hi,

     

    That’s a by design feature, but you can apply view settings to all folders of the same type. Here are the detailed steps:

     

    1. Open a folder and make changes as you like.

    2. Press Alt to display the menu bar. Click Tools -> Folder options.

    3. Click View tab.

    4. Press the "Apply to folders" button.

    5. Click Apply and click OK.

     

    Note: The "Apply to folders" settings apply the current view setting to all folders that are optimized for the same content as the folder you have open. This setting will not apply to the folders which is not the same type.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Tuesday, April 19, 2011 8:02 AM
    Thursday, April 7, 2011 9:29 AM

All replies

  • Hi,

     

    That’s a by design feature, but you can apply view settings to all folders of the same type. Here are the detailed steps:

     

    1. Open a folder and make changes as you like.

    2. Press Alt to display the menu bar. Click Tools -> Folder options.

    3. Click View tab.

    4. Press the "Apply to folders" button.

    5. Click Apply and click OK.

     

    Note: The "Apply to folders" settings apply the current view setting to all folders that are optimized for the same content as the folder you have open. This setting will not apply to the folders which is not the same type.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Tuesday, April 19, 2011 8:02 AM
    Thursday, April 7, 2011 9:29 AM
  • This "answer" doesn't actually answer the question or provide a solution.  The problem Cary has, and that I see also, is one of Windows 7 shifting columns underneath the users actions when in List View.

    The problem is that if *any* part of the file/folder name in the column extends off the view in the window, clicking on an item in that column makes it the left most column in the pane.  This is very undesirable behavior when double-clicking on a file/folder that I want to open because Windows 7 takes the first click and moves the column to the left.  This renders my second click useless and is quite frustrating, because I then have to go double-click the file/folder AGAIN to open it.  I see no option in Windows 7 folder or view options to disable this behavior.

    • Proposed as answer by R Dumonceaux Monday, August 20, 2012 11:13 PM
    Monday, May 23, 2011 11:50 PM
  • This is a very annoying bug. I'm using the list view as standard for all folders. Has anyone found a solution for this?

     

    Saturday, August 6, 2011 5:26 PM
  • The only workaround I could find is to open Folder Options-> tick "Single-click".  I  didn't like the Single-click option before, but after working with it on for awhile, it is so much better than my folders jumping around. Hope this helps until they find a solution.
    Thursday, September 22, 2011 9:53 PM
  • How dare you, as a representative of Microsoft, offer such a lame evasion to a genuine OS shortcoming!

    Additionally, I have not been able to get your "apply to folders" solution to work for anything anyway. I have a large amount of video and audio all arranged in an intricate tree structure of folders. No matter how many times I correct the settings in any folder and "apply to folders", none of the others ever change. Are they somehow "not the same type"? If so, how would I make them the same type? They all contain music (or video). I end up changing every single folder manually.

    I want my XP back!

     

     

    Sunday, November 13, 2011 3:44 AM
  • Had the same problem that the guy you're answering for had. Fixed it right away. Cheers.
    Wednesday, March 28, 2012 9:06 AM
  • Leo's response is NOT HELPFUL in the LEAST.  I've been having the same ANNOYING issue (which was never an issue in a previous Windows version) and have found NO useful solution. To clarify, MICROSOFT: this is NOT an issue that can be resolved via Apply to folders - read the problem (and subsequent contributions) CAREFULLY, then respond - without some canned nonsensical 'solution' that doesn't solve anything.  PLEASE.
    Monday, August 20, 2012 10:55 PM
  • You're amazing djdevelop. Thanks for the useful info.  =(
    Monday, August 20, 2012 10:57 PM
  • Just went through all the related threads. There are better explanation's (but no solutions or admission of flaw) elsewhere than Leo's obtusely unaware nonanswer above, but switching to Single Click seems to be the only work around. Just have to get used to it until MS realizes that there is no practical purpose to moving something OUT of focused view with one click. We know there are more files in the folder. We can slide and wheel through column folder views, the OS does not need to resort what we've moused over. The flaw here is that there is no way to open a folder by double click because the first click moves the item. So if it isn't in the first column, even though we can clearly see the item we want to open, we need three clicks with refocusing the eyes and adjusting the mouse to between clicks one and two. Anyone who sorts through hundreds of folders on a regular basis will likely be familiar with this issue.
    Saturday, March 15, 2014 6:29 PM
  • Hi,

     

    That’s a by design feature, but you can apply view settings to all folders of the same type. Here are the detailed steps:

     

    1. Open a folder and make changes as you like.

    2. Press Alt to display the menu bar. Click Tools -> Folder options.

    3. Click View tab.

    4. Press the "Apply to folders" button.

    5. Click Apply and click OK.

     

    Note: The "Apply to folders" settings apply the current view setting to all folders that are optimized for the same content as the folder you have open. This setting will not apply to the folders which is not the same type.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    genuine worthless garbage.
    Wednesday, October 15, 2014 8:49 AM
  • I find more often than not, when Microsoft responds to an issue, their answer has absolutely nothing to do with the question.   Doesn't Microsoft hire people who have any kind of reading comprehension?    Are these people lazy or just stupid?
    Wednesday, September 16, 2015 5:58 PM

  • I found a solution to the OP's question (It works for windows 10 also), I've had this same quirk for years and finally got tired of it today which brought me here. 

    Download "ultimate windows tweaker" and disable the "full row select" item feature which is under

    "customization --> file explorer" It works like a charm so do check it out! 

    (be sure to read the ReadMe.txt file which comes with the application)

    Below is a link to the original discussion I hope this helps anyone having this issue in the future.

    https://www.sevenforums.com/general-discussion/344317-jumping-files-folders-2.html?s=23325e2995cf418f216cd266af6dd40f


    • Edited by on-3 Saturday, February 25, 2017 4:58 PM
    Saturday, February 25, 2017 4:57 PM
  • Download "ultimate windows tweaker" and disable the "full row select" item feature which is under

    "customization --> file explorer" It works like a charm so do check it out! 

    Saturday, February 25, 2017 5:00 PM