locked
Install-ContainerHost.ps1 script failing at Containerimage RRS feed

  • Question

  • Just installed Tp5 Datacenter gui version.  Trying to get started with containers via the blog here:  https://blogs.msdn.microsoft.com/jcorioland/2016/04/28/getting-started-with-containers-and-docker-on-windows-server-2016-technical-preview-5/

    I was able to download the Install-ContainerHost.ps1 script and when I ran it, it did it's thing and then rebooted and continued running.  However the script failed.  Here's the PS output:

    Extracting NSSM from archive
    Configuring NSSM for Docker service
    Starting docker
    Waiting for Docker daemon
    Successfully connected to Docker Daemon
    Following Images are present on this machine (none)
    Installing ContainerImage provider

    WARNING: Package 'ContainerImage' failed to download
    Install-PackageProvider : Package 'ContainerImage' failed to install.
    At C:\work\Install-ContainerHost.ps1:796 char: 9
    Install-PackageProvider ContainerImage -Force | Out-Null

    Tried to manually run that command.  Failed.  Also tried to manually run Install-Module containerimage and it failed.

    Get-psrepository is PSGallery
    Find-module containerimage - Containerimage v .6.4.0

    Any ideas?

    Wednesday, May 11, 2016 3:25 PM

Answers

  • Hi,

    Thanks for the post, what about trying with below command?

    Install-PackageProvider -Name "ContainerImage" -Force | Out-Null

    Also you can check the below article for some reference:

    https://technet.microsoft.com/en-us/library/mt676543.aspx?f=255&MSPPError=-2147217396

    Hope it helps.

    Best Regards,

    Elaine


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Elaine Jing Wednesday, June 1, 2016 7:42 AM
    Thursday, May 12, 2016 7:08 AM