locked
SharePoint 2016 - Icons Not Displayed - Untrusted Fonts RRS feed

  • Question

  • Hello,

    So we have begun the process of getting our 2016 environment created and have encountered an issue in regards to certain ICONS not being displayed in IE11.

    Firstly, I am aware that the GPO that is being forced down on us from higher is the issue, but this GPO cannot be removed and so we are looking for a work around.

    On Page Load for a Site Collections Home Page the console reads:

    ....................................................
    CSS3111: @font-face encountered unknown error.
    shellicons.eot

    CSS3111: @font-face encountered unknown error.
    shellicons.woff

    CSS3114: @font-face failed OpenType embedding permission check. Permission must be Installable.
    shellicons.ttf
    ....................................................

    My research has led me to believe that this could be avoided if I was able to find the fonts that SharePoint is trying to have my system download and install them onto the systems we are using.  Is that true and if so, how would I go about obtaining the fronts that SharePoint is referencing?

    Thank you

    Tuesday, August 8, 2017 6:44 PM

Answers

  • Hi,

    As I understand, Microsoft is removing the recommendation to enable the “Untrusted Font Blocking”

    Try to drop the Untrusted Font Setting in Group Policy and make it work for SharePoint font and icon, locate the settings:

    Group Policy setting in Computer Configuration | Administrative Templates | System | Mitigation Options

    More information in MSDN blog:

    Dropping the “Untrusted Font Blocking” setting

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, August 17, 2017 2:15 AM
  • Yeah, so after much research, trial and failure, I have came to a decision.  As long as you have the Untrusted Font Blocking Feature enabled, there is no way to make SharePoint 2016 display these icons. You will read that if you install the fonts in windows\fonts it will work.  You will have been lied to, lol.

    Believe me when I say that I have already installed shellicons, office365icons, literally every font from: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\LAYOUTS\Fonts.  Internet Explorer doesn't bother to check and see if there is a .ttf that is equivalent to the .eot.  It just blocks it and attempts to use defaults to render and they can't.

    So it came down to either disabling the Untrusted Font Blocking Feature, which was being pushed by a CATII GPO from my Higher (drama) or adding an application exception.  But the Application in question is frakkin Internet Explorer and so was essentially the same thing as disabling the Feature, lol

    However with all that said, for the sake of those that found this via Google, looking for an answer... Windows 10 comes with Microsoft Edge installed by default.  Edge has no issue displaying these images.  My guess is that either Microsoft didn't bother fixing this because it works in Edge and Edge is in Windows 10.  Or they purposefully didn't fix this because they want us to use Edge (they've done stuff like that before).  Either way, I'm simply going to put out a memo that tells the CMD to use Edge for the Internal Portal and get back to work on development.  For those that are being forced to keep looking by their Higher.  I finally came to this decision when I read what is the official Microsoft Stand Point on this known issue:

    https://support.microsoft.com/en-hk/help/3175070/office-365-app-launcher-and-menu-bar-icons-are-blank

    lol

    Thanks,




    Thursday, August 17, 2017 6:41 PM

All replies

  • Hi Vincent,

    SharePoint will place font and icon file in this file location:

    C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\LAYOUTS\Fonts

    For this issue, I suggest you can check in this folder, if the system font icon file existed, in my SharePoint 2016 environment:

    If these file were lost, you can copy form another environment to this folder to check if it resolved this issue.

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, August 9, 2017 8:54 AM
  • Thank you,

    The grander issue is IE11 denying the download of fonts presented by SharePoint.  Even with the SharePoint fonts physically sitting on your system.  IE is still denying the send from SharePoint and doesn't both to check for them on the computer (even with the exact same name).

    I'll keep digging around and appreciate the locations.  I'll let the thread know if I am able to resolve short of removing the GPO that is forcing IE11 to deny font download.

    Wednesday, August 9, 2017 8:03 PM
  • Hi,

    In my environment, I checked the IE11 F12 console, there is no such error message about font issue, I suggest you can try to access the SharePoint site home page with other browsers, see if this issue still exists.

    And make sure the font file is available on the local path.

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, August 10, 2017 4:41 AM
  • Thanks,

    As stated in my thread, this is happening because of a GPO that is being forced down on IE11 when running on Windows 10 machines.  This does not happen in other browsers.  However, I work for the California Military Department and we use specific systems, specific computer base line images, network enforced GPOs, etc...

    Essentially every one is going to be what I'm using now and what I'm using now aint workin.. lol

    Also, I have already navigated to: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\LAYOUTS\Fonts, grabbed the shellicons font files and installed the shellicons.ttf on my system.  Same results.

    The only possible work around I can think of would be to force .jpg or .png images in place of the font created icons.  But I have 0 idea how to do that.





    Thursday, August 10, 2017 1:32 PM
  • Hi,

    As I understand, Microsoft is removing the recommendation to enable the “Untrusted Font Blocking”

    Try to drop the Untrusted Font Setting in Group Policy and make it work for SharePoint font and icon, locate the settings:

    Group Policy setting in Computer Configuration | Administrative Templates | System | Mitigation Options

    More information in MSDN blog:

    Dropping the “Untrusted Font Blocking” setting

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, August 17, 2017 2:15 AM
  • Yeah, so after much research, trial and failure, I have came to a decision.  As long as you have the Untrusted Font Blocking Feature enabled, there is no way to make SharePoint 2016 display these icons. You will read that if you install the fonts in windows\fonts it will work.  You will have been lied to, lol.

    Believe me when I say that I have already installed shellicons, office365icons, literally every font from: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\LAYOUTS\Fonts.  Internet Explorer doesn't bother to check and see if there is a .ttf that is equivalent to the .eot.  It just blocks it and attempts to use defaults to render and they can't.

    So it came down to either disabling the Untrusted Font Blocking Feature, which was being pushed by a CATII GPO from my Higher (drama) or adding an application exception.  But the Application in question is frakkin Internet Explorer and so was essentially the same thing as disabling the Feature, lol

    However with all that said, for the sake of those that found this via Google, looking for an answer... Windows 10 comes with Microsoft Edge installed by default.  Edge has no issue displaying these images.  My guess is that either Microsoft didn't bother fixing this because it works in Edge and Edge is in Windows 10.  Or they purposefully didn't fix this because they want us to use Edge (they've done stuff like that before).  Either way, I'm simply going to put out a memo that tells the CMD to use Edge for the Internal Portal and get back to work on development.  For those that are being forced to keep looking by their Higher.  I finally came to this decision when I read what is the official Microsoft Stand Point on this known issue:

    https://support.microsoft.com/en-hk/help/3175070/office-365-app-launcher-and-menu-bar-icons-are-blank

    lol

    Thanks,




    Thursday, August 17, 2017 6:41 PM