none
Metadata Fields not saving from "Edit Properties" Form in sharepoint 2016 + Deleting existing properties. RRS feed

  • Question

  • Hi All,

    We are facing this below issue on our Dev/Test/Production servers from last couple of days.

    While updating managed metadata properties for Documents using Edit Properties Form, We are able to select the managed metadata property but when we click on save button properties are not getting saved and also deleting the existing properties like date,people picker fields.

    We haven't found any specific error related to managed metadata service even in Verbose ULS logs.

    Steps Performed:

    1. Managed metadata service restarted on all the servers.

    2. Farm account has necessary permissions on Managed metadata service.

    3. Remapped the managed metadata properties.

    Thanks in advance.

    Monday, July 22, 2019 1:32 PM

All replies

  • Hi Rajendar, 

    I have done a test in my SharePoint 2016 and i cannot reproduce your issue. 

    What is the build number of your SharePoint farm? the build number of my farm is 16.0.4834.1000. 

    Whether the issue exists in other libraries of the same site. Try to create a new new library and compare whether the issue exists in new library. 

    Whether the issue exists in other libraries of the different site. Try to create a new new library in other site and compare whether the issue exists in new library. 

    Is there some workflow flow which update clear the values of the columns?

    Have you modified the managed metadata column from EditForm.aspx page or from office client? Earlier version of office might not support to save managed metadata column.

    Refer to the following article:

    http://blog-sharepoint.blogspot.com/2010/08/metadata-not-saving-after-editing.html

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, July 23, 2019 3:24 AM
    Moderator
  • Hi Lisa,

    Thanks for the reply.

    The build number for our Farm is 16.0.4771.1000

    We are using documents as templates and these managed metadata columns are parts of different document templates.

    We test the issue for new created document libraries but the meta data are getting saved there. While issue is for existing document libraries of different site collection in the farm.

    There is one custom workflow that gets triggered manually and its not changing the any property of the document.

    We are trying to modify the property using the EditForm.aspx page as from office client we are facing Currently Unavailable error for User and group column so the document is not getting saved with office client.

    Thanks and Regards,

    Rajendar Singh

    Tuesday, July 23, 2019 8:51 AM
  • Hi Rajendar, 

    Can you modify the property using the EditForm.aspx page ?

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, July 24, 2019 9:08 AM
    Moderator
  • Hi Lisa,

    For old documents i cant but for new documents i can.

    Thanks and regards,

    Rajendar Singh

    Wednesday, July 24, 2019 12:55 PM
  • Hi Rajendar, 

    Have you migrated the farm? 

    How many documents are affected?

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, July 29, 2019 8:04 AM
    Moderator
  • I want to echo the have you migrated anything? I've had this issue in the past, and I am trying to remember what it was exactly. But I recall there was an issue when someone decided to mess about with the Managed Metadata service.

    If this is helpful please mark it so. Also if this solved your problem mark as answer.

    Tuesday, July 30, 2019 7:47 AM
    Moderator