none
finding out why an email was not delivered

    Question

  • I have an Exchange 2010 SP2 server receiving emails but some emails are not getting to my inbox.  In the EMC I run :

    Get-Exchangeserver | where {$_.isHubTransportServer -eq $true -or $_.isMailboxServer -eq $true} | Get-Messagetrackinglog -Start "5/9/2012 7:00 AM" -End "5/9/2012 5:00 PM" -EventId "Fail" -Recipients greg@mydomain.com | Select-Object Timestamp,Clienthostname,eventid,source,sender,@{Name="Recipients";Expression={$_.recipients}},Recipientcount,serverhostname,SourceContext

    I see:

    Timestamp      : 5/9/2012 10:52:03 AM
    ClientHostname : email
    EventId        : FAIL
    Source         : SMTP
    Sender         : ahi@checkout.info
    Recipients     : {user1@mydomain.com, greg@mydomain.com, user2@mydomain.com}
    RecipientCount : 3
    ServerHostname :
    SourceContext  : Content Filter Agent

    Timestamp      : 5/9/2012 11:28:48 AM
    ClientHostname : email
    EventId        : FAIL
    Source         : SMTP
    Sender         : IntuitServiceNotice@intuit.com
    Recipients     : {user1@mydomain.com, greg@mydomain.com, user2@mydomain.com}RecipientCount : 3
    ServerHostname :
    SourceContext  : Sender Id Agent

    Timestamp      : 5/9/2012 12:05:10 PM
    ClientHostname : email
    EventId        : FAIL
    Source         : SMTP
    Sender         : QuickBooks_CustomerService@intuit.com
    Recipients     : {user1@mydomain.com, greg@mydomain.com, user2@mydomain.com}RecipientCount : 3
    ServerHostname :
    SourceContext  : Sender Id Agent

    Timestamp      : 5/9/2012 12:05:32 PM
    ClientHostname : email
    EventId        : FAIL
    Source         : SMTP
    Sender         : QuickBooks_CustomerService@intuit.com
    Recipients     : {user1@mydomain.com, greg@mydomain.com, user2@mydomain.com}RecipientCount : 3
    ServerHostname :
    SourceContext  : Sender Id Agent

    Timestamp      : 5/9/2012 12:09:09 PM
    ClientHostname : email
    EventId        : FAIL
    Source         : SMTP
    Sender         : QuickBooks_CustomerService@intuit.com
    Recipients     : {user1@mydomain.com, greg@mydomain.com, user2@mydomain.com}RecipientCount : 3
    ServerHostname :
    SourceContext  : Sender Id Agent

    I check the smtpreceive logs in:

    C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\Logs\ProtocolLog\SmtpReceive\RECV20120509-1.log

    and the messages say queued mail for delivery but they are not delivered.  I just turned on Quarantine messages with SCL rating greather than or equal to 6 so at least when this happens in the future the email should be in the mailbox I designated.  In case you are wondering the message is addressed to a distrubition group.

    So where did these emails go?  Why does the smtpreceive log say queued for delivery but the EMC command says FAILED?

    Thanks,

    Wednesday, May 09, 2012 7:53 PM

Answers

  • Per your message tracking its failing due to the sender id checking, whitelist the domain.

    http://technet.microsoft.com/en-us/library/aa998859.aspx

    Set-SenderIdConfig

    The BypassedSenderDomains parameter specifies one or more domain names. Messages that originate from the domains listed in this parameter are excluded from processing by the Sender ID agent. To enter multiple domains, separate the domains by using a comma and enclose the addresses in quotation marks ("), for example: "contoso.com, fabrikam.com"


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Marked as answer by Greg_33 Friday, May 11, 2012 7:08 PM
    Friday, May 11, 2012 6:03 PM

All replies

  • hi,

    If these mails has been routed to your exchange server, and finally they can't been route to mailbox successful. I think these messages will stay at undelivery queue. So you first should check the queue. You can use the queue viewer to check.

    Smtp log record the connect state between server and server, message tracking log record the process of mail delivery in the internal server. So they are not the same.

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    Thursday, May 10, 2012 8:15 AM
  • Run a www.dnsstuff.com report for the e-mail/domain. The could be many reasons such as server down, closed port 25, non-existing e-mail or alias.
    Thursday, May 10, 2012 12:51 PM
  • So some e-mails get delivered correctly while others do not?
    Thursday, May 10, 2012 7:46 PM
  • Most emails do get delivered.  However we are having difficultiy receiving emails from intuit.com.  As you can see the email gets to the server.  However when I run:

    Get-Exchangeserver | where {$_.isHubTransportServer -eq $true -or $_.isMailboxServer -eq $true} | Get-Messagetrackinglog -Start "5/9/2012 7:00 AM" -End "5/9/2012 5:00 PM" -EventId "Fail" -Recipientsgreg@mydomain.com | Select-Object Timestamp,Clienthostname,eventid,source,sender,@{Name="Recipients";Expression={$_.recipients}},Recipientcount,serverhostname,SourceContext

    The messages show as FAILED.  I can not find why they failed.

    Thursday, May 10, 2012 10:36 PM
  • hi,

    In the EMC->tool mailbox->message tracking

    open it and go to options, see all option->mail control-?delivery report. Try to find Why your mail delivery failure?

    hope can help you

    thanks,


    CastinLu

    TechNet Community Support

    Friday, May 11, 2012 6:37 AM
  • Per your message tracking its failing due to the sender id checking, whitelist the domain.

    http://technet.microsoft.com/en-us/library/aa998859.aspx

    Set-SenderIdConfig

    The BypassedSenderDomains parameter specifies one or more domain names. Messages that originate from the domains listed in this parameter are excluded from processing by the Sender ID agent. To enter multiple domains, separate the domains by using a comma and enclose the addresses in quotation marks ("), for example: "contoso.com, fabrikam.com"


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Marked as answer by Greg_33 Friday, May 11, 2012 7:08 PM
    Friday, May 11, 2012 6:03 PM
  • It was right in front of me.  Oh well.

    Thank you for your help.  

    Friday, May 11, 2012 7:08 PM
  • You blocked intuit.com?
    Friday, May 11, 2012 8:31 PM
  • Greg_33,

                 I'm curious at to what the problem was. Thanks.

    Monday, May 14, 2012 3:17 PM