locked
Is there any way to exclude bare linefeed messages from a send connector? RRS feed

  • Question

  • We have an Exch2010 system and we are using Barracuda Message Archiver to archive via journaling.  We noticed every now and then a slowdown/backup at the queues on the Exchange box.  After some testing I have found that when I send a message to yahoo.com that is rejected for bad address, size etc. it sends back an NDR that has a bare linefeed.  I get the bounceback in my email, but it never makes it out of the exchange send connector for the journaling because Barracuda is built to the Internet RFC which this is a violation of.  I don't have this problem with bounces coming from gmail and others so it has to do with yahoo.  They are obviously responding in a way that results in bare line feeds.  Since they won't change based on making my life easier, :-)  I looked into Microsoft documentation and see that I can reject at the recieve connector, but I assume that means I would never know my email didn't get delivered.  I would much rather stop these from trying to go out the send connector dedicated to the Barracuda.  Any ideas on making that happen?  Thanks for your help. 

    Thursday, March 8, 2012 5:32 PM

Answers

  • On Thu, 8 Mar 2012 17:32:07 +0000, OTS Tech wrote:
     
    >We have an Exch2010 system and we are using Barracuda Message Archiver to archive via journaling. We noticed every now and then a slowdown/backup at the queues on the Exchange box. After some testing I have found that when I send a message to yahoo.com that is rejected for bad address, size etc. it sends back an NDR that has a bare linefeed. I get the bounceback in my email, but it never makes it out of the exchange send connector for the journaling because Barracuda is built to the Internet RFC which this is a violation of. I don't have this problem with bounces coming from gmail and others so it has to do with yahoo. They are obviously responding in a way that results in bare line feeds. Since they won't change based on making my life easier, :-) I looked into Microsoft documentation and see that I can reject at the recieve connector, but I assume that means I would never know my email didn't get delivered. I would much rather stop these from trying to go out the send
    >connector dedicated to the Barracuda. Any ideas on making that happen? Thanks for your help.
     
    Use the set-receiveconnector with the parameter
    -BareLinefeedRejectionEnabled:$true
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, March 9, 2012 1:49 AM

All replies

  • On Thu, 8 Mar 2012 17:32:07 +0000, OTS Tech wrote:
     
    >We have an Exch2010 system and we are using Barracuda Message Archiver to archive via journaling. We noticed every now and then a slowdown/backup at the queues on the Exchange box. After some testing I have found that when I send a message to yahoo.com that is rejected for bad address, size etc. it sends back an NDR that has a bare linefeed. I get the bounceback in my email, but it never makes it out of the exchange send connector for the journaling because Barracuda is built to the Internet RFC which this is a violation of. I don't have this problem with bounces coming from gmail and others so it has to do with yahoo. They are obviously responding in a way that results in bare line feeds. Since they won't change based on making my life easier, :-) I looked into Microsoft documentation and see that I can reject at the recieve connector, but I assume that means I would never know my email didn't get delivered. I would much rather stop these from trying to go out the send
    >connector dedicated to the Barracuda. Any ideas on making that happen? Thanks for your help.
     
    Use the set-receiveconnector with the parameter
    -BareLinefeedRejectionEnabled:$true
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Friday, March 9, 2012 1:49 AM
  • Hi OTS Tech

    Did you try the command that Rich provided.

    "The BareLineFeedRejectionEnabled parameter specifies whether this Receive connector rejects messages that contain bare line feed (LF) characters in the SMTP DATA stream. "

    And for more detail about Set-ReceiveConnector, please refer to

    http://technet.microsoft.com/en-us/library/bb125140.aspx 

    Cheers

    Zi Feng


    Zi Feng

    TechNet Community Support


    Monday, March 12, 2012 2:45 AM
    Moderator
  • I saw that but didn't want to try it until the work week when I can better track it.  I do have one bit of info that I was hoping to get clarified.  Our email comes in through a Microsoft SMTP server that is about 4 years old.  This dates to before we had Exchange.  Is this bare line feed NDR being caused by that server since it is the last server before the email leaves for (in this case) a bad address?  I would think that if it was the server generating the BLF, it would do it on other bad addresses such as those goign to gmail.com.  I just want to be sure it is yahoo that is not adhering to the RFC and not one of my servers which I can do something about.  Thanks for your help.
    Monday, March 12, 2012 3:12 PM
  • I have set BareLinefeedRejection:$true on all three of my receive connectors.  I still get a bare linefeed for an ndr when I send to yahoo with an incorrect name.  How could this be happening?  Are there settings that allow incoming mail servers to ignore this setting?  Could the Exchange server be generating it and if so, how do I turn it off?  Other than archiving, things are going well, this is just the last bit of the exchange mgration and it is really frustrating.  Thanks for your help!
    Monday, March 26, 2012 3:57 PM
  • I have set BareLinefeedRejection:$true on all three of my receive connectors.  I still get a bare linefeed for an ndr when I send to yahoo with an incorrect name.  How could this be happening?  Are there settings that allow incoming mail servers to ignore this setting?  Could the Exchange server be generating it and if so, how do I turn it off?  Other than archiving, things are going well, this is just the last bit of the exchange mgration and it is really frustrating.  Thanks for your help!
    Monday, March 26, 2012 3:57 PM
  • Has this issue been resolved?  I have the exact same problem. Currently on Exchange 2010 SP3.
    Tuesday, April 2, 2013 4:59 PM