locked
Windows 7 64bit PRO stopped sleeping recently RRS feed

  • Question

  • About 4 or 5 weeks ago my computer stopped going into sleep mode. The monitor would go off but all else was still going.

    From memory it was following a large update from MS, including a Video Card driver update.

    There have been no hardware or software changes.

    I've run "powercfg /requests" and got the following.

     

    C:\Windows\system32>powercfg /requests

    DISPLAY:

    None.

    SYSTEM:

    [DRIVER] High Definition Audio Device <HDAUDIO\FUNC_01&VEN_10EC$DEV_0892&SUBSYS_1458A102&REV_1003\4&174ede36&0&0001>

    An audio stream is currently in use.

    AWAYMODE:

    None.

    How do I disable it?

     

    Monday, July 18, 2011 4:49 AM

Answers

  • You can use the powerconfig command to override the request. Check out this article for more info...

     

    http://uclue.com/?xq=3587

     

    In your case, I think entring the following command at a command prompt will do the trick...

     

    powercfg -REQUESTSOVERIDE DRIVER "High Definition Audio Device" SYSTEM

    -josh

     

     

    • Proposed as answer by bigjoshlevine Wednesday, July 20, 2011 1:24 AM
    • Marked as answer by thebiker41 Wednesday, July 20, 2011 1:41 AM
    Wednesday, July 20, 2011 1:24 AM

All replies

  • Hi Thebiker41, you said..

    An audio stream is currently in use.    How do I disable it?

     

    The only thing I can suggest is in power settings - advanced settings - and under multimedia settings - perhaps change 'prevent idling to sleep' to 'Allow computer to sleep'

    There's other Sleep settings there you could re-check too.

     

    All the best with it. pkn2011

    Monday, July 18, 2011 11:07 AM
  • Anyone ?

    I'm sure there is a powercfg request that will enable me to override whatever the on-board sound is doing to stop my computer from sleeping.

     

    Wednesday, July 20, 2011 1:13 AM
  • You can use the powerconfig command to override the request. Check out this article for more info...

     

    http://uclue.com/?xq=3587

     

    In your case, I think entring the following command at a command prompt will do the trick...

     

    powercfg -REQUESTSOVERIDE DRIVER "High Definition Audio Device" SYSTEM

    -josh

     

     

    • Proposed as answer by bigjoshlevine Wednesday, July 20, 2011 1:24 AM
    • Marked as answer by thebiker41 Wednesday, July 20, 2011 1:41 AM
    Wednesday, July 20, 2011 1:24 AM
  • I'm rather underwhelmed by the response from the MS gurus.

    After many hours googling I seem to have found a 'fix'.

    powercfg -requestsoverride DRIVER High Definition Audio Device SYSTEM

    System now sleeping at the pre-set time out.

     

    • Marked as answer by thebiker41 Wednesday, July 20, 2011 1:35 AM
    • Unmarked as answer by thebiker41 Wednesday, July 20, 2011 1:40 AM
    Wednesday, July 20, 2011 1:35 AM
  • Thanks Josh.

    Would you believe I'd just seen your post on uclue. Didn't realise you had responded here.

    I'll mark your post as the answer.

    Wednesday, July 20, 2011 1:40 AM
  • Hope this helps someone searching for a solution.

    I had the same issue of laptop not sleeping automatically.

    In addition, I also had the issue of speakers giving a "whistling" or "hissing" sound when volume was turned up above 35%.

    I went to the HP drivers downloads, and got their latest driver for IDT audio.

    After installing and rebooting, both the above problems got fixed.

    Saturday, March 28, 2015 8:22 PM