locked
Windows 7 Program Compatibility Wizard Troubleshooter crashing RRS feed

  • Question

  • Just upgraded from Vista and noticed problem with compatibility troubleshooter.  Generated the following error code:

    Package ID: PCWDiagnostic
    Path: C:\Windows\diagnostics\system\PCW
    Error code: 0x80131700
    Source: Engine
    User: XXXX/xxxxx
    Context: Restricted
    Sunday, October 25, 2009 1:38 AM

Answers

  • Hi  Anuj,

    Problem solved by upgrading to Net Framework 4.0 Beta !!!!!!!!!!!!!!!

    :)))))))))))))))))))
    • Marked as answer by satwar2 Friday, October 30, 2009 4:58 PM
    Friday, October 30, 2009 4:58 PM

All replies

  • Same here.  Let us know if you figure it out and I'll do the same
    Monday, October 26, 2009 2:02 AM
  • Hi satwar2,

    Thank you for your post.

     

    As per my understanding your problem is because of the installed .net framework 1.1. You can find solution for this issue in the following Microsoft KB article.

    http://support.microsoft.com/kb/922377

     

    Hope this helps.

    Thanks,

    Bineesh

     

     

    • Edited by Bineesh N Tuesday, October 27, 2009 6:10 AM
    • Proposed as answer by RobSchee Tuesday, October 27, 2009 3:02 PM
    Monday, October 26, 2009 5:49 PM
  • Hi Bineesh,
    Wow, is your response ever out in left field. :)

    Must have your posts mixed up.
    Monday, October 26, 2009 11:31 PM
  • Hi Satwar2,
                    
                    Basically "Error code:0x80131700" is generated due to the old version of .NET Framework installed on system. I tried using .NET Framework 1.1 and checked few applications using "Program Compatibility Wizard" on Win 7, but it was working fine for me. Wizard wasn't crashing at any stage and gave expected result.

    Can you specify, which .NET Framework installed on your system and details regarding the application or state at which wizard is crashing?

    Regards:
    Anuj Sharma
    Tuesday, October 27, 2009 7:07 AM
  • The trouble shooter crashes as soon as I use it.   How do I confirm what version I'm running ?  I don't know where to go.
    Tuesday, October 27, 2009 3:25 PM
  • Hi Satwar2,
                      Earlier it was possible to check what all environment are set for the machine by simply checking into control panel -> user account.
    Anyways, you can check for the version at : Start -> Control Panel -> Programs -> Programs and Features. Here you will find all the applications installed on your system. Check for the .NET Framework version, if it's not ".NET Compact Framework 3.5", then go to the link and install the same: http://www.microsoft.com/downloads/details.aspx?FamilyID=E3821449-3C6B-42F1-9FD9-0041345B3385&displaylang=en

    Hope this resolves the issue.


    Regards:
    Anuj Sharma

    Wednesday, October 28, 2009 2:50 AM
  • Hi Anuj,

    Well I finally found Net Framework hiding in "Turn Windows Features on or off" and supposedly 3.51 is installed and running.  Still no compatibility wizard on my 64 bit Windows 7 system however.
    Wednesday, October 28, 2009 6:58 PM
  • Hi Satwar2, 
                    
                  Try following steps to check your compatibility wizard:

    1) Goto: C:\Windows\diagnostics\system\PCW
    2) Double click on DiagPackage which is a Troubleshooting Pack type, that will open the Program Compatibility Wizard.
    3) Click next, it will start searching for all the installed applications on your system, select one from them or if it's not mentioned then click Not Listed then it will give you the browse option to find the application. Select your application and click next.
    4) Click on Try recommended settings.
    5) Click on Start the Program button, this will start your application, and click next.
    6) You may face the UAC prompt asking to allow the application (Hoping your application is from safe source), allow the same.
    7) If the application starts running, then click Yes, save these settings for this program otherwise try other options.

    Try out these steps to find out, if the wizard is working fine or not.
    Otherwise, check for the updates, as you upgraded from Vista to Win 7, so, may be you are missing any update. You can check update setting at Control Panel\System and Security\Windows Update\Change settings, under Important updates, select the Install updates automatically as this is recommended to better performance.

    Hope this resolves the issue.


    Regards:
    Anuj

    Thursday, October 29, 2009 7:22 AM
  • She crashes at the start of step 3, when I click the "next" button.  "An unexpected error has occurred", with error codes shown on first post.

    All Windows updates have been applied.

    The DiagPackage is dated 13/07/2009
    Friday, October 30, 2009 2:24 AM
  • Hi  Anuj,

    Problem solved by upgrading to Net Framework 4.0 Beta !!!!!!!!!!!!!!!

    :)))))))))))))))))))
    • Marked as answer by satwar2 Friday, October 30, 2009 4:58 PM
    Friday, October 30, 2009 4:58 PM
  • Hi Satwar2,
                     It's nice to hear that the problem is resolved after all. Thanks for sharing the information.



    Thanks & regards:
    Anuj Sharma
    Monday, November 2, 2009 8:01 AM
  • I have this same error message every time I run troubleshooting on Windows 7. And I have exactly the same symptoms when I try to follow Step 3, I just get the same blasted error code again.

    If I try to download .Net framework 3.5.1 SP, the first time installation fails and it tells me I must use add/remove programs to adjust the installed package.
    Then it offers to restart with settings 'compatible with my OS'. I choose OK, and it goes back to downloading installation components, then redownloads the .net framework bootstrap installer. Which then redownloads the install packages. And then when it runs I get....

    ====
    'Setup Error'
    ====
    OK
    ====
    Please wait while Setup is sending your feedback - grrr (with cancel button disabled). It feels a bit ridiculous.

    Well, looks like I might have a v4 framework installed, from installing Dev10 Beta 1: v4.0.20506.
    I will try uninstalling Dev10 Beta1, and see if this fixes the problem. If that's no good I will be trying .Net framework Beta2 to see what happens.

    Tim

    P.S. D'oh. Afterwards, I found this information (on Aaron Ruckman's weblog):

    "If you upgrade to Windows 7 from Windows Vista with the .NET Framework 4 Beta 1 installed, your machine will be in an unreliable state. In this state, Visual Studio 2010, and some managed programs depending on .NET Framework 3.5 or earlier will not work.  There is no way to repair a machine that gets into this state. You will need to reinstall Windows 7."
    Monday, December 7, 2009 4:18 AM
  • I'm having the same issue here. I have Microsoft 7 64 bit operating system installed, as well as .Net Framework 4 Beta 2. Microsoft update tells me I have the most recent updates, but yet I keep getting this error. I am including a link to my website that I have pasted a screenshot of the error onto an empty webpage since I cant figure out how to copy the image here in the forum. thanks for the help.   http://www.mythicaldesignsl.com/microsoft7_errorCode.html

    also, I'm not sure if the problems could be related or not, but I am also having my Internet Explorer frequently stop responding..and another HUGE issue is my whole pc will at times quit responding...when this happens NOTHING works...nothing even happens when I type alt-ctrl- delete. I have to manually turn the pc off by pressing the power button and holding it down untill it powers off (wich I hate doing, as I don't believe it's good for the computer.) It is a new computer and I wasnt having any of these problems untill I upgraded from Vista to Windows 7, so it makes me think its possibly problems with the OS, or something was messed up through the upgrade :(
    Sunday, January 17, 2010 2:56 PM
  • Hello aadams21,

    I've just upgraded to Windows 7 from Vista at 64 bit and am having the same problem described in your first paragraph.  I hope someone comes up with a solution...
    Sunday, January 24, 2010 9:11 PM
  • Hi all

    same here after .net framework 4 installed on my Windows 7 x64

    it's affect to:

          Program Compatibility troubleshooter (step 3 as well)

          Nero MediaHub 10 (prevent from start without any dialogue box)

          Nero Vision 10 ("Nero Vision has experienced a serious problem  and must close         immediately")

    All of this programs  work just fine without .net framework 4

    I tried to reinstall it hundred times, tried cleanup_tool, tried re-enable dotnet framework 3.5.1 in windows features. Unsuccessfully at all. 

    • Edited by 6arrep Friday, December 3, 2010 4:48 PM grammar
    Sunday, November 21, 2010 8:39 AM
  • i bought this damned expensive puter with no upgrading it came with w7. ive only let one update, serv pkg #1, on it. it came with net2.0 i now have net 4.0 and when i boot up all kinds of messages flash (too quik to read) telling me bout all the programs that wont work. my dvd player and usb sometimes disappear. i did cleanup and everything else that the ms techs have said to to, still no tshooter and it doesnt like to recognize any of the 3 adapters for wifi......this puter only has about 3 hrs of life in the last 5 months. it crashes and i also have too hold down power button for ever to shut off..i hate that i know im making it worse...why hasnt someone helped us .there are so many of us with the same problem and were being ignored!!!!!!!!they got our money and ran. guess they want us all to go mac. saw an ipad for 700.00 on qvc.please someone HELP...if it matters Asus intel i5 4gb 650gb w7 premium. oh i forgot it also has rewriten programs over and over and over every time i turn on, to fix it. all of my memory is gon,e its in the red 1.53 is free of 149 on main drive, and i havent installed anything on it.nothing not even music. help im a shut-in i need this to work!!!!!!!!!!!

    Saturday, May 12, 2012 12:48 AM