none
The backup failed. The RPC server is unavailable (0x800706BA)

    Question

  • After the Windows 10 version 1803 upgrade on April 30, 2018, my System Image Backup keeps failing withe two messages. "The backup failed" "The RPC server is unavailable (0x800706BA)".

    Note that the System Image Backup worked before the upgrade. The upgrade completed OK and I have not found any other issues.

    I checked that =1= The RPC (Remote Procedure Call) service in Services is active and running and =2= the DCOM (Distributed COM) is enabled. There used to be a SYSTEM disk when I did the defrag, the defrag does not show the SYSTEM disk in version 1803.

    Is it a bug, or is there a fix or should I try the Image Recovery (that might fail as well).

    Wednesday, May 02, 2018 2:38 AM

All replies

  • Hi jjfull,

    Based on my knowledge, the error code 0x800706BA sometimes occurs when the Remote Procedure Call (RPC) server is unavailable.

    Firstly, we need to make Sure that the RPC Services are Properly Functioning
    You could check if Remote Procedure Call (RPC) Service is set to automatically.
    https://social.technet.microsoft.com/Forums/en-US/a46a3d2e-6be4-4d63-b090-fb627340a520/win-10-pro-64-win-backuprestore-win-not-complete-backup?forum=win10itprogeneral

    In some cases, the Firewall may be blocking the traffic requested by RPC, hence resulting to the error. Please also  temporarily disable Firewall to do a check.

    You could also be seeing the RPC server error because of a network connection interruption. As such, you have to check if all your devices are correctly connected to the network you’re using.

    And please also test to create another user account with exactly the same privileges > logon to it > see if it will do the backup. If it works, then it is likely your original account is corrupted.

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 02, 2018 6:57 AM
    Moderator
  •  I have the same problem with my Nextbook (Win 10 Home edition). I created a system image as usual with no problem. Immediately thereafter, I downloaded the April update version 1803. The update appeared to install with no problems, so the first thing I did was to create a restore point. again no problem. Then I attempted to create a system image to the same ext harddrive I always use The system image failed. "The RPC Server is unavailable. Error code0x800706BA. I tried again and I get the same failure every time.
       I reverted back to the previous version of windows 10, and then I was able to successfully create a system image.  I, again,  installed version 1803, and the problem returned. Again I can't create a system image.

    • Edited by fuddd Thursday, May 03, 2018 8:51 AM
    Wednesday, May 02, 2018 1:42 PM
  • Mary's  answer in no way addresses the fact that there was no problem with the previous version, prior to version 1803.

    • Edited by fuddd Wednesday, May 02, 2018 1:59 PM
    Wednesday, May 02, 2018 1:51 PM
  • Thanks Mary. I have Windows 10Pro client, 32 bit software. I did check the RPC is Automatic and active. I run the dskchk C: /f /r /x (note that there were few fixes done by the dskchk) and tried to create a system image again it failed with the same error. Then I tried the restore from a previous system image, it failed with the same error. Then I stopped the firewall and tried to create a system image. It failed with the same error, just run a bit longer. I do not have other issues, but I cannot do the system image backup or to restore from the previous system image.
    Wednesday, May 02, 2018 5:31 PM
  • Some more follow ups with the same Fail messages:

    1. I did not have the Volume Shadow Copy service running. It was set to Automatic and started

    2. As I mentioned, Remote Procedure Call (RPC) Service was automatic and started

    I got a new message:

    The mounted backup volume is inaccessible. Please retry the operation (0x8078004F)

    3. Then I stopped the Symantec Security firewall

    I got some more new messages

    The Interface is unknown (0x800706B5)

    There was a failure in preparing the backup image of one of the volumes in the backup set. (0x807800C5)

    But they changed back to (the old RPC message) after another retry

      The backup failed. The RPC server is unavailable (0x800706BA)

    4. Then I did the clean reboot with all the above and got the same message

      The backup failed. The RPC server is unavailable (0x800706BA)

    Mary, Do you have another idea I can try?

    jjfull

    Wednesday, May 02, 2018 7:57 PM
  • Hi Mary: I completed the last test, a new admin account was created with standard unmodified defaults

    But the system image backup message is the same: The backup failed. The RPC server is unavailable (0x800706BA)

    jjfull

    Wednesday, May 02, 2018 9:28 PM
  • Hi,

    The problem only happens to windows 10 1803 version? Other version haven't such problem right?

    Since this is windows server backup forum,  maybe also consult in windows 10 forum for client windows 10

    https://social.technet.microsoft.com/Forums/en-US/home?category=Windows10ITPro

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, May 03, 2018 1:28 AM
    Moderator
  • Yup. Its a bug. The image backup is broken in 1803 on the 32 bit version only. If you try to perform an image backup to a network location it gives the RPC statement above. If you attached a local USB or SD drive, it fails also with the same message. Is there a simple 32 bit DLL that we can drop in to fix this?
    Thursday, May 03, 2018 8:07 PM
  • KenTopDogAce,  Thanks for taking a serious look at this. Your analysis describes my problem exactly.
    Thursday, May 03, 2018 8:47 PM
  • KenTopDogAce,  Thanks for taking a serious look at this. Your analysis describes my problem exactly.

    I have the same Problem with Version 1803, when i do a backup it becomes the Error: 0x800706BA
    Friday, May 04, 2018 7:27 AM
  • Thanks for the confirmation. I use an external USB drive for the target image copy backup. I have gone through the event log and noticed some errors regarding some problems to access the USB drive:

    1.The volume is recognized by NTFS but it is corrupted that NTFS could not mount it. Run CHKDSK /F to fix any errors on this volume, and then try accessing it.

    2.The backup operation that started at '‎2018‎-‎05‎-‎02T17:49:08.717202700Z' has failed with following error code '0x807800C5' (There was a failure in preparing the backup image of one of the volumes in the backup set.).

    3. The disk cannot be written to because it is write protected. Please remove the write protection from the volume %hs in drive %hs.

    But after every failed Image backup a new corrupted backup file was created on the USB external drive that I deleted after each failure.

    After that I run chkdsk C: /F on my system drive,  chkdsk D: /F on my second partition and chkdsk F: /F on my USB external drive. All completed clean. Then I checked the services and run the Image backup to the USB external drive one more time. The system Image Copy backup failed again with the same error: The RPC server is unavailable (0x800706BA). I never had a problem with my Image backups on windows 7 or Windows 10 until the upgrade to version 1803, so it does look like a BUG.


    Friday, May 04, 2018 2:55 PM
  • We see the same issue...  image backup is broken in 1803 on the 32 bit version only!

    Sierra

    Friday, May 04, 2018 4:00 PM
  • Same problem with my 32 bit laptop. If you remember 64 bit build 16251 rd 3 Back up and restore had an issue with system image.

    Robert Denis

    Sunday, May 06, 2018 12:28 AM
  • Has Microsoft acknowledged the existence of this error and given an estimate of when they'll fix it?
    Wednesday, May 16, 2018 12:13 PM
  • The above W10 1803 Image copy potential bug was posted to the Microsoft Feedback Hub, with supporting screen shots. It was acknowledged by Microsoft, but no response provided yet.
    Wednesday, May 16, 2018 3:31 PM
  • The issue you submitted though the feedback hub has been received.  Would it be possible for you to attach the System and Application event log data to your issue in the feedback hub, as well?  You could just reproduce the error and then export the last 30 minutes, or so, worth of events in .csv format from each log.  This would be helpful in determining the root case of this issue.

    Thanks,

    Wes

    Microsoft Corporation

    Thursday, May 17, 2018 6:02 PM
  • Hi Wes: The System and Applications event logs from two failed Image backups from today were attached with comments in the Feedback Hub.

    Jerry

    Thursday, May 17, 2018 9:47 PM
  • I talked to tech support (Ticket #1424749859) about this for over 3 hours while watching a tech on my laptop remotely, until he finally admitted defeat. ("Wait for an update that fixes the problem.")

    After all was said and done, i replaced the x86 1803 version of wbengine.exe with the 1709 version through the recovery command prompt.

    After that the image backup worked and a recovery disc PRIOR to 1803 successfully restored it.

    While I wouldn't propose this as a solution, it certainly defines the problem.

    wbengine.exe (x86) is the problem. RPC is merely a symptom.

    The x64 version of wbengine.exe in 1803 is not a problem.

    I reported this back to tech support under the same ticket number. Apparently you have to tell them from 4 different directions before someone notices.

    Friday, May 18, 2018 9:25 PM
  • I had Norton running. Had same problem and after disabling auto-protect until system reboot (in Norton) the "create system image" worked. Well fingers crossed anyway as it is running now (but previously failed almost straight away!)
    Friday, May 18, 2018 9:58 PM
  • Good god. Thanks to jjfull for asking, KenTopDogAce for sniffing this thing out, and to Wes Keetch for stepping up from Microsoft.

    I've spent (read: wasted) way too many hours of my life trying to figure this out. Lost a lot of sleep. Time is like miles run off a tire -- you can't put the rubber back on; it is gone forever. Our most precious non-renewable resource consumed, again, by technology run amuck.

    Sorry. Got on a roll. I understand that not every situation can be foreseen; however, this affects the backup functionality, something I presume a lot of users take advantage of. I do wish Microsoft would advise everyone who gets upgrades about bugs when they find them rather than just letting its loyal users flounder and struggle trying to figure out how to fix the unfixable.

    So now I can get back to my life whilst waiting for a fix.

    My sincere gratitude to you folks.

    14 hours 20 minutes ago