Synonyms and best bets not working RRS feed

  • Question

  • I just finished configuring FAST Search for SharePoint 2010.

    I can now access FAST Search Keywords from site settings as well as all pages from FAST Search Administration from FAST Query SSA.

    I added some keywords with two-way synonyms as well as some best best.

    However the search results seem to ignore them - they only return files based on searched term, not the synonyms.

    I did a full crawl and checked that the service application associations are correct (using FAST Query SSA, Search Service Application unticked).

    Any ideas what might be missing?

    Thursday, September 29, 2011 11:40 AM

All replies

  • Hi May be you are aware of that synonym are not highlighted into search results. Execute the search on search term for which you have defined synonym and record the search counts.

    For Narrowing down the issue, you can remove the synonym and then execute the query on that search term for which you are removing synonym.

    Now the search results should be less in comparison to previous case. here I am just trying to narrow down the problem. 

    Please check this use case at your end.




    Ashish Gupta
    Thursday, September 29, 2011 12:06 PM
  • I have FAST search enabled on a test site, which has only few documents uploaded.

    Searching for terms, which are in those documents includes them in the results. Searching for synonyms of these terms doesn't.

    Thursday, September 29, 2011 12:35 PM
  • I created a new site collection based on FAST Search Center template, added some keywords and synonyms and they are now included in the results.

    However my root site collection does seems to be ignoring them.

    Question here - is this by design? - why is my default site collection not taking advantage of FAST search functionality? - can this be enabled?


    Just to clarify - I'm trying to search using this default control in the top right corner of the site:

    • Edited by tsw_mik Thursday, September 29, 2011 1:20 PM
    Thursday, September 29, 2011 1:18 PM