locked
Retention Processing does not move Document Set to the Drop Off Library RRS feed

  • Question

  • Hi Everyone.

    Had Retention Processing working fine. Moving files between Document Librarys and the Record Centre using Information Management Policies to move to the Drop-Off Library where the Content Organizer Rules moved them to the relevent Library.

    It has all come to a grinding halt with the following line in the '14 hive' logs.

    Skipping retention processing for item /doc/Housing/1 RET TEST SET on web http://moraysrv052/doc because there is an unprocessed schedule update.    1b1dfe42-28f9-440a-b84a-17c20aa9c7d6

    I have searched the Internet and these forums but can find no reference to this error, Can anyone help as automatic retention policies are crucial to our Sharepoint Implementation.

    Cheers

    Ross Urquhart

    Friday, October 7, 2011 8:53 AM

Answers

  • Hi

    Have discovered by trial and error that the workaround is:

    Go to Library Settings, Metadata Navigation Settings, Indexed Columns.

    If Expiration Date is missing Go back and Turn On Automatically manage column indices on this list.

    Create a new Management Information Policy and check the Index. If it is back then delete your new policy and turn off Automatically manage column indices on this list.

    If not change your Management Information Policies to Library, create one and check the Index again. If it has returned put your policies back the way they were.

      If any changes have been made to Information Management Policy please make sure the Information management policy Timer Job has ran to pick them up.


    Monday, February 2, 2015 1:53 PM

All replies

  • Hi,

    There are two timer jobs involved and both run weekly. You can try to run them (now) in this order:
    Information management policy
    Expiration policy

    Check out these link below,they might come into handy for your issue

    1) http://ithinksharepoint.blogspot.com/2009/03/expiration-policy-timer-job-does-not.html

    2) http://vspug.com/teameli/2008/10/13/record-center-information-management-policy-jobs-not-running/

    3) http://social.msdn.microsoft.com/Forums/en-US/sharepointecm/thread/caa2f889-ca74-43c9-9ebc-106dd549c497/

     


    Regards Vinit Shah
    Monday, October 10, 2011 6:44 AM
  • Vinit

    Thanks for the advise but not the answer unfortunately.

    I have the Content Organizer & Expiration Policy Timer Jobs running every 15 mins, Information Management Policy runs Weekly as this only effects changes to Policy. I have changed the times so all jobs run every 15 mins. Still get the same error message.

    Expiration worked perfectly before when it was triggered by Closure Date, A column we created which the user populates to indicate the Document can be closed. Retention then moves the Document to the Record Centre. I changed the trigger on one of the Document Sets to be Created Date and this generates the error, Change this back to Closure Date, no error, Document moves to Record Centre Drop Off Library.

    Another observation. If Retention is against a any other Content Type it is called Created if it is against a Document Set Content Type it is called Created Date, however when you review the Compliance Details of the Set it is called Created.

    Does this trigger any ideas.

    Cheers

    Ross Urquhart

    Monday, October 10, 2011 8:36 AM
  • Hi Ross

    Not sure if you have an answer to this yet. But from my research, I realize that retentions policies which involve moving a Document Set to another location does not work on Document Sets! Option would be to create a Job to do this. Sadly so!

    I may be totally wrong. If so please help.


    Firoz Ozman


    • Edited by FirozOzman Wednesday, February 22, 2012 5:42 PM
    Wednesday, February 22, 2012 5:10 PM
  • Hi Moray,

    I had similar error message in the log, I restarted SharePoint Timer service and every thing worked back again .. Try Over !!

    Thansk

    Emad El Faramawi

    Wednesday, July 25, 2012 11:59 AM
  • Hi,

    I have an almost similar problem but no way to find what's goign wrong, did you solve your issue ?

    Olivier

    Wednesday, July 16, 2014 7:17 AM
  • Hi

    Have discovered by trial and error that the workaround is:

    Go to Library Settings, Metadata Navigation Settings, Indexed Columns.

    If Expiration Date is missing Go back and Turn On Automatically manage column indices on this list.

    Create a new Management Information Policy and check the Index. If it is back then delete your new policy and turn off Automatically manage column indices on this list.

    If not change your Management Information Policies to Library, create one and check the Index again. If it has returned put your policies back the way they were.

      If any changes have been made to Information Management Policy please make sure the Information management policy Timer Job has ran to pick them up.


    Monday, February 2, 2015 1:53 PM