locked
IE8 drag and drop in Outlook Web App OWA is not working RRS feed

  • Question

  • I'm having trouble identifying the cause behind an inability to drag and drop emails between folders in OWA (Exchange 2010).

    The problem PC is running fully up to date 32 bit Windows XP SP3 with IE8. When I try to drag and drop an email all I see is a black stop symbol. On another PC with the same spec, logged in with the same user account, I can drag and drop emails fine between folders in OWA.

    I've tried clearing browser cache/history etc, resetting the browser to factory defaults, re-installing the browser, reducing security in the browser to absolute minimum, re-installing Java, Silverlight, S/MIME (although I'm sure it doesn't use these).

    Can anyone suggest anything else, or provide helpful links? I've been looking at this for many hours without any progress. If I even just knew what component/tool/feature IE is using when it does/doesn't drag and drop I'd have somewhere to start...

    TIA.

    Wednesday, June 19, 2013 3:58 PM

Answers

  • I cannot identify which differences are actually important.

    Start with a coarse filter such as Process and Thread.  Where do the traces diverge?  That's where you could add the other event categories, e.g. Registry and File to find out why.   Alternatively, use that difference as a clue for something to try changing.  Etc.

     
    Good luck



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Wednesday, July 3, 2013 1:40 AM
    Thursday, June 20, 2013 11:52 AM
    Answerer

All replies

  • On another PC with the same spec, logged in with the same user account, I can drag and drop emails fine between folders in OWA.

    Then you have an opportunity to use ProcMon to take two traces and compare them for their essential differences--probably something in the registry but there might be an interferer involved instead.   To try to test for the latter case you could try running in No Add-ons mode or simply compare what all is loaded in the two machines when the same event occurs.

     
    Good luck


    Robert Aldwinckle
    ---

    Wednesday, June 19, 2013 7:30 PM
    Answerer
  • I had tried manually disabling all Add-ons, but as this made no difference I'd ruled out Add-ons as being the cause. However, I tried running the browser using the No Add-ons shortcut instead, and this has worked. It's not ideal to have it running in No Add-ons mode all the time, so I need to identify exactly what IE does when you start it in No Add-ons mode. As I said, disabling every Add-on manually didn't work, so there is something else going on...

    I did try to trace using ProcMon in a working and non-working scenario, and while I can see minor differences between them I cannot identify which differences are actually important.

    Thursday, June 20, 2013 11:19 AM
  • I cannot identify which differences are actually important.

    Start with a coarse filter such as Process and Thread.  Where do the traces diverge?  That's where you could add the other event categories, e.g. Registry and File to find out why.   Alternatively, use that difference as a clue for something to try changing.  Etc.

     
    Good luck



    Robert Aldwinckle
    ---

    • Marked as answer by Cloud_TS Wednesday, July 3, 2013 1:40 AM
    Thursday, June 20, 2013 11:52 AM
    Answerer
  • Hi,
    I tried a couple of options and it didn't work. Finally, I added this website to the list of trusted sites, HAD to restart the IE window and it worked for me. I open OWA in Win 2008 R2 with IE8 is my environment. Switching On/Off the Protected Mode in IE is not relevant here. This issue was not there in Win 2003 and IE8. Hope it helps somebody :)


    Praveen Behara
    MCST : BizTalk Server 2006 R2, 2010

    Monday, July 22, 2013 6:31 AM
  • added this website to the list of trusted sites

    Switching On/Off the Protected Mode in IE is not relevant here.


    Yet that is one of the principal differences between the two zones?   ; }


    Robert Aldwinckle
    ---

    Monday, July 22, 2013 2:52 PM
    Answerer
  • I have this problem I heard there is a hotfix but I dint get the number, this affects any drag and drop options such as dropbox, sharepoint, etc..

    When I get the number I will post it for you.

    a work around is Chrome. but it has options for the html5 which is not present even in IE 10. :(.


    technet sharepoint alert

    I spent about three days on this and one IT guy and more than several Engineers at microsoft india, they are helpfull but not this time.

    this works on server 2008r2 but not vista, I am guessing Windows 7.

    • Edited by Tech_guy_HAP Friday, March 21, 2014 4:52 PM update
    • Proposed as answer by Tech_guy_HAP Friday, March 21, 2014 4:52 PM
    Friday, March 21, 2014 3:17 PM
  • I had this problem and my solution was.

    1) In internet explorer select Tools --> Compatability View Settings

    2) In "Websites you've added to Compatability View " select the website that hosts your e-mail and

    3) After selecting your website pres the remove button on the right site and then Close.

    In my case this solved the problem.

    Valdimar Helgason

    Saturday, February 21, 2015 3:05 PM
  • Esc dit not do the trick for me but this did

    I had this problem and my solution was.

    1) In internet explorer select Tools --> Compatability View Settings

    2) In "Websites you've added to Compatability View " select the website that hosts your e-mail and

    3) After selecting your website pres the remove button on the right site and then Close.

    In my case this solved the problem.

    Valdimar Helgason

    Saturday, February 21, 2015 3:06 PM
  • Esc dit not do the trick for me but this did

    I had this problem and my solution was.

    1) In internet explorer select Tools --> Compatability View Settings

    2) In "Websites you've added to Compatability View " select the website that hosts your e-mail and

    3) After selecting your website pres the remove button on the right site and then Close.

    In my case this solved the problem.

    Valdimar Helgason

    Saturday, February 21, 2015 3:07 PM