locked
UAG 2010 SP1 Question RRS feed

  • Question

  • Hi All,

    I'm just skilling up on UAG by way of building it out in a test environment. I've got it installed, I have an HTTPS trunk created and all the certs assigned so the portal works great. The in-built remote desktop client works as well, I can RDP through UAG to the rest of the servers in the test environment.

    What I can't get working is anything else so I think I'm fundamentally misunderstanding how the product works (even though I've read the book written by the product team guys). My first attempt was to try and connect the ConfigMgr console back through UAG to the ConfigMgr server, this failed. I tried by setting the console up as an EGCA (multiple servers) application, with the ports I had observed the console using in netmon (yes including the ephemeral port), my test client wasn't on the same domain so I put this down to an authentication issue and thought I would try something simpler.

    I thought I would try MSTSC.exe, simply as a means to connect to a server with an IP and port. I set it up as an EGCA (hosts disabled) application, put in 192.168.0.10 as the server with 3389 as the port, mstsc.exe as the application and /v:192.168.0.10 as the argument. Still no joy, so I enabled socket forwarding as basic, still said it couldn't find the host.

    My understanding is that if you enable socket forwarding then the client component should inspect the traffic and route accordingly, without socket forwarding then you need one of the application types that modify the hosts file to direct the traffic back locally for the SSL Application Tunneling.

    Have I just picked two really bad examples to try or have I got all this back to front? I have spent the best part of a day researching this and information is surprisingly scarce, although I did find some posts on using the telnet client with arguments %localip% and %localport%, that in itself I find confusing, how does directing the telnet client to the local host get the client connectivity to anything meaningful.

    Obviously I'm missing something fundamental here, if anyone can put me straight I would much appreciate it.

    Thanks and sorry for the long post.


    • Edited by TickTarry37 Friday, January 6, 2012 9:13 PM
    Friday, January 6, 2012 6:10 PM

All replies