none
Project Professional 2010 Not Publishing to Project Server 2010 RRS feed

  • Question

  • I am having trouble publishing a project from Project Professional 2010 to the Project Server 2010 (PWA). What I am trying to publish is a master project which is contains many enterprise projects as subprojects. When I press publish, it prompts me to save and if I click yes then it goes through and saves all the subporjects and then just stops there and doesn't publish the changes to the master project. If I press publish and click no to the save prompt then it gives me the status "sychronizing data to server" for around 15 seconds and then just does nothing after the sychonization finishes.

    It usually should be giving a "publishing job done 0%" or "publishing job completed" when it publishes, but it gives nothing like that. I also check the project through the PWA and it has not updated yet, but when I open it for editing in the client it has everything updated and up to date, meaning that the save is working properly and just not the publishing.

    All my subprojects are able to publish correctly, it's just this master project that is not working.

    Does anyone know why this is happening? Is the publishing process timing out for some reason? Or is it something else?

    Please help.


    EDIT: The progress notification at the bottom of Project Professional just stops at "save completed sucessfully" whenever I try to publish
    Monday, March 28, 2011 7:43 PM

Answers

All replies

  • Hi KmkLeung,

    Did you check for Queue Error?

    For your information choose the column Co-Relation ID in Selectied Column, then Refresh the Queue after finding out the Co-relation ID for the error, use the same ID in ULS log to find out the cause of the problem.

    Kindly share that ULS logs with us to troubleshoot the same.


    Warm Regards Badal Ratra
    Tuesday, March 29, 2011 3:13 PM
  • Thanks for your response Badal, but I'm not sure of how to check for Queue error, what do you mean by choosing the column correlation ID in the selected column?

    Could you guide me through this step by step?

    Tuesday, March 29, 2011 3:43 PM
  • To check the queue, navigate to Server Settings > Manage Queue and view the jobs that are present. If there is an error when publishing you should see it in the queue.
    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Saturday, April 30, 2011 12:46 PM
    Moderator
  • Hi,

    I am having the same issue, I am triying to publish a Master Project but only save. I review the queue jobs and not exist errors, the publish jobs not are displayed and only displayed the save jobs. This same behaviour is working in other masters projects

    I have Project Server 2010 SP1 with April 2012 Update and MS Project professional 2010 SP1.

    Please your help and comments

    Thanks

    
    
    
    Monday, June 11, 2012 7:18 PM
  • Hello,

    Same problem. Project Server 2010 SP1 and Project Pro.

    Publishing master project from Project Pro starts only saving in Queue.

    No other action is taken. Queue not showing any errors nor ULS logs does

    Any clue what could be wrong

    Maciej

    Thursday, November 21, 2013 10:21 PM
  • Same problem.. any solution for this?

    Sakthi

    Wednesday, April 15, 2015 8:21 PM
  • This is not the answer.  When checked in the queue, no publishing job exists in the queue after the save project from project professional job.
    Friday, November 13, 2015 6:47 PM