none
Exchange Active Sync Only Works WiFi, Not 3G, On EVO 4G Running Android 2.2 On SBS 2008

    Question

  • Just switched to Sprint EVO 4G from Sprint Mogul which had been syncing (EAS) for 3 years with Exhange Server on SBS. EVO will sync mail, calendar and contacts when connected to (secured) WiFi router, even without VPN tunnel (which also works). But when wireless turned off the EVO cannot connect to the SBS 2008 server (running Exchange 2007) via Sprint 3G (other 3G services like internet access work). I suspect a certificate problem on the EVO (running Android 2.2). I copied the standard (self signed) certificate file (.cer) to the root directory of the EVO SD card but it doesn't recognize it. Apparently it wants a .p12 certificate? Pleas advise if you have encountered and solved this problem, and how. Thanks.

    Thursday, October 28, 2010 7:37 PM

All replies

  • The cost of a 3rd party SSL cert is so cheap (less than $20 from places like GoDaddy), we urge you to get one, and use the SBS 2008 wizard for installing the cert.
    -Kevin Weilbacher (SBS MVP)
    "The days pass by so quickly now, the nights are seldom long"
    KW Support MVP Blog
    MVP's do NOT work for Microsoft. We give our time freely to support the SBS community!
    Thursday, October 28, 2010 9:30 PM
  • You might want to check out the following links that describe converting the Windows .cer to a format that the Android can use and installing it on the phone.  This did work OK for a couple of my users with our self signed certificate.

    http://abtevrythng.blogspot.com/2010/06/adding-cer-certificates-on-your-android.html

    http://onlygizmos.com/installing-cer-certificates-on-your-updated-htc-hero-android-2-1/2010/06/

    Good luck.

    "HughMul" wrote in message news:a9099003-ffb3-463b-9f0a-8ea27835fcd0@communitybridge.codeplex.com...

    Just switched to Sprint EVO 4G from Sprint Mogul which had been syncing (EAS) for 3 years with Exhange Server on SBS. EVO will sync mail, calendar and contacts when connected to (secured) WiFi router, even without VPN tunnel (which also works). But when wireless turned off the EVO cannot connect to the SBS 2008 server (running Exchange 2007) via Sprint 3G (other 3G services like internet access work). I suspect a certificate problem on the EVO (running Android 2.2). I copied the standard (self signed) certificate file (.cer) to the root directory of the EVO SD card but it doesn't recognize it. Apparently it wants a .p12 certificate? Pleas advise if you have encountered and solved this problem, and how. Thanks.

    Thursday, October 28, 2010 11:28 PM
  • This didn't work. I created 3 or 4 certs (user, admin) from client machine and SBS server carefully following instructions. Each time certs were accepted and installed by EVO. I am wondering if the certificate is not the problem but perhaps some bug in Android 2.2 or some setting on server. Any follow-up help would be appreciated.
    Tuesday, November 02, 2010 8:02 PM
  • I did not have to do anything further for it to work on our network.   Since it works with some 3G but not with Sprint have you talked with them to see if they are aware of any issues?   You might also check the Android forums as I did find a lot of good information there as well.    Sorry that I can't help any further.

    "HughMul" wrote in message news:a1c18e23-5b9c-4e95-a2b2-0bc7f39a9f73@communitybridge.codeplex.com...

    This didn't work. I created 3 or 4 certs (user, admin) from client machine and SBS server carefully following instructions. Each time certs were accepted and installed by EVO. I am wondering if the certificate is not the problem but perhaps some bug in Android 2.2 or some setting on server. Any follow-up help would be appreciated.

    Wednesday, November 03, 2010 5:56 PM
  • HughMul,

    Am wondering if you have found a solution yet.  My EVO is experiencing the same issue.  When on Wifi, it sync's with the Exchange Server without a problem.  When I use 3G, it gives me an Exchange Sync error.

    I know it is not a firewall issue as the Wifi network is a couple thousand miles from where the Exchange server is located. 

    Tuesday, November 30, 2010 4:30 PM
  • JeffLeitman,

    Not yet. Let me ask if you've experienced the same (related?) activity. I downloaded a self signed certificate from my SBS 2008 server, converted it to a p12 file type, put it in the root of the SD card and installed it on the EVO. Android 2.2 recognized and installed the cert sucessfully. I enabled secure credentials under EVO security and gave it a password (that is NOT the same as my network password). Everything seemed correct, however when I reboot the phone the "use secure credentials" checkbox is again unchecked. I've done this several times with the same result (insanity?). Let me know if you've made any progress on this issue, thanks.

    Wednesday, December 01, 2010 3:53 PM