none
Mobile devices not authenticating after moving Exchange 2013 to new server in same network/domain.

    Question

  • I added a new server to my network/domain, installed Exchange 2013 on Server 2012 R2 and used the Ed Crowley method to move mailboxes to new server. Outlook seems to work but mobile devices cannot authenticate back to new Exchange server. Get the error that user cannot be authenticated. I checked the DNS. My MX goes to our static, public IP and I have traffic routed to the correct, new server. The error is that the new server name doesn't resolve to the same name as the original Exchange server. The original Exchange server resolved to mail.domain.com. The new server resolves to servername.domain.local.

    I know there is a way to change how the server's name gets resolved but can't remember where.  Can someone kindly remind me what I am missing?

    Thank you.


    • Edited by bctsllc Monday, September 4, 2017 4:33 AM
    Monday, September 4, 2017 4:32 AM

All replies

  • Hi Bctsllc,

    Check the following settings:

    Get-ActivesyncVirtualDirectory |fl Name,Server,InternalUrl,ExternalUrl

    Then set the Internal and External URL to resolved to mail.domain.com, as below:

    Set-ActivesyncVirtualDirectory "NewServerName\Microsoft-Server-ActiveSync (Default Web Site)" -InternalUrl https://mail.domain.com/Microsoft-Server-ActiveSync -ExternalUrl https://mail.domain.com/Microsoft-Server-ActiveSync

    Hope this helps,

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 5, 2017 6:17 AM
    Moderator
  • Hi Bctsllc,

    I'm just writing to check how's everything going? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

     

    Thanks for your understanding.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 22, 2017 9:05 AM
    Moderator