locked
Problem Connecting SharePoint Calendar in Outlook 2016 RRS feed

  • Question

  • We are in the process of standing up a SharePoint 2016 environment that is using ADFS for authentication.  Accessing the site and calendars are fine when going through the browser and Outlook 2010, but access is denied when attempting to connect the calendar in Outlook 2016.  In Outlook 2016, it will connect the calendar and then prompt for username and password.  Entering credentials does nothing.  There will be a send/receive error that states access is denied (0x80070005). The result is the calendar gets added, but will not populate any data.  I've tested this with a Windows 10 system that has Office updates and one without.  Any suggestions?

    Thank you

    • Moved by Chenchen Li Thursday, November 23, 2017 2:51 AM Outlook IT
    Wednesday, November 22, 2017 3:31 PM

Answers

  • The issue ended up being Modern Authentication.

    We made the reg changes below and are now able to connect.

    1. Close Outlook
    2. Open the registry editor (regedit).
    3. Open the registry key in the following path HKCU\SOFTWARE\Microsoft\Office\16.0\Common\Identity
    4. Check if EnableADAL key is present
    5. If not present then create new REG_DWORD key with name EnableADAL and value 0
    6. Close regedit
    7. Open Outlook

    • Marked as answer by kieffer Monday, November 27, 2017 7:07 PM
    Monday, November 27, 2017 7:07 PM

All replies

  • Hello,

    Thanks for posting here. This forum (Outlook for Developers) is for development issues when using Outlook Object Model. According to your description, you fail to connection calendar after entering credentials. The issue is not related to code or Outlook Object Model, so i would move this thread into Outlook IT Pro Discussions forum.

    Regards,

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, November 23, 2017 2:50 AM
  • Hi,

    Does this issue happen with all users' Outlook 2016 or just certain ones? All SharePoint calendars affected?

    Besides, we may also try removing the calendars in Outlook and then reestablish the connection to Outlook as per the following article suggested:

    https://support.microsoft.com/en-us/help/2938471/0x80070005-error-when-you-try-to-sync-a-sharepoint-online-list-in-outl

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Steve Fan Monday, November 27, 2017 9:39 AM
    Friday, November 24, 2017 9:13 AM
  • Thanks for the reply.  It does happen for all calendars and with all users.  This occurs on the initial connection when adding the calendar, so there aren't any existing connections for the calendar in this case.  We are going to open a call with Microsoft.

    Thank you

    Monday, November 27, 2017 6:44 PM
  • The issue ended up being Modern Authentication.

    We made the reg changes below and are now able to connect.

    1. Close Outlook
    2. Open the registry editor (regedit).
    3. Open the registry key in the following path HKCU\SOFTWARE\Microsoft\Office\16.0\Common\Identity
    4. Check if EnableADAL key is present
    5. If not present then create new REG_DWORD key with name EnableADAL and value 0
    6. Close regedit
    7. Open Outlook

    • Marked as answer by kieffer Monday, November 27, 2017 7:07 PM
    Monday, November 27, 2017 7:07 PM
  • Great! Glad to hear that you have found the solution. Thank you for sharing your experience here.

    Cheers,

    Steve Fan


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, November 28, 2017 2:17 AM