locked
hp officejet d series vista driver RRS feed

  • Question

  • I cannot get my hp officejet D 125xi all in one printer working with the vista supplied driver It says “ it encountered an error while attempting to install it”  “The parameter is incorrect .”  I have tried it with the standard lpt1 , usb and even a networked print server. And get the same message  I think the driver is not written correctly. Xp drivers don’t seem to install ether.  What does The parameter is incorrect mean ?

    Friday, June 16, 2006 1:52 PM

All replies

  • This is from HP , I hope it helps
     
    Workaround
    CAUTION: Do not connect the USB cable from the product to the computer until prompted to do so by the installer.
    1. Click Start.
    2. Click the Printers and Faxes folder.
    3. Click File then select Add Printer. The Add Printer Wizard opens.
    4. Click Next.
    5. Uncheck the Automatically detect and install my Plug and Play printer checkbox.
    6. Click Next. The Select a Printer Port window opens.
    7. Click Next. The Install Printer Software window opens.
    8. In the Manufacturer list, select HP.
    9. In the Printers list, select hp deskjet 990c.
    10. Click Next. The Name Your Printer window opens.
    11. If the Printer name is OK, click Next.
    12. Click Next. The Printer Sharing window opens.
    13. Select No when prompted Do you want to print a test page.
    14. Click Next. The Completing the Add Printer Wizard window opens.
    15. Click Finish.
      NOTE: At this point the driver installation portion of the process is complete.
    16. Connect the USB cable to the printer and the computer.
      NOTE: Windows will start the Plug and Play process.
    17. Click Cancel each time a Found New Hardware Wizard window opens.
      NOTE: The number of Found New Hardware Wizard windows that open will vary depending on the product plugged into the computer.
    18. In the Printers and Faxes Folder, click once on the hp deskjet 990c printer icon to highlight it.
    19. Click File, and then Properties.
    20. Click the Ports tab
    21. Select USB00x Port. The checkbox should have a check in it. If not, click once to select the port.
    22. Click Close.
    Wednesday, June 21, 2006 6:39 PM
  • This forum is for the Application Compatibility Toolkit (ACT). I am moving your thread to the Hardware forum where they may be able to provide some guidance.
    Friday, July 28, 2006 10:46 PM