none
OWA not working on Firefox and Chrome (but does in IE) RRS feed

  • Question

  • Hi , I am a bit stumped.

    Installed Exchange 2016 CU7 and keep on getting redirect type issues on Chrome / Firefox when accessing /OWA: (IE works fine)

    Chrome: <url> redirected you too many times.

    Firefox:The page isn’t redirecting properly

    I did toggle the IIS redirect setting on the IIS default site and virtual directory, as many articles suggest.

    Here is the kicker:

    I can open /ECP on all browsers. Its just OWA not playing nicely

    Any ideas ?

    Thursday, May 30, 2019 2:28 PM

All replies

  • Hi

    Do you have any servers on the latest CU or 1 version behind the latest?

    Would you be able to upgrade and then advise?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 30, 2019 6:39 PM
    Moderator
  • Hi,

    Does OWA work well on Chrome or Firefox before configuring http to https redirection for OWA?

    Please check this official article and make sure all steps are configured correctly: Configure http to https redirection for Outlook on the web in Exchange Server

    Please make sure the Chrome or Firefox browsers are updated to the newest version.

    You can reproduce your issue, and check the IIS logs for further analysis. The default path is C:\inetpub\logs\LogFiles\W3SVC1.

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, May 31, 2019 9:59 AM
    Moderator
  • Hi,

    Just checking in to see if above information was helpful.

    If you have solved your problem, could you share with us? Maybe it will help more people with similar problems. Don't forget to mark it as answer, this will be easy for other community members to find the useful one.

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, June 5, 2019 1:35 AM
    Moderator