none
Mounting Bitlocker encrypted VHDX. RRS feed

  • Question

  • I keep having this repetitive problem on both my surface pro 4 and my desktop pc, where if i attempt to mount a bitlocker encrypted virtual drive, multiple errors and an empty explorer windows pop up. 

    Is this a common bug?

    The drive is configured with all the newer formats, such as GPT partition style, dynamic allocation, .vhdx extension, etc. It is on my internal hard drive, the issue cannot be related to performance or storage usage. 

    The errors are as follows:

    F:/ is not accessible. Access is denied

    and 

    The disk image isn’t initialized, contains partitions that aren’t recognizable, or contains volumes that haven’t been assigned drive letters. Please use the disk management snap-in to make sure that the disk, partitions, and volumes are in a usable state

    Along with these errors are an empty window.


    Tuesday, January 24, 2017 12:07 AM

All replies

  • Hi ,

    Kindly refer to following link for assistance.
    How to Create an Encrypted Container File With BitLocker on Windows
    http://www.howtogeek.com/193013/how-to-create-an-encrypted-container-file-with-bitlocker-on-windows/
    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    In addition, for the "Access Denied" issue, the process monitor tool should be useful to troubleshoot it.
    Process Monitor v3.2
    https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx
    Solving Access Denied Errors Using Process Monitor
    http://improve.dk/solving-access-denied-errors-using-process-monitor/

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, January 24, 2017 7:28 AM
    Moderator
  • Phil,

    are you ever asked for a key when trying to mount it? Is that key entered and accepted or at what point do these errors appear?

    Thursday, January 26, 2017 12:10 PM
  • this appears as soon as i double click on the vhd to mount it. 
    Thursday, January 26, 2017 4:32 PM
  • Have done this often, never a problem.

    Are you sure the file ain't corrupted? Does it mount anywhere? If you right click it, what is the action you see in bold letters? Should be "mount" .

    Friday, January 27, 2017 7:54 AM
  • it does mount, but it gives me multiple errors in the process, ive ceated multiple other virtual disks encrypted by bitlocker and they give the same result, its strange that when i created, encrypted, and mounted a virtual hard drive inside my virtual machine it worked flawlessly.

    im now wondering whether pieces of what i stored are now corrupted because of this, and i really hope not.


    • Edited by Phil Nadon Friday, January 27, 2017 7:59 AM
    Friday, January 27, 2017 7:59 AM
  • Ok, so it mounts.

    When it is mounted (but not accessible) to letter for example x:, use this command:

    manage-bde -unlock x: -pw

    and enter the password after you are asked for it.

    or

    manage-bde -unlock x: -rk 129387-123121-.....(your 48-digit-key here)

    Friday, January 27, 2017 8:10 AM
  • I have the same problem, Windows 10 1803. The VHDX can be unlocked and mounted, either from the window in the Desktop, or from File Explorer. 

    But everytime I get the error mesage

    "The disk image isn’t initialized, contains partitions that aren’t recognizable... "

    This is confusing and shouldn´t happen.

    Thursday, November 1, 2018 1:35 PM
  • Please describe how you proceed to mount and unlock the .vhdx
    Monday, November 5, 2018 7:17 AM