locked
Application won't install during monitoring RRS feed

  • Question

  • Hi,

    I am having problems sequencing a Windows 32-bit application.  Last year, I successfully sequenced it on my Windows XP 32-bit sequencer vm and it works correctly when published to clients also running Windows XP 32-bit O/S.  I tested the sequenced app on Windows 7 64-bit by updating the OS value in the OSD file.  Though, the application opens when launched on W764 clients, it isn't able to generate graphs, the error message "failed to open graphics server" appears.

    As we are about to upgrade our clients to Windows 7 64-bit O/S, I have tried sequencing it on a vm running Windows 7 64-bit and sequencer version 4.6.0.20200.  During monitoring the error message "C:\windows\system32\OLE2.dll is either not designed to run on Windows or it contains an error" appears during the final stage of the program installation wizard.  Oddly, the program installs correctly on my vm if I try it when not monitoring. (I have also tried sequencing it on a machine running 32-bit Windows 7, though the ole2.dll error message doesn't appear the 'failed to open graphics server' message does).

    I noticed that the 32-bit OLE2.dll file mentioned during installation is located in C:\windows\SysWOW64 (32-bit binaries folder) on Windows 7 64-bit.  In the system32 folder (64-bit binaries) it is called OLE32.dll.  During monitoring it seems to be looking in the wrong folder for the dll file.

    I wondered if anyone could help me resolve this issue.

    Many thanks.

    • Edited by DanyonL Thursday, August 26, 2010 7:58 PM
    Sunday, August 22, 2010 4:39 PM

Answers

All replies