locked
Installing NC with VMM: problem with installing the network service. RRS feed

  • Question

  • Hello again!

    I've been trying to install network controller several times, and I think I'm pretty close. But i'm having issues at a step of this procedure: https://technet.microsoft.com/en-us/library/mt729074(v=sc.16).aspx . I have two hosts, one of wich hosts the VM for NC. VMM is not located on one of those hosts.

    The deployement of the network service went without issues. But I have not been able to add the network service to VMM. that is, without errors I mean, as it always appears in the network service tab in VMM.

    Here is my connection string: serverurl=https://xx-stw-ts-nc04;SouthBoundIPAddress=10.12.104.52;servicename=NC-VMM-TP5

    The 04 at the end of nc04 is because it's my fourth try, and I didn't want to wait for a DNS update so I just created a new name for the nc. During the installation wizard, I am able to connect to my NC and get his certificate. The server role appears as installed and the VM has joined the domain.  But when I wanted to install the NC, I got this error:

    Error (50124)
    Plugin for network service 'NC' threw an exception: 'An internal error has occurred trying to contact the 'xx-stw-ts-hst02.xx.ca' server: : .
    
    WinRM: URL: [http://xx-stw-ts-hst02.xx.ca:5985], Verb: [INVOKE], Method: [ExportCertificateByNameFromStore], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/scvmm/AgentManagement]
    
    Check that WS-Management service is installed and running on server 'xx-stw-ts-hst02.xx.ca'. For more information use the command "winrm helpmsg hresult". If 'ul-stw-ts-hst02.ul.ca' is a host/library/update server or a PXE server role then ensure
     that VMM agent is installed and running. Refer to http://support.microsoft.com/kb/2742275 for more details.'
    
    Recommended Action
    Work with the network service vendor to fix the problem.


    Here's what I know when this errors appears:

    • Windows firewall allows every connections, on both the NC and the hosts
    • WinRM appears as running in powershell on both the nc and the hosts
    • xx-stw-ts-hst02 was the host hosting the NC VM at first, but even if I migrate the VM on hst01, the error still appears

    However, I found this blogpost: https://thepracticalsysadmin.com/wtf-friday/

    tl;dr: It talks how tinkering with some gpo's solved his issue with a similar error message. So trough trial an error, i found a gpo that didn't solve the problem, but changed the error: Computer Configuration-Administrative Templates - Windows Components - Windows Remote Management (WinRM) - Winrm Service - Allow remote server management trough WinRM

    That policy isn't configured on either host, but when I enable it on hsto2, I get this error:

    Error (2916)
    VMM is unable to complete the request. The connection to the agent 'ul-stw-ts-hst02.ul.ca' was lost.
    
    WinRM: URL: [http://xx-stw-ts-hst02.xx.ca:5985], Verb: [ENUMERATE], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/cimv2/Win32_Service], Filter: [select * from Win32_Service where Name="NcHostAgent"]
    
    Unknown error (0x80338126)
    
    Recommended Action
    Ensure that the Windows Remote Management (WinRM) service and the VMM agent are installed and running and that a firewall is not blocking HTTP/HTTPS traffic. Ensure that VMM server is able to communicate with 'xx-stw-ts-hst02.xx.ca' over WinRM by successfully
     running the following command:
    
     winrm id –r:xx-stw-ts-hst02.xx.ca
    
    This problem can also be caused by a Windows Management Instrumentation (WMI) service crash. If the server is running Windows Server 2008 R2, ensure that KB 982293 (http://support.microsoft.com/kb/982293) is installed on it.
    
    If the error persists, restart 'xx-stw-ts-hst02.xx.ca' and then try the operation again. /nRefer to http://support.microsoft.com/kb/2742275 for more details.


    I'm not sure what to do with this. Do you know what could cause the issue, and how I could add the network service without any errors?

    Thank you, and sorry for my poorly written english.

    -Alexis Lessard




    Tuesday, June 14, 2016 8:02 PM

Answers

  • I managed to get the service installed. I had to remove my hosts from the cluster and the host group, and then add them back to the cluster, one at a time. Adding the network service went without any problems. I don't know how it solved the problem, but it did! 
    • Marked as answer by AlexisLessard Thursday, June 16, 2016 3:04 PM
    Thursday, June 16, 2016 3:04 PM