none
Set-GPPermissions always prompting

    Question

  • Does anyone know how to bypass the Set-GPPermissions prompt? I have an automated script that removes 'Authenticated Users' from the security filtering and I couldn´t find a way to bypass it. Even if I put -Confirm:$false it still prompts... There is no -force option in this command..

    Get-gpo $policy_name -Domain $domain | Set-GPPermissions -Replace -PermissionLevel None -TargetName 'Authenticated Users' -TargetType group
    

    I know after kb3163622 all computers must have read access to user GPOs, and I will be using another security group to this GPO above, so just wanted to avoid that prompt confirmation.

    thanks

    Wednesday, June 7, 2017 1:03 PM

All replies