none
crawleradmin does not recognize sp collection RRS feed

  • Question

  • Why doesn't crawleradmin recognize 'sp' as a valid collection when the cmdlet does? Please see the example below.

     

    Get-FASTSearchContentCollection sp

    Name          : sp

    Created       : 2011-08-31T15:53:56

    Cleared       : 2011-08-31T15:53:56

    LastInput     : 9/13/2011 3:58:29 PM

    DocumentCount : 37039

    Description   :

    Pipeline      : Office14 (webcluster)

     

    crawleradmin --collstats sp

    crawleradmin.exe 14.0.0291.0000 10012900

    ERROR: Collection does not exist: sp

     

    This is unexpected, so your help is appreciated.

    Thanks, Kevin


    -Kevin
    Tuesday, September 13, 2011 10:22 PM

Answers

  • Something sounds indeed funky with your environment. That line should work - if the docid is correct. At the very least, it really shouldn't give you a "collection name is required" warning. Are you sure you're typing it in correctly? Are your "-" really "-" ? (there are a couple of variants of these, and copy pasting sometimes give you the wrong one).

    Fyi, you don't need to specify the -U parameter when deleting a document. It's used when pushing web sites. The below line would e.g. download and index MS's start page:

    docpush -c sp -U http://www.microsoft.com

    (Actually, docpush wouldn't fetch the page. The pipeline processor "DocumentRetriever" would download it for you).

     


    Marcus Johansson | Search Nerd | comperiosearch.com | linkedin.com/in/marcusjohansson
    • Proposed as answer by Mikael SvensonMVP Thursday, September 15, 2011 6:57 PM
    • Marked as answer by Kevin-SP2010 Friday, September 23, 2011 4:21 PM
    Wednesday, September 14, 2011 6:54 PM

All replies

  • Hi Kevin,

    A collection in the Enterprise Crawler is unrelated to a content collection in the index. A crawler collection consists of the crawler configuration, statistics, and the data collected during the crawl. The content collection is - as you already know - a subset of the index.

    Regards,

    Marcus

     

     


    Marcus Johansson | Search Nerd | comperiosearch.com | linkedin.com/in/marcusjohansson
    Tuesday, September 13, 2011 10:43 PM
  • As a follow on question, I am trying to follow the instructions for removing a URL from search results. (http://technet.microsoft.com/en-us/library/ee943508.aspx)

    Once the docid is found, I use this command:

    docpush.exe -c sp -l verbose -U -d ssic://11868

    The result is: Error: Collection name is required

    If this should work, it seems like something is broken in my environment.

    Thanks for the follow up,

    Kevin


    -Kevin
    Wednesday, September 14, 2011 3:02 PM
  • Something sounds indeed funky with your environment. That line should work - if the docid is correct. At the very least, it really shouldn't give you a "collection name is required" warning. Are you sure you're typing it in correctly? Are your "-" really "-" ? (there are a couple of variants of these, and copy pasting sometimes give you the wrong one).

    Fyi, you don't need to specify the -U parameter when deleting a document. It's used when pushing web sites. The below line would e.g. download and index MS's start page:

    docpush -c sp -U http://www.microsoft.com

    (Actually, docpush wouldn't fetch the page. The pipeline processor "DocumentRetriever" would download it for you).

     


    Marcus Johansson | Search Nerd | comperiosearch.com | linkedin.com/in/marcusjohansson
    • Proposed as answer by Mikael SvensonMVP Thursday, September 15, 2011 6:57 PM
    • Marked as answer by Kevin-SP2010 Friday, September 23, 2011 4:21 PM
    Wednesday, September 14, 2011 6:54 PM
  • " Are your "-" really "-" ? (there are a couple of variants of these, and copy pasting sometimes give you the wrong one)."

    Thank you  . . .  this mostly fixed the issue! Arrgh! The -U parameter was still required to complete the removal. Without it, the http:\\cohowinery\ was pre-pended to the path and it failed the deletion.

    Thanks again!

     


    -Kevin
    Wednesday, September 14, 2011 9:32 PM