locked
Unable to see Server 2012 RDS Collections created by different admin. RRS feed

  • Question

  • I setup RDS on Windows Server 2012 Standard x64 in a VM and created a collection and published several remote apps. When a colleague logs into the server, he can see that Remote Desktop Services is configured but he cannot see the attached servers, the collections or any remote apps.  He is also a Domain Admin and has the same domain credentials as myself.

    Anyone have any ideas?

    Friday, March 7, 2014 4:52 PM

Answers

  • It appears to be working now that servers were added and security settings were modified as listed above.

    P.S. Somehow the forum asked me for another username, ignore DKReamey's post, that is me.

    Monday, March 10, 2014 12:24 PM

All replies

  • Hi,

    Did he add the RDS servers (RDCB, RDSH, RDG, RDWeb, etc.) to Server Manager?

    -TP

    Friday, March 7, 2014 4:59 PM
  • Hi,

    Did he add the RDS servers (RDCB, RDSH, RDG, RDWeb, etc.) to Server Manager?

    -TP

    He shouldn't have to should he, I already did that, unless it is profile based?
    Friday, March 7, 2014 6:41 PM
  •  I found this, not sure why it works but it does. I had to edit the Security Properties of every admin that needs access to this and add the servers and their computers if they are using the Windows 8/8.1 Server Manger to the Windows Authorization Access group. Even after doing this it takes several minutes for the Server Manager to populate the RDS Collections.

    ==========
     If Connection Broker and RD Web Access are used, add the computer accounts for each server to the Windows Authorization Access group of the domain.  You must also verify that this group has read access to the user properties of each user object that you are deploying personal virtual desktops to:

    1. Look at the Properties of the user account and then select the Security tab.  Check to see if the Windows Authorization Access group has effective permissions to read the msTSProperty01 attribute of the user.
    2. If this group does not have read access to this property, do the following:
    a. On the security tab of the new user account that was created, click Advanced and then highlight Windows Authorization Access Group and click Edit.
            b. Change to the Properties tab and check Read all properties and then select OK.

    Friday, March 7, 2014 7:25 PM
  • Hi,

    I mean add them to the server pool in server manager.  For example, if a different user connects to the RDCB server using Server Manager and selects RDS, it will say that you need to add the following servers to the pool (or similar text), with a list of all of the RDS servers in the deployment.

    As to you needing to change the security properties of each admin, I do not see why that is required but if it solved the issue for you then great.  I will say that I have never had to do that to get different domain admins to be able to manage a RDS deployment.

    What level is the domain?  2003, 2008, 2012?  Was the domain originally at an older level and then upgraded to its current level?

    -TP

    Friday, March 7, 2014 8:13 PM
  • Hi,

    I mean add them to the server pool in server manager.  For example, if a different user connects to the RDCB server using Server Manager and selects RDS, it will say that you need to add the following servers to the pool (or similar text), with a list of all of the RDS servers in the deployment.

    As to you needing to change the security properties of each admin, I do not see why that is required but if it solved the issue for you then great.  I will say that I have never had to do that to get different domain admins to be able to manage a RDS deployment.

    What level is the domain?  2003, 2008, 2012?  Was the domain originally at an older level and then upgraded to its current level?

    -TP


    TP,  When I configured RDS I added the RD License Server and the RD Session host to the pool. When my colleague remoted to the RD Session Host and was prompted to add the RD License server. Once the RD License Server was added he could see the collection tab but not the configured collection or the Remote Apps. After I modified his security setting listed above and a logout/login, the collection showed up. The Domain is at Server 2008R2 Level, I don't know if it was upgraded, only been here three years.
    Friday, March 7, 2014 8:56 PM
  • Hi,

    How is everything going? Could you please tell us the present situation? If you need any further assistance, please let us know.

    Thanks,
    Dharmesh
    Monday, March 10, 2014 6:28 AM
  • It appears to be working now that servers were added and security settings were modified as listed above.
    Monday, March 10, 2014 9:04 AM
  • It appears to be working now that servers were added and security settings were modified as listed above.

    P.S. Somehow the forum asked me for another username, ignore DKReamey's post, that is me.

    Monday, March 10, 2014 12:24 PM
  • Hi,

    Glad to hear that you got it working. 

    Thank you for sharing your experience here. It will be very beneficial for other community members who have similar questions. 

    If you want any more solution in future, kindly place your post in Forum.

    Thanks,
    Dharmesh
    Tuesday, March 11, 2014 1:24 AM
  • Hi TP,

    the solution for me was to add all servers from the RDS farm to the server manager. When there are servers missing the server manager is not able to show the RDS correctly. Simple but worked for 3 of my colleagues.

    Kind regards

    Michael

    Tuesday, January 26, 2016 3:58 PM
  • What are the security settings?  Everyone says listed above but I see no above.

    Brad

    Tuesday, November 8, 2016 4:04 PM
  • Definitely replying late to this/ Necro-posting, but wanted to shed some light on this. I too was having issues finding a Collection in an environment I was new to. After reviewing every known RDS server in the environment, none of them showed the Collection I was looking for, for the property I was looking for (User Profile Disks).

    However, after finding this thread and the above post by Michlund, I added every RDS server in the environment into Sever Manager on the RDS server I happened to be logged into at the time. After doing so, I was able to see a Collection of RDS servers, called "Farm" in this environment, and within this collection I was able to see the User Profile Disks.

    It appears the Collection(s) will not appear until all servers associated with the Collection(s) are added to be managed by the server you are actively running Server Manager from.

    Hope this helps someone, like it helped me.

    Cheers,

    McGuinty
    Thursday, October 11, 2018 9:27 PM