none
How do I get IE to drop the domain name from authentication responses RRS feed

  • Question

  • All,

    I have a number of internal www servers that run various non MS operating systems which are not tied to the windows domain in any way. They are secure www sites and require authentication.

    When I connect to one via IE on a domain joined workstation or server (ie 8 & 9) I am unable to authenticate because I can not remove the domain name from the authentication credentials that IE is passing back to the www server.  I get an authentication prompt for user name & password with the domain pre populated.

    How the heck to I get IE to NOT pass the domain name as part of the authentication process. I've tried putting .\ in front of the user name but to no avail.

     

    Thanks,

    Steve D.

    Monday, October 31, 2011 3:26 PM

Answers

  • I figured it out. In case anyone is interested the answer is to un-check "Enable Integrated Windows Authentication*" on the Advanced tab of Internet Options. Remove the check from this box and you no longer pre-populate the current logon domain.

    Rgds,

    Steve D.

    • Marked as answer by SteveDiG Tuesday, November 1, 2011 1:49 AM
    Tuesday, November 1, 2011 1:49 AM

All replies

  • As you can see below, when you first attempt the auth it defaults to you domain user account... in this case win\username.

    When you select use another account, you get the following with no means to remove the domain name which causes auth failure as this www server isn't a domain member and doesn't use the domain for auth.

    How do I get rid of Domain: .... ???

     

    Thanks,

    Steve D.

    Monday, October 31, 2011 3:44 PM
  • I figured it out. In case anyone is interested the answer is to un-check "Enable Integrated Windows Authentication*" on the Advanced tab of Internet Options. Remove the check from this box and you no longer pre-populate the current logon domain.

    Rgds,

    Steve D.

    • Marked as answer by SteveDiG Tuesday, November 1, 2011 1:49 AM
    Tuesday, November 1, 2011 1:49 AM
  • Even this didn't work for me. I used \\ and then followed by the username and it worked for me.

    • Proposed as answer by hwasp Friday, November 6, 2015 10:11 AM
    Monday, October 20, 2014 7:19 PM
  • Thank you soooo much. I was having this issue and the double back slash \\ worked. Why there is no option to delete the domain is beyond me.
    • Edited by Gomek Friday, June 23, 2017 5:28 PM
    Friday, June 23, 2017 5:27 PM
  • thanks Gomek! This worked for me. 
    Friday, June 23, 2017 5:31 PM
  • Even this didn't work for me. I used \\ and then followed by the username and it worked for me.

    Yes! Thanks.
    Wednesday, January 31, 2018 1:14 PM