locked
logonui.exe consumes 100% memory when logged onto Windows 8.1 Pro notebook RRS feed

  • Question

  • I bought a new notebook and upgraded from windows 8.1 standard to pro so I can rdp into it.

    I use rdp because it's easier to connect this way and take advantage of my desktop screens and keyboard/mouse.

    When I am connected via RDP, the logonui.exe process takes more and more memory until the machine is unusable. I kill the process (or process tree) and it re-starts climbing in memory consumption once again.

    It only happens when connected via RDP from my windows 7 Pro desktop.


    James Eggebeen

    • Moved by Marvin_Guo Thursday, March 27, 2014 7:13 AM
    Wednesday, March 26, 2014 3:18 PM

All replies

  • Hi,

    Due to this issue just occurs to one specific computer, this could be related to some software conflicts. Please test in Clean Boot mode to check if this issue persists.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Karen Hu Monday, April 7, 2014 2:50 AM
    • Unmarked as answer by Judy_Zhou Monday, May 26, 2014 2:14 AM
    Friday, March 28, 2014 6:29 AM
  • I can confirm this behavior.

    I have a new HP 

    Model #: 700-230qe
    Product #: E6S61AV#ABA
    Serial #: 2MD41408FX
    Software Build #: 14AM1RCA605#SABA#DABA
    Service ID #: 20140417
    PCBRAND #: HP

    Fully Patched with VMWARE workstation 10.

    Within an hour all 16GBs are used.  Kill LogonUI.exe frees it up for a little bit


    -Brian-

    Monday, April 21, 2014 1:58 AM
  • Just like James, i've upgraded my Windows on my newly bought machine to take advantage of RDP. In my case the upgrade was from Windows 8.1 x64 to Windows 8.1 Pro x64.

    The behavior of the memory usage is the same in my case: all 8GBs are used within 15 minutes.
    Killing LogonUI.exe cleans up the memory for a short while, before it is taking more and more memory again.

    Brand: HP
    Model: 700-203ED
    Product: F9P34EA#ABH

    Thursday, May 1, 2014 6:31 AM
  • I have the extact same problem. After Upgrade to pro cause I wanted to use RDP the computer freezes once a day.....
    Monday, May 5, 2014 11:28 AM
  • Hi,

    I notice that this issue happened after upgrading to Windows 8 Pro, I suspect this is caused by some corrupted system files, which maybe come from the upgrade installation.

    In this situation, let’s narrow down this issue by using Process Explorer:

    Our focus should be under the thread tab.

    This tab displays all the threads within a process. On the main threads tab, you can view the Thread ID, CPU consumption, and Cycles Delta. The Cycles Delta count is good for seeing if a thread is running in your CPU.

    From the Threads Tab, you can also look inside the thread stack. In the stack you will be able to see which DLL’s are called. Remember work from the bottom up.

    Let’s run this tool first.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, May 26, 2014 9:27 AM
  • Hi Alex,

    I downloaded the Process Explorer, ran it and made some screenshots while connected over RDP.
    Unfortunately I can't upload images because my account seems to be unverified and I don't know how to verify.

    On the Threads tab there are about 13 threads with no CPU or CSwitch Delta consumption, all with Start Address "!RtLUserThreadStart".
    There are 2 threads with no CPU or CSwitch Delta consumption, both with Start Address "0x0".

    There's still one thread with CPU consumption (about 12.54) and CSwitch Delta is "1".

    I noticed on the Performance tab, all data is "n/a".
    If you want to see more details, please let me know.

    Sunday, June 1, 2014 1:31 PM
  • If you are being told you cant post a link, or embed a picture (or any other restriction) you just need to post to this thread saying your account has not been validated
    Look for the verify your account thread that is stuck to the top of the page.
    http://social.technet.microsoft.com/Forums/en-US/home?forum=reportabug

    Wanikiya and Dyami--Team Zigzag

    Sunday, June 1, 2014 2:06 PM
  • I have the same issue when I try and do a RDP connection from Windows 8.1 to another Windows 8.1 (both Enterprise Update 1).

    The installation on the computer where LogonUI.exe grows non-stop exponentially has a clean fresh installation of Windows 8.1 Update 1.

    Also processexplorer needs to be run as administrator to get the values for LogonUI.exe, if run as the logged on user all the values appear as n/a.

    From threads tab:

    4364 12.44 2,410,585,886 OmniPassCredProv.dll!DllGetClassObject+0x7a40
    4780 LogonUI.exe+0x1a4c
    7328 msvcrt.dll!endthreadex+0x38
    6784 authui.dll!DllGetClassObject+0x13860
    3548 DUI70.dll!CSafeElementProxy::s_SyncCallback+0x2f4
    5844 ntdll.dll!RtlReleaseSRWLockExclusive+0x64
    6304 storeng.dll!IsMachineInLDAPStore+0x1240
    7764 winbio.dll!WinBioReleaseFocus+0x1668
    5200 SHCORE.dll!GetScaleFactorForDevice+0x1d4
    1588 ntdll.dll!RtlReleaseSRWLockExclusive+0x64
    5476 MSCTF.dll!SetInputScopes+0x79c
    444 uxtheme.dll!OpenThemeDataEx+0x528

    (having similar issues with attaching image. I have sent the other forum to have my account validated).

    Monday, September 1, 2014 4:53 PM
  • Since my account is verified now, I hereby post some screenshots.

    Monday, September 1, 2014 6:16 PM
  • RedFuse - Run the process explorer as Administrator. That way you do not run in to access denied or n/a
    Monday, September 1, 2014 8:20 PM
  • Also, here's another trick I found out ... not really the solution but you can use Process Explorer, After running it as Administrator and find LogonUI.exe and suspend the process. You can right click on it and you have the option of suspending it. That seems to not let it consume the memory.

    This does not affect the performance or usability, but like I said only a temporary fix. Waiting on what microsoft has to say.

    Monday, September 1, 2014 8:22 PM
  • Any suggestions or fixes?

    I am using an HP envy machine. And the climb is steep and fills up al my 16GB memory in 30mins.

    Thursday, September 11, 2014 2:17 PM
  • I wrote a small program that looks at the memory usage and kills the process whenever the memory gets above a certain point. I have to run this all day, watching the screen blank every few minutes. Has anyone heard from Microsoft on how to fix this? I feel bad for anyone who is not able to do what I did. The other day I forgot to start my little killer program and I lost an hour's work when the machine froze. Really frustrating.

    Some days the usage hits 100KB and stops, on those rare days the system works as it should, but I can't find any sequence of events that reliably gets into that mode. It seems to be a matter of luck.


    James Eggebeen

    Wednesday, September 17, 2014 1:47 PM
  • Can I get a copy of the program somehow (paste source or link to your binary?) -- i have the EXACT same machine and problem.  Microsoft level 2 has been working on my PC for 2 and 1/2 weeks and is on it right now in fact.  If I get a fix, I'll let you know.  I would like to get a copy of that program - please.

    {removed}


    • Edited by ZigZag3143x Sunday, September 21, 2014 4:07 PM Removed PII
    Sunday, September 21, 2014 3:54 PM
  • Wrote my own so I don't need your code/binary -- still waiting for Microsoft to get back to me.

    crowg83@hotmail.com

    Sunday, September 21, 2014 9:11 PM
  • Just in case anyone else is frustrated with this issue, here is the code I used. It's a simple c# app that I run as administrator so it has the rights to kill the process. I just start it when I log on remotely and let it run. Sometimes after a day or more, the logonui process dies and does not come back, so I do check the console from time to time to see when that has happened.

                do
                {
                    try
                    {
                        Process[] prs = Process.GetProcesses();
                        foreach (Process pr in prs)
                        {
                            if (pr.ProcessName == "LogonUI")
                            {
                                long paged = pr.PagedMemorySize64;
                                long nonpaged = pr.NonpagedSystemMemorySize64;
                                Console.WriteLine("Paged [" + paged + "][" + nonpaged + "]");
                                if (paged > 300000000)
                                {
                                    Console.WriteLine("Killing it.");
                                    pr.Kill();
                                }
                            }
                        }
                    }
                    catch (Exception ex)
                    {
                        Console.WriteLine(ex);
                    }
                    Thread.Sleep(5*60*1000);
                } while (true);


    James Eggebeen

    Monday, September 22, 2014 2:16 PM
  • Thanks for the suggestion but unfortunately unless you unsuspend it you can't log in again! If you enable it again it contines to tick away in the background until you log in normally.
    Friday, December 19, 2014 9:08 AM
  • I can't believe how few hits there are for this issue but I have fallen foul of it too on my HP Envy. I have managed to fix it though :)

    In the previously posted screen shots of ProcessExplorer you can see a dll called OmniPassCredProv. Mine showed the same and the dll lives in c:\Program Files\Hewlett Packard\SimplePass.

    That software appears to be for the finger print scanner which I don't use so I uninstalled it and now LoginUI no longer gobbles memory.


    • Proposed as answer by RichardNZ Friday, December 19, 2014 9:33 AM
    • Edited by RichardNZ Friday, December 19, 2014 9:34 AM
    Friday, December 19, 2014 9:33 AM
  • I experienced the same issue with a new HP-350-G1 Laptop on Windows 7 x64 when using RDP to connect to it. Thanks a lot for the hint with HP SimplePass, in my case this software is unnecessarily preinstalled (laptop has no fingerprint sensor), after uninstalling everything works fine and memory usage is 1GB (of 4GB installed)...
    Monday, January 5, 2015 1:50 PM
  • Hi,

    same here, rdp from Win 8.1 to Win 8.1 pro, target machine is HP with OmniPass....

    

    p.s. make sure you start procexp as administrator (right click - Run As administrator)

    b/r

    thanks!

    -Nick

    Friday, October 30, 2015 11:03 PM
  • Great Fix! Worked like a charm!

    Wednesday, July 20, 2016 5:11 PM