none
SCOM 1801 - Web Console Installation issue RRS feed

  • Question

  • Hi,

    I installed SCOM 1801 Web Console.

    But if I bowse on Internet Explorer v11, https://<WEB CONSOLE>/OperationsManager the web page is empty.

    Also https://<WEB CONSOLE>/MonitoringView has error: "the website cannot display the page"

    If I use Firefox, it will prompt first logon windows. If I type the logon credentials (Windows Authentication) then Firefox shows me Operations Manager logon page. After typing my credentials it shows there it say "user does not have permission". But this user is SCOM administrator.

    If I use "Alternate Credentials", then I get"404 not found":

    What the the main issue and solution here?

    I could get pages using:

    https://<WEB CONSOLE>/Dashboard

    https://<WEB CONSOLE>/AppAdvisor

    https://<WEB CONSOLE>/AppDiagnostics

    Best regards

    Birdal




    • Edited by _Birdal Friday, April 6, 2018 6:45 AM
    Friday, April 6, 2018 6:06 AM

Answers

  • Hi Stoyan,

    I figured out the issue:

    SCOM Web COnsole installation process with "Enable SSL" does not set in IIS "SSL required" option automatically. That must be set manually in IIS. After I set "Default Web Site > SSL Settings > SSL required" enabled, then the SSL related Web Console worked.

    Before, I did not set in IIS any SSL accept the certificate and bindings.

    This solved the problem.

    But it is really strange that Microsoft offers an installation process with "Enable SSL", but did not set the configuration correctly during the installation.

    I have another problem in Web Console with Dashboard URL. But I will create another question in Technet.

    Best Regards

    Birdal

    Thursday, April 12, 2018 1:47 PM

All replies

  • Hi Birdal.

    where is the console installed on? On a MS or on a separate server?
    I think you need to search further in IIS and in the authentication settings in IIS. How does your config regarding authentication looks like?

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Friday, April 6, 2018 8:35 AM
    Moderator
  • Hi Stoyan,

    again and again this Web Console problem!

    SCOM 1801 Web Console is installed on the separate machine.

    I checked authentication and followed also MS articles. I cannot see any problem there. We use HTTPS and Web.Config in WebHost is OK.

    It is strange that "404 not found" error is there.

    I checked the new path in Web Console 1801 for OperationsManager subsite in IIS, it is "C:\Program Files\Microsoft System Center\Operations Manager\WebConsole\Dashboard".

    Should I in SCOM Operations Console > ADMINISTRATION > Settings > Web Console

    type the address "https://webconsole.mydomain.com/Dashboard" or "https://webconsole.mydomain.com/OperationsManager"

    Please consider that we use NLB for Management Servers. The NLB cluster address is for example om.mydomain.com. In the installation phase, this NLB cluster address is not accepted by Web Console installation process so that I had to set as Management Server address (RMS server)  MS1.mydoain.com during the installation. After the installation I tried and get these above errors.

    To test, Afterwards I set NLB cluster address (om.mydomain.com) to test the connection in the following files:

    "C:\Program Files\Microsoft System Center\Operations Manager\WebConsole\Dashboard\Web.config"

    "C:\Program Files\Microsoft System Center\Operations Manager\WebConsole\WebHost\Web.config"

    "C:\Program Files\Microsoft System Center\Operations Manager\WebConsole\MonitoringView\Web.config"

    I changed also following in the registry key of Web Console so that it looks now so:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\System Center Operations Manager\12\Setup\WebConsole]
    "ENCRYPTION_KEY"="079069D3523F92F267CB426F377F4D3A68AE96CD5B99510D"
    "WEBSITE_ID"="1"
    "DEFAULT_SERVER"="om.mydomain.com" (THAT IS NLB CLUSTER)
    "WEB_CONSOLE_URL"="https://webconsole.mydomain.com/OperationsManager" (CHANGED FROM https://localhost/OperationsManager to this VALUE)
    "APM_DIAGNOSTICS_URL"="https://localhost/AppDiagnostics"
    "APM_ADVISOR_URL"="https://localhost/AppAdvisor"
    "BINDING_CONFIGURATION"="DefaultHttpsBinding"
    "BINDING_AUTHENTICATION_SCHEME"="Negotiate"
    "AUTHENTICATION_MODE"="Windows"
    "HTTP_GET_ENABLED"="false"
    "InstallDirectory"="C:\\Program Files\\Microsoft System Center\\Operations Manager\\WebConsole\\"
    "ENCRYPTION_KEY_VALIDATION"="1E319E122F22179E597D936B1B719F37FEF8B0308140F3615719E1430CE1E713"
    "OVERRIDE_KEY"="C45720DF4E26F086E7AA731F13B46BE57DDA56E6BF413227"
    "OVERRIDE_KEY_VALIDATION"="A2B15E3B95FA002F0564F0EDC9D2EF7E30724E6335D166E2EC068F902841E49D"
    

    I think the problem is NLB?!

    Best Regards

    Birdal

    Friday, April 6, 2018 9:16 AM
  • Hi Stoyan,

    if I run debug on different Browsers, they show me following errors:

    Internet Explorer 11.0.9600.18921

    Firefox 59.02

    As you see in Firefox debugging the problem is related to authentication. Unfortunately I cannot localize it.

    IE has another problem. In IE, no page is displayed, no logon page also.

    Best Regards

    Birdal


    • Edited by _Birdal Friday, April 6, 2018 10:54 AM
    Friday, April 6, 2018 10:54 AM
  • Hi Birdal,

    Strange indeed. You have some "luck" with those web consoles. Did do the test with Firefox after chosing Windows Authentication or Alternate Credentials?
    Can you workaround the NLB cluster and test without it?

    And I also assume you have checked everything from:

    Configure authentication with the Web console

    I installed the web console in our test env and the install went well. I haven't configured NLB though. 

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    • Proposed as answer by GouravIN Friday, April 6, 2018 12:13 PM
    Friday, April 6, 2018 11:21 AM
    Moderator
  • Hi Stoyan,

    > "Did do the test with Firefox after chosing Windows Authentication or Alternate Credentials?"

    Both I tested. The same result.

    > "Can you workaround the NLB cluster and test without it?"

    I tested first without NLB cluster with the first Management Server. The same error were there. After I changed to NLB Cluster. That was the same.

    > "And I also assume you have checked everything from:"

    Yes, I checked all.

    Best Regards

    Birdal

    Friday, April 6, 2018 12:59 PM
  • Hi Stoyan,

    It seems it is an IIS issue

    Debugging of browsers show "HTTP 404" error in conbination with "500 internal server error".

    Perhaps that is the problem & solution?!

    https://community.ivanti.com/docs/DOC-21873

    Must I do any other configuration in IIS?

    I checked all in IIS, but I could not find any problem.

    Perhaps, you can tell me if you made any configuration change in IIS after you installed SCOM Web Console.

    Best regards

    Birdal

    Friday, April 6, 2018 2:01 PM
  • Hi Birdal,

    that is the thing - I did not have to do any special config to make it work. That is why I am trying to guess what happens in your case. But I agree on one thing - it is IIS related.

    I will try to check all the settings in my test lab tomorrow and try to give you some points.

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Monday, April 9, 2018 7:56 AM
    Moderator
  • Hi Stoyan,

    thank you for your engagement.

    :-)

    Best Regards

    Birdal

    Monday, April 9, 2018 11:45 AM
  • Hi Stoyan,

    I reproduced 2 times an installation behaviour/issue in SCOM Web Console:

    1) I installed SCOM Web Console with "Enable SSL" option

    I tested Web Console access and always I got the error "THe remote server returned an error: (404) Not found"

    2) I installed SCOM Web Console without "Enable SSL" option.

    I could access Web Console without any problem.

    It seems so that Web Console installation has an issue with "Enable SSL" option?!

    How did you installed "Web Console": with or without "Enable SSL"?

    Best regards

    Birdal


    • Edited by _Birdal Thursday, April 12, 2018 7:24 AM
    Thursday, April 12, 2018 7:23 AM
  • Wow, nice.. I did th einstall without enabling SSL, but enabled and added the certficate on a later stage. Maybe this is why it worked?

    I am afraid I don't have the time to test this right now, but would be very curious if others are also experiencing this behavior. 

    Great job, Birdal. 

    Let's see if others will report this too..

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Thursday, April 12, 2018 7:42 AM
    Moderator
  • Hi Stoyan,

    I figured out the issue:

    SCOM Web COnsole installation process with "Enable SSL" does not set in IIS "SSL required" option automatically. That must be set manually in IIS. After I set "Default Web Site > SSL Settings > SSL required" enabled, then the SSL related Web Console worked.

    Before, I did not set in IIS any SSL accept the certificate and bindings.

    This solved the problem.

    But it is really strange that Microsoft offers an installation process with "Enable SSL", but did not set the configuration correctly during the installation.

    I have another problem in Web Console with Dashboard URL. But I will create another question in Technet.

    Best Regards

    Birdal

    Thursday, April 12, 2018 1:47 PM
  • Hi Birdal,

    I wonder if this is just a behavior you are experiencing or it is reproducible? Please mark your reply as an asnwer.

    Maybe it makes sense to open a thread here:

    General Operations Manager Feedback

    but this makes sense only if this can be repro. 

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    • Marked as answer by _Birdal Thursday, April 12, 2018 2:27 PM
    • Unmarked as answer by _Birdal Thursday, April 12, 2018 2:27 PM
    Thursday, April 12, 2018 1:58 PM
    Moderator
  • Hi SToyan,

    yes, I will do it.

    Thank you.

    Best Regards

    Birdal

    Thursday, April 12, 2018 2:27 PM
  • Hi Birdal,

    you are now a true SCOM community contributor. :) Thank you for this.

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Friday, April 13, 2018 9:21 AM
    Moderator
  • Hi Stoyan,

    I have thousands of miles in front of me to be a true SCOM contributor :-).

    Best Regards

    Birdal

    Friday, April 13, 2018 10:56 AM
  • To add my contribution to this weird issue :

    Fresh install (windows 2016 fully patched, SCOM 1801), certificate imported in IIS (binding *:443), SPN double-checked.

    If I select "Enable SSL" during Web console install, I can't access it with "use windows authentication" (error 500), but it works if I manually re-enter my credentials with "use alternate credentials".

    If I don't select "Enable SSL" during web console install, I can access it using http://servername/operationsmanager (as exepected)... but I can also access it using https://servername/operationsmanager , without any change to web.config file nor to registry!



    • Edited by CyrAz Tuesday, June 5, 2018 3:19 PM
    Monday, June 4, 2018 4:42 PM
  • And another one :

    I just added a second MS+webconsole to the same fresh SCOM 1801 deployment.

    Exact same everything, except this time I didn't select "enable ssl" from the begining.

    Console is working but is not authenticating me directly, I need to type in my credentials.

    Fixed by modifying the "authentication" settings for OperationsManager site in IIS > for "windows authentication", move "NTLM" provider to the top of the list instead of "negotiate".

    Even though it's working perfectly fine on the first server with "negotiate" on top.

    Go figure...

    Tuesday, June 5, 2018 12:16 PM
  • Lol, yeah. This whole web console thing needs some love from Microsoft I think :D

    Thanks for sharing!

    Cheers!


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!) Blog: https://anaops.com/

    Tuesday, June 5, 2018 12:23 PM
  • None of the solutions worked for me...

    Upgraded to 1807 without success.

    Friday, September 21, 2018 12:43 PM
  • Has anyone found a solution to the problem?

    The options requre SSL and ignore client certificate is not helped for me, changing method of authentication too

    Monday, January 14, 2019 5:42 AM