Hyper-V Generation 2 in Windows Server 2012 R2 keyboard not working


  • I'm trying to install a Hyper-V Generation 2 guest OS Windows Server
    2012 on a host OS Windows Server 2012 R2 RTM from the technet

    What I found interesting from the description of the Hyper-V generation 2 is "This virtual machine generation provides support for features such as secure boot, SCSI boot, and PXE boot using a standard network adapter. Guest operating systems must be running at least Windows Server 2012 or 64-bit versions of Windows 8"

    However, when I tried to install a Windows Server 2012 VM, my keyboard is not working and if I want to copy something from the clipboard I got below error.

    I tried install Windows Server 2012 R2 as well, all works great.

    So i'm wondering is it a bug for Windows Server 2012 installation or the above support guest OS description need to change to Windows Server 2012 R2?


    Wednesday, September 18, 2013 4:24 AM


All replies

  • Hi Ricky,

    You're not alone! I am facing this problem just this minute! Waiting to see if Microsoft have patch for this...


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. Milton Goh

    Wednesday, September 18, 2013 7:23 AM
  • Is your Server 2012 media somehow have slipstreamed / updated Integration Components built into the VM?  (like the 2012 R2 does?)

    There is an IC revision dependency as well for what you are attempting to do.

    Beyond that the copy and paste (not using the Clipboard option) requires that the VM be installed and RDP functioning and the feature enabled on the hypervisor (off by default with Server).

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, September 18, 2013 3:16 PM
  • It's not only for copy paste, but also for any typing in the VM as well, I cannot

    type in anything using my physical keyboard.

    My installation media is the Technet subscription Windows Server 2012 ISO file. I don't think there's an updated version for Technet users at the moment


    • Edited by Ricky Gao Wednesday, September 18, 2013 11:39 PM
    Wednesday, September 18, 2013 10:37 PM
  • Interesting.

    I just tried our 2012 VL ISO x64 installing as a Gen2 VM on my RTM 2012 R2 and it worked fine.

    But, mine is Server with Hyper-V and not Hyper-V Server and a remote management UI (if that makes any difference or applies to you I don't know).

    In the Hyper-V Settings I do have "Enhanced Session Mode" enabled.  But the "Guest Services" is not enabled on the VM.

    Also, I did not upgrade Hyper-V but did a clean install.  (I have been hearing of various strange things resulting from upgrades of 2012 to 2012 R2 RTM)

    Is there any pattern between the two of you?

    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, September 19, 2013 3:46 PM
  • Brian,

    You mentioned you are using the Volume License ISO? Do you know if there is likely a different ISO from the one distributed to TechNet?

    *Sorry, just trying to remove any possibilities.*


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. Milton Goh

    Friday, September 20, 2013 1:48 AM
  • Hi Moderator,

    My host OS is Windows Server 2012 R2 datacenter with clean install.

    I tried both "Enhanced Session Mode" is disabled or enabled, same.

    The ISO image i'm using is "en_windows_server_2012_x64_dvd_915478.iso"

    I tried the Windows 8 image "en_windows_8_x64_dvd_915440.iso" still got the same result

    If it's the image related, i'm guessing Microsoft will release a new version of Windows Server 2012 and Windows 8 image for technet or MSDN user very soon

    Ricky's Blog

    Friday, September 20, 2013 3:35 AM
  • Hello,

    Just adding my name to the list. I have the exact same issue, so sadly I will have to create some of my new lab servers (non-R2) as gen-1 for now...

    Sunday, September 22, 2013 9:13 AM
  • Hi all

    At a recent conference (System Center Universe 2013 in Switzerland) it was said that one needs to use Windows 8.1 in order to use the enhanced console (unless MS releases an update for Windows 8 later on). If I understand correctly, you were all using Windows 8, not 8.1 - might this be the reason for the problem?


    Sunday, September 22, 2013 5:38 PM
  • Hi,

    Are you using the KVM console device or the USB Hub device between your keyboard and your computer? Please use the general connection method and try again.

    Additional, I am using the similar system environment with yours but nothing error found, you can update your parent host service pack first or try change the ISO image and try again.

    Hope this helps.

    Alex Lv

    Monday, September 23, 2013 5:26 AM
  • I am running into the same issue...unfortunately.


    Sunday, September 29, 2013 5:59 AM
  • Same issue here, trying to install Server 2012 Standard into Gen2 VM from freshly downloaded TechNet ISO onto 2012 R2 Standard host HyperV server. Cannot type anything from the keyboard, tried from multiple machines. Anyone find a resolution? 
    • Edited by pipnz Tuesday, October 22, 2013 4:10 AM
    Tuesday, October 22, 2013 4:10 AM
  • Same issue here.  Cannot use the keyboard or paste from clipboard to a Windows 2012 Standard Edition install using Generation 2 VM.  Tried from local Hyper-V host and from VMM; no joy.  Had no issues with a Windows 2012 R2 Standard Edition install.
    Wednesday, October 23, 2013 2:41 PM
  • Exact same issue

    HP DL360P server running Hyper-V Server 2012 R2. Cannot use keyboard when booting a VM to WDS/MDT boot. Works if I install the image directly from an ISO (Server 2012 R2 ISO), but does not work when booting to an MDT boot. 

    Running the latest version of MDT (6.1.2373.0) and ADK for 8.1 (although Im redownloading it just in case).

    I think its something to do with some potential drivers not being loaded by winPE but I dont know if thats a PE/MDT generation issue, or a fault with actual drivers on the Physical server. Will update hopefully within the next few days

    Thursday, October 24, 2013 4:24 AM
  • Update:

    Reinstalling the latest version of Windows ADK tools and MDT 2013 resolved my issue. 

    Deployment workbench = 6.2.5019.0 

    ADK = 8.100.26020 

    Running the Preview versions dont seem to work for the RTM releases

    Thursday, October 24, 2013 8:22 PM
  • Hello,

    same problem here: I have a fresh install of Win8.1 Enterprise, running Hyper-V.

    When creating a gen2 VM and trying to install Windows 8 by means of PXE boot, I can select the boot menu entry after PXE Bootloader has started - but once the Win8 Setup has loaded and started, I can not input any keys to the VM anymore (mouse works fine though), and since I need to authenticate with domain credentials at the PXE/WDS server, I'm at a dead end here - since I cannot enter any keyboard input inside the vm...

    On the same Hyper-V host, a gen1 VM (PXE-booted from the same WDS server) accepts any keyboard input just fine, during Win7 Ultimate x86 setup as well as Win8 Enterprise x64 setup...

    Baseline: impossible to set up any WDS-deployed OS inside a gen2 VM.



    Thursday, October 24, 2013 8:22 PM
  • I'm amazed You ever succeeded with the installation.

    Seems to me that windows 8.1 can not be installed as generation 2.

    Tried both pro and enterprise version.

    Works fine as generation 1.

    Hyper-v host is server 2012 R2

    Saturday, October 26, 2013 3:43 PM
  • Same issue here too :/

    Robson Hasselhoff - Follow me @Robk9e

    Saturday, October 26, 2013 7:26 PM
  • I'm amazed You ever succeeded with the installation.

    Seems to me that windows 8.1 can not be installed as generation 2.

    Tried both pro and enterprise version.

    Works fine as generation 1.

    Hyper-v host is server 2012 R2


    Why shoud it not work? The prerequisites for a Gen2 VM are "Win8/Server2012 or newer, and x64 architecture"...

    If you try installing Win8.1 x86 it will not work.
    With Win8.1 x64 Installation should work without problems (aside from the keyboard not being captured inside the VM).


    Monday, October 28, 2013 10:18 AM
  • Have you tried using the on-screen keyboard?  I entered my key with that method.  I will install, reboot, patch and hope for the best...

    Seems to be working! 

    I suppot PASS -

    • Proposed as answer by Vixion Thursday, March 10, 2016 12:50 PM
    Tuesday, October 29, 2013 6:45 AM
  • Detailed answer and workaround is here:

    Easiest solution is to update the boot.wim file on the WDS server to that from the x64 Windows 8.1 or Windows Server 2012 R2 media


    John Howard, Senior Program Manager, Hyper-V Team, Microsoft Corporation.
    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    Tuesday, October 29, 2013 6:15 PM
  • I had the same problem yesterday and my host os is 2012r2.

    But with host os win 8.1 it's possible to make 2012r2 gen-2 VM and then export it to srv 2012r2 host.

    Thursday, November 28, 2013 8:11 AM
  • I've also got the same issue with a Gen-2 Hyper-V Terminal, doesn't seem to pick up my laptop's (Dell Precision M3800) keyboard but does pick up the mouse (running Windows 10 Pro). Gen1 VM's are fine. The issue is with the boot.wim for WDS. Going to give the tutorial posted by John Howard a go,it's the only known workaround for this issue. *sighs*
    Wednesday, December 16, 2015 11:24 AM