none
error when resetting password on SSPR RRS feed

  • Question

  • Hi,

    we are experiencing some issues on SSPR. When the users try to reset, answer all the collenge question right and then input the new password, it waits for about a minute and come back with error "Error while attempting to reset password.".

    On the FIM service/portal server, i can see the following the in the Event log:

    ====================

    There was a timeout error while resetting the user's password.

    Details:

    System.TimeoutException: The request channel timed out while waiting for a reply after 00:00:59.9941404. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException: The HTTP request to 'http://<portalserver name>.local:5726/ResourceManagementService/WorkflowManager/79315438-c20b-465e-bcd6-677685f2783a/7' has exceeded the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.WebException: The operation has timed out

       at System.Net.HttpWebRequest.GetResponse()

    ========================

    I don't find a lot of information but looks like it cannot talk to back to the FIM portal for workflows but I have no idea on how to fix it.

    CAn you please help?

    Thanks,

    Tuesday, November 12, 2013 10:27 PM

All replies

  • Rabit,

    I would think this is one of two things:

    1. Is the endpoint listed above ('http://<portalserver name>.local:5726........) the correct server/alias name?

    2. Make sure that port 5726 is open between the password reset portal server and the FIM service machine, maybe firewall?

    Wednesday, November 13, 2013 3:13 AM
  • I encounter the same issue and by extending the timeout for the Reset portal could reset the password. You could change the timeout as follow:

    Edit the web.config file for the Password Reset site:

    FROM: 

     <resourceManagementClient
    resourceManagementServiceBaseAddress="http://FIMPORTAL.DOMAIN.COM:5725"
    timeoutInMilliseconds="60000" />

    To: 

    <resourceManagementClient
    resourceManagementServiceBaseAddress="http://FIMPORTAL.DOMAIN.COM:5725"
    timeoutInMilliseconds="300000" />


    Run IISRESET and test again :



    Regards Andre van der Westhuizen

    Wednesday, November 13, 2013 8:19 AM
  • To answer your question:

    1. Yes, the endpoint is correct

    2. Yes, the port is open on firewall. Actually the portal and the FIM service is the same box.

    Thanks,

    Wednesday, November 13, 2013 2:56 PM
  • Thanks for the suggestion.

    I will give this a try. It has been working for months till last weekend's reboot. I am wondering why this just popped up. Also the portal and the FIM service is on the same server so I dont know how much this can help. But I will give this a try anyway and report back.

    Thanks again,

    Wednesday, November 13, 2013 2:57 PM