none
Develop an App for SharePoint 2016 using Visual Studio 2015?

    Question

  • Hi All ,

    I am trying to create a SharePoint-hosted App in a SharePoint 2016 development environment using Visual Studio 2015.

    I have installed all of the required templates in Visual Studio, but while creating the SharePoint App, after selecting "SharePoint Hosted App" the next screen only gives me an option for "SharePoint 2013, SharePoint Online".

    Please let me know how to create an App that will target for SharePoint 2016 using VS 2015. 

    Thanks

    Vishnu

    Thursday, December 15, 2016 7:43 PM

All replies

  • Hi All,

    Getting the below error when adding sequential workflow,List,Event Receivers from visual studio.

    "SharePoint connection error", -"Can not connect to the SharePoint site"

    Pls let me know if you have any idea.

    Thanks

    Vishnu

    Thursday, December 15, 2016 8:48 PM
  • Hi All,

    I am trying to create SharePoint hosted app , but unable to add the new items(List) into the project.
    showing the below error.

    " The required version of SharePoint foundation or SharePoint server is not installed on this system. The target version of the SharePoint project is 15.0."

    Pls suggest me if you have any idea.

    Thanks

    Vishnu

    Thursday, December 15, 2016 8:50 PM
  • Hi Vishnu,

    Please install the “Microsoft Office Developer Tools Preview 2 for Visual Studio 2015”:

    https://www.microsoft.com/en-us/download/details.aspx?id=51683

    After that, when creating a SharePoint Hosted App, there will be a new option “SharePoint 2016”:

    Best regards,

    Patrick

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 16, 2016 10:42 AM
    Moderator
  • Hi Patrick,

    Thanks for reply. I have installed the same developer tools, now i am able to create the App, 

    but when i try to add the other SharePoint components (i.e. List) for the created App, it is giving me the below error.

    I think this issue is related to SQL permissions for the user, even i am getting the same issue when creating other SharePoint components also(when adding sequential workflow,List,Event Receivers from visual studio). Pls suggest me if you have any idea.

    Thanks

    Vishnu

    Friday, December 16, 2016 4:49 PM
  • Hi Vishnu,

    What account you use to do the operation?

    I suggest you look into ULS logs to see if there any more details related to this issue.

    Best regards,

    Patrick

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 26, 2016 3:16 AM
    Moderator
  • Hi Patrick,

    I am using the account which has all the necessary permissions.

    System Admin

    Database Login ( Security Login with db. creator and public roles)
    Farm Admin
    Site Collection Admin

    Reg ULS logs i have already looked it. But didn't find correct error.

    Thanks

    Vishnu

    Wednesday, December 28, 2016 2:21 PM
  • Hi Vishnu,

    Can you access this site in browser with this account?

    Please create another user account with the same permissions as the current account to see if the issue persists.

    Best regards,

    Patrick

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, January 3, 2017 1:23 AM
    Moderator
  • Hi Patrick,

    Yes, i am able to access this site in browser. Even we have verified with other user account also, but facing the same issue.. :-(

    Thanks

    Vishnu

    Monday, January 9, 2017 7:45 PM
  • Hi Vishnu,

    Here are the steps of adding a list in an app in my environment:

    1, new a SharePoint Add-in project:

    2, specify a developer site which is built on the "Developer" site template:

    3, choose SharePoint 2016:

    4, add new item into this project:

    5, add a list:

    6,

    7, as we can see, the list is added into my project properly:

    Can you show me on which step the error occurs?

    By the way, my environment is patched with the October 2016 CU, please do another test after install this CU or the latest CU, let’s see if the issue persists or not?

    Best regards,

    Patrick

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, January 10, 2017 5:38 AM
    Moderator