locked
Scan to email with 25MB exceeds size limits RRS feed

  • Question

  • Hi,

    We’re having some problems increasing the size of mail attachments for internal mail sent/received from a Sharp Multifunctional.

    Out setup:

    -          Multifunctional Sharp with Scan to me (S2M), Scan to folder (S2F), Scan to mail S2Ma) all working;

    -          S2M limit of 10 Mb has been reached and users are requesting larger files to be sent;

    -          Due to sometimes sensitive contents of the documents S2F has been forbidden;

    -          Increased the mailbox Set-Mailbox -MaxSendSize 50MB and -MaxReceiveSize 50MB;

    -          This was setup on 2 accounts which worked fine using Send-MailMessage with 25MB;

    -          S2Ma uses no-reply@company.com which just gives a network error for files above 10MB;

    -          Tried from another subnet (VDI’s) using using Send-MailMessage with 25MB, this works;

    But from the Sharp Multifunctional I cannot seem to get it to work. I receive the following error in my inbox when using S2M:

    =============================================================

    The maximum size for e-mail attachments has been exceeded.

    Attachement: 1 file(s)
    Total size: 17025 KB
    Receiver: MyEmailus@Company.com

    Subject: Scanned document from SHARP MF Printer


    Body:

    Scan settings:

    Color mode: Full color
    Resolution: 400 dpi
    Type: Duplex
    File format: PDFA


    Sent by Pcounter Embedded for Sharp

    =============================================================

    We strongly believe that the mail is hitting the connector limit which is strange since we’ve been able to send mail using PowerShell in 2 different subnets but from the Multifunctional, No way!

    Any ideas would be appreciated.

    Here are some of the PowerShell receiver outputs:

    Get-ReceiveConnector

    Identity                            Bindings                  Enabled

    --------                            --------                  -------

    EXS02\Default EXS02                 {0.0.0.0:2525, [::]:2525} True

    EXS02\Client Proxy EXS02            {[::]:465, 0.0.0.0:465}   True

    EXS02\Client Frontend EXS02         {[::]:587, 0.0.0.0:587}   True

    EXS02\Relay Connector               {0.0.0.0:25}              True

    EXS01\Default EXS01                 {0.0.0.0:2525, [::]:2525} True

    EXS01\Client Proxy EXS01            {[::]:465, 0.0.0.0:465}   True

    EXS01\Client Frontend EXS01         {[::]:587, 0.0.0.0:587}   True

    EXS01\Relay Connector               {0.0.0.0:25}              True

    EXS01\Default Frontend EXS01        {[::]:25, 0.0.0.0:25}     True

    EXS01\Outbound Proxy Frontend EXS01 {[::]:717, 0.0.0.0:717}   True

    EXS02\Default Frontend EXS02        {[::]:25, 0.0.0.0:25}     True

    EXS02\Outbound Proxy Frontend EXS02 {[::]:717, 0.0.0.0:717}   True

    Get-ReceiveConnector | ? {$_.Identity -like "*Default*"} | ft name,maxm* -AutoSize

    Name                   MaxMessageSize

    ----                   --------------

    Default EXS01          10 MB (10,485,760 bytes)

    Default EXS02          10 MB (10,485,760 bytes)

    Default Frontend EXS01 10 MB (10,485,760 bytes)

    Default Frontend EXS02 10 MB (10,485,760 bytes)

    Get-Mailbox MyMailbox | ft maxsen*,maxrec*

    MaxSendSize              MaxReceiveSize

    -----------              --------------

    50 MB (52,428,800 bytes) 50 MB (52,428,800 bytes)


    Timmy


    • Edited by TimTTY Wednesday, August 1, 2018 6:24 AM
    • Moved by Edward van BiljonMVP Wednesday, August 1, 2018 9:27 AM Moved to correct Forum
    Wednesday, August 1, 2018 6:23 AM

Answers

  • Hi TimTTY,

    If Sharp Printer wants to send mails, it should use a relay connector, you can use command below to find out which connector is enabled anonymous relay:

    Get-ReceiveConnector | Get-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" | ?{$_.ExtendedRights -like "*Ms-Exch-SMTP-Accept-Any-Recipient*" } | fl Identity

    Then you can use command below to check which connector's RemoteIPRanges contains this Sharp Printer's IP

    Get-ReceiveConnector "EX2016CU6\Anonymous Relay" | fl *remote* 
    If you have more then one connector contains this this Sharp Printer‘s IP,this Sharp Printer is more tend to use the more specifically one. You can also enable STMP log for this connector to find out whether Sharp Printer uses this connector.

    Then you can try to improve send/receive limit for this connector.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by TimTTY Sunday, August 19, 2018 7:57 PM
    Monday, August 13, 2018 7:01 AM

All replies

  • Hi TimTTY,

    If you use an Exchange mailbox, here are message size limits in Exchange:

    1. Limit on mailboxes. 

    Get-Mailbox user | fl *size*

    2. Limit on TransportConfig.

    Get-TransportConfig | fl Max*size

    3. Limit on Connector.

    Get-ReceiveConnector | fl name,Max*size

    4. Size limit by transport rule. 

    For more information about message size limits in Exchange, you can have a look about this article: https://docs.microsoft.com/en-us/exchange/mail-flow/message-size-limits 

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, August 2, 2018 6:41 AM
  • Hi Kyle,

    That's not really what I was looking for since that's been done.

    The problem is with the connectors. Consider the following facts:

    1. I increased the mailbox Max values to 50MB for myself and 1 test user;
    2. We can send mail to each other through Outlook 2016 and from any server using PowerShell;
    3. We cannot send to ourselves or each other from the Sharp Printer;

    Today I have increased the size to 20 MB on the Relay Connector and added the IP address from the sharp printer to test. So far so good. But now I am baffled since I cannot understand the reason why this worked. Do you have an idea?

     

    Next step is to remove the IP address from the Relay Connector Scoping and see if it still works.

    Any ideas on this?


    Timmy


    • Edited by TimTTY Thursday, August 2, 2018 9:58 AM
    Thursday, August 2, 2018 9:56 AM
  • Hi  TimTTY,

    As I said before, the limit on message size includes mailbox, connector and transport configure.

    The Sharp Printer needs to use Relay Connector to relay mails, it cannot use the default connectors, so the limit is related to Relay Connector, mailbox and transport configure.

    The reason why you could send mails to each other from Telnet is those mails don't use Relay Connector.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, August 7, 2018 1:39 AM
  • Hi TimTTY,

    If Sharp Printer wants to send mails, it should use a relay connector, you can use command below to find out which connector is enabled anonymous relay:

    Get-ReceiveConnector | Get-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" | ?{$_.ExtendedRights -like "*Ms-Exch-SMTP-Accept-Any-Recipient*" } | fl Identity

    Then you can use command below to check which connector's RemoteIPRanges contains this Sharp Printer's IP

    Get-ReceiveConnector "EX2016CU6\Anonymous Relay" | fl *remote* 
    If you have more then one connector contains this this Sharp Printer‘s IP,this Sharp Printer is more tend to use the more specifically one. You can also enable STMP log for this connector to find out whether Sharp Printer uses this connector.

    Then you can try to improve send/receive limit for this connector.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by TimTTY Sunday, August 19, 2018 7:57 PM
    Monday, August 13, 2018 7:01 AM