locked
WSS 2.0 Gradual Upgrade to WSS 3.0 - HELP! RRS feed

  • Question

  • I am performing a gradual upgrade from WWS 2.0 to WSS 3.0 - after version 3 installs and I run the wizard it builds the new central admin for version 3.  In the Operations->Upgrade and Migration tab, it lists the sites from v2 to be upgraded... but two (2) of the sites are missing... (it only populated 6 of the 8 sites)

    (databases are running on sql server 2005)

    I've been banging my head against the wall for days and I can not figure out why it does not list those two sites in the upgrade tab for the next steps(Begin Upgrade)... the prescan tool finds all 8 sites, but when that page is built under Operations in central admin, it acts like they do not exist...
    I have checked all the security I can think of in sql to make sure it can access the pages... I have checked the logs generated by the wizard and the prescan tool... everything says it finds those two sites... it lists them in the log file just like the rest of the sites and shows no errors or anything the looks like a failure during the wizard upgrade portion (when it makes central admin) but they do not show up in the Upgrade and Migration tab... I have re-run the entire process from installing WSS 3.0 and letting the wizard run 4 times on our production server without luck... I can not duplicate the problem in my test environment...

    any suggestions?
    Monday, August 25, 2008 1:57 PM

Answers

  • I found a solution to my own problem... imagine that one :)

    stsadm -o backup -url http://testsite -filename c:\backupfile

    then
    stsadm -o restore -url http://testsite -filename c:\backupfile -overwrite

    this rebuilds the site from the backup file... I did it on a test site first then re-ran the wss 3.0 installer and wizard and it found the "rebuilt" site..
    so then I did it to the production site and all is well...

    thx for reading anways :)
    -John
    Tuesday, August 26, 2008 2:58 PM