Windows Update UI on Windows 10 does not automatically change once applied group policies RRS feed

  • Question

  • Hello everyone,

    When I disable the GPO "Configure Automatic Updates" option, in the PC Settings Panel -> Advanced Options I see "check for update..." switched ON although I do a "gpupdate /force" command or I restart the PC.

    The option switch to "never check for updates..." just when I manually select "check for updates...".

    I wonder if it is just a UI refresh issue or if the PC still check for updates in background.

    Thanks for any answer.



    Tuesday, July 5, 2016 12:41 PM


  • Hi,

    Yes, as you said, on my Windows 10 machine, the status is same. This is an expected behavior, you could regard this condition as an UI refresh issue.

    About if system will still check for update in background, answer is yes, it is by design, even though we configured GPO.

    The "Disabled" option actually disables automatic updates without notification, Windows just will not install update automatically, if you want to completely disable update, the way I can consider is just disabling Windows Update service.


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact

    • Marked as answer by merk2015 Thursday, July 7, 2016 12:14 PM
    Wednesday, July 6, 2016 3:18 AM