locked
Phantom public folder store RRS feed

  • Question

  • I have an Exchange 2007 server that was originally part of a migration from Exchange 2003.  I had some problems with the public folders during the initial migration, and I had created a couple of different public folder stores to try to replicate with the old Exchange 2003 organization before I finally got it fixed.  The current public folder store works perfectly with no problems.  However, I've just discovered that there's a phantom public folder store, called "PublicFolders2" still on the Exchange 2007 server and it's trying to replicate this phantom store to the old Exchange 2003 server as well.  The old Exchange 2003 server, however, has had Exchange uninstalled for about 2 years. 

    I'd just like to get rid of this since it's throwing replication errors, although they just expire and nothing ever happens.  I checked in ADSIEdit, and this public folder store still appears in the storage group properties in AD for the Exchange 2007 server.  However, there's no actual database in existence for that set of public folders. Can I just delete it using ADSIEdit?


    Deb

    Monday, February 25, 2013 5:46 PM

Answers

  • Hi

    Is there an error when you run

    Get-PublicFolder "PublicFolders2"

    If yes, Please follow Martina's steps on this thread to delete it

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/3873bd8e-a8af-484c-98a1-5e0be0c41253/

    • Open Active Directory Users and Computers (ADUC)
    • Turn on Advanced Features in the View Bar
    • Go to the Container "Exchange System Objects"
    • Delete the Public Folder PublicFolders2

    Cheers

    If you have any feedback on our support, please click here


    Zi Feng
    TechNet Community Support

    Tuesday, February 26, 2013 9:02 AM
    Moderator
  • Hi

    If you could not confirm, and there is no issue happen from that public folder.

    Just keep it

    Cheers

    If you have any feedback on our support, please clickhere


    Zi Feng
    TechNet Community Support

    Friday, March 1, 2013 2:34 AM
    Moderator

All replies

  • Hi

    Is there an error when you run

    Get-PublicFolder "PublicFolders2"

    If yes, Please follow Martina's steps on this thread to delete it

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/3873bd8e-a8af-484c-98a1-5e0be0c41253/

    • Open Active Directory Users and Computers (ADUC)
    • Turn on Advanced Features in the View Bar
    • Go to the Container "Exchange System Objects"
    • Delete the Public Folder PublicFolders2

    Cheers

    If you have any feedback on our support, please click here


    Zi Feng
    TechNet Community Support

    Tuesday, February 26, 2013 9:02 AM
    Moderator
  • Thanks very much for your suggestion. I do get an error when I run "Get-PublicFolders" basically saying that the public folder doesn't exist, and it doesn't.  The problem, I think, is that the Public Folders2 hierarchy exists (I can see it in ADSIEdit in the FolderHierarchies container), although there's no public folder database. When I look in the Microsoft Exchange System Objects container in ADUC, there is no Public Folders2 there either. 


    Deb

    Tuesday, February 26, 2013 3:17 PM
  • Hi

    Do you need that public folder? If not, you can delete it.

    Cheers


    Zi Feng
    TechNet Community Support

    Wednesday, February 27, 2013 3:21 AM
    Moderator
  • That's what I was trying to confirm - that it would be OK to just delete it using ADSIEdit. That's the only way I can see it at all.


    Deb


    • Edited by SYNOFF Wednesday, February 27, 2013 2:13 PM
    Wednesday, February 27, 2013 2:13 PM
  • Hi

    If you could not confirm, and there is no issue happen from that public folder.

    Just keep it

    Cheers

    If you have any feedback on our support, please clickhere


    Zi Feng
    TechNet Community Support

    Friday, March 1, 2013 2:34 AM
    Moderator