locked
Scan for broken links Error RRS feed

  • Question

  • Sharepoint 2007 -

    Hi All,

    I have configured the Link Checker in our Sharepoint Content management Portal. Also i have configured the HTTPS Url.

    The Link Checker is working fine in local URL (http://portalname). Here, i didnot get any Broken link as result.

    But, in my https://www.portalname.com portal shows the Broken link as a result while running the "Scan for broken link".

    Can you please tell me which configuration i missed in the Portal.

    Thanks in Advance.

    Thanks & Regards,
    Sankar M

     

     

     


    • Edited by Mike Walsh FIN Friday, July 29, 2011 12:48 PM Sharepoint 2007 default so moved from Title to text
    Friday, July 29, 2011 12:00 PM

All replies

  • Do you have alternate access mapping for https://www.portalname.com  and http://portalname?
    Serge Tremblay MVP SharePoint
    Friday, July 29, 2011 8:03 PM
  • Hi Sankar,

    As Tremblay mentioned u need to check the AAM for the site. AAM wil solve ur problem.

     

    Tuesday, August 2, 2011 12:57 PM
  • HI,

    Carry out these steps:

    1. Login to your central admin.

    2. Go to Operations --> Global Configurations--> Alternate access mapping.

    3. Here check if you have defined alternate access mapping for the URLs.

    4. If not create them and then again execute the tool and then check the result.

     

    I hope this will help you out.

     

    Thanks,

    Rahul Rashu

    • Marked as answer by Emir Liu Tuesday, August 9, 2011 10:13 AM
    • Unmarked as answer by SankarM Thursday, August 11, 2011 11:40 AM
    Wednesday, August 3, 2011 4:19 AM
  • Hi Rahul Rashu,

    In the Central Administration, i have added both URL in the AAM. But, still i am getting the same error.

    Please check the below screenshot for your reference.

    http://portalname -> default URL(While creating site)
    http://portal.local -> Intranet URL.
    https://www.portalname.com -> Internet URL.

    If you think, the AAM configuration will solve this problem, please tell me steps to configure the AAM with HTTPS url.

    Thanks & Regards,
    Sankar M

     




    • Edited by SankarM Thursday, August 11, 2011 12:05 PM
    Thursday, August 11, 2011 11:41 AM
  • HI,

    Follow the same steps and reach upto AAM settings in centrala dmin.

    Now I would suggest you add https:// Urls in default zone for your internal and public URL zone.

    Add http: in custom zone.

    I hope this will help you out.


    Thanks, Rahul Rashu
    Thursday, August 11, 2011 11:58 AM
  • Hi,

    Thank you your reply. I have configured the AAM as per your guide. Now the "Scan for Broken link" is working fine.

    But, i am getting the Error message in Content Editor Web Part. The error messages are "Cannot retrieve the properties at this time" and "Cannot save your changes.".

    Can you please help me to solve this issues?

    Thanks in Advance.

    -- Sankar M

     



    Tuesday, August 16, 2011 10:10 AM