locked
Why can't I enable network discovery in Server 2008 R2 RRS feed

  • Question

  • Every time I go into "Advanced sharing settings", select "Turn on Network Discovery", then click "Save settings", when I then go back to Advanced sharing settings "Turn off Network Discovery" has been re-selected.  I can understand this being true for Public networks, but not for home/work networks.  This could be the reason that I can't connect to my server with Windows Explorer, from my Win 7 mobile workstation, and vice versa.

    What could be causing this???

    Sunday, May 25, 2014 3:16 PM

Answers

  • Hi,

    This issue occurs for one of the following reasons:

    •The dependency services for Network Discovery are not running. 

    •The Windows firewall or other firewalls do not allow Network Discovery. 

    To resolve the issue, follow these steps:

    1.Make sure that the following dependency services are started:

    • DNS Client
    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host

    2.Configure the Windows firewall to allow Network Discovery. To do this, follow these steps:

    • Open Control Panel, click System and Security, and then click Windows Firewall.
    • In the left pane, click Allow a program or feature through Windows Firewall.
    • Click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    • Select Network discovery, and then click OK.

    3.Configure other firewalls in the network to allow Network Discovery.

    4.Turn on Network Discovery in Network and Sharing Center

    Quote from http://support.microsoft.com/kb/2722035

    Hope this helps.



    Steven Lee

    TechNet Community Support

    Monday, May 26, 2014 3:14 AM

All replies

  • Hi,

    This issue occurs for one of the following reasons:

    •The dependency services for Network Discovery are not running. 

    •The Windows firewall or other firewalls do not allow Network Discovery. 

    To resolve the issue, follow these steps:

    1.Make sure that the following dependency services are started:

    • DNS Client
    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host

    2.Configure the Windows firewall to allow Network Discovery. To do this, follow these steps:

    • Open Control Panel, click System and Security, and then click Windows Firewall.
    • In the left pane, click Allow a program or feature through Windows Firewall.
    • Click Change settings. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
    • Select Network discovery, and then click OK.

    3.Configure other firewalls in the network to allow Network Discovery.

    4.Turn on Network Discovery in Network and Sharing Center

    Quote from http://support.microsoft.com/kb/2722035

    Hope this helps.



    Steven Lee

    TechNet Community Support

    Monday, May 26, 2014 3:14 AM
  • Thanks a million, Steven, that did the trick.  The problem was the services; only one of them was running.  I set the others to automatic, started them, and was able to turn on Network Detection (but only for my home/work settings).  I left the public turned off.

    Capt. Dinosaur

    Monday, May 26, 2014 5:37 PM