none
Logging on new Lotus Domino Connector RRS feed

  • Question

  • Hi there

    Has anyone had success with enabling trace logging for the new Microsoft Domino Connector please? Documentation is a bit scarce.  The documentation here makes reference to this article

    I have tried to enable trace logging to a file using the following config in the miisserver.exe.config but am not getting any data logged. 

    <source name="ConnectorsLog" switchValue="Verbose" switchType="System.Diagnostics.SourceSwitch">
    <listeners>
    <add name="test" type="System.Diagnostics.TextWriterTraceListener" initializeData="DominoConnector.log"/>
    </listeners>
    </source>

    Any suggestions would be appreciated.

    Monday, April 9, 2018 12:26 PM

Answers

  • I figured it out just in case someone else struggles with this.  I think I had to add the type tag in the listener configuration.  In our scenario, the full import from Domino was taking excessively long and no logs were generated that I could see although when I did let the full import complete, the log was there.  So it looks like the trace output is buffered somewhere and committed to the log file on completion.

    <source name="ConnectorsLog" switchValue="Verbose">
                    <listeners>
                    <add initializeData="C:\Logs\ConnectorsTrace.log"
                      type="System.Diagnostics.TextWriterTraceListener, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
                      name="ConnectorsTraceListener">
                      <filter type="" />
                    </add>
                    </listeners>
                </source> 

    • Marked as answer by Adrian Thomas Monday, April 16, 2018 5:30 PM
    Monday, April 16, 2018 5:29 PM

All replies

  • Adrian-

    The tracing does work. I'd make the path to the log fully qualified (e.g. c:\logs\dominoconnector.log) and make sure you've granted the MIM Sync service account access to write to that folder.

    Thanks,
    Brian


    Thanks,
    Brian

    Consulting | Blog | AD Book

    Monday, April 9, 2018 5:51 PM
    Moderator
  • Thanks Brian

    Appreciate the response.

    I confirmed that the sync service service account has rights to the folder specified (C:\Temp) and configured the logging source as below in the miisserver.exe.config file but still not getting any logs.  The Source Name (ConnectorsLog) is apparently hard-coded into the connector and the 2nd link in my initial question makes reference to this name being the value to use.

    <source name="ConnectorsLog" switchValue="Verbose" switchType="System.Diagnostics.SourceSwitch">
                    <listeners>
                        <add name="test" type="System.Diagnostics.TextWriterTraceListener" initializeData="C:\Temp\DominoConnector.log"/>
                    </listeners>
                </source>

    Am I missing something?  

    Tuesday, April 10, 2018 7:08 AM
  • I figured it out just in case someone else struggles with this.  I think I had to add the type tag in the listener configuration.  In our scenario, the full import from Domino was taking excessively long and no logs were generated that I could see although when I did let the full import complete, the log was there.  So it looks like the trace output is buffered somewhere and committed to the log file on completion.

    <source name="ConnectorsLog" switchValue="Verbose">
                    <listeners>
                    <add initializeData="C:\Logs\ConnectorsTrace.log"
                      type="System.Diagnostics.TextWriterTraceListener, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"
                      name="ConnectorsTraceListener">
                      <filter type="" />
                    </add>
                    </listeners>
                </source> 

    • Marked as answer by Adrian Thomas Monday, April 16, 2018 5:30 PM
    Monday, April 16, 2018 5:29 PM