locked
I have a weird problem with a Junction (I think so anyway....) Part Two!! RRS feed

  • Question

  • This question was previously asked in the Windows community forum ( http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/i-have-a-weird-problem-with-a-junction-i-think-so/fd0d46ff-a77f-4c5f-8511-dbf25c4c108d?tm=1465803820537&auth=1 ), but I have been sent here for further help.

    Quote:

    Hello there,

    I have been forcibly migrated from 32bit Vista to 84bit 7 due to hardware issues, but due to various legacy data issues I need to keep using some old software, especially Kodak Easyshare.  I have over 35,000 photos in over 800 albums, and many of these photographs have links within Easyshare to three or more different albums. It is the structure of these albums which I really need to retain, as they are the index which allows me to access the right photo for the right taxonomic project. My files have been migrated since 2006 through three previous computers - each of which had a different file structure! and  I have finally hit trouble.

    My Original files (before 2007-09-21) were in directories of the format C:\Documents and Settings\User_2\My Documents\My Pictures\... etc  

    the file from 2007-09-22 to          C:\Documents and Settings\All Users\Documents\My Pictures\Kodak Pictures\... etc

    and so on.

    I decided, for conformity and tidiness that I would transfer all of the photos to the directory in which my camera now automatically uploads (this is C:\Users\Public\Pictures\Kodak Pictures\... ). In order to keep my original album structure I copied my previous Easyshare Catalog files into my new installation - this worked fine as it restored the catalog without the files (or so I thought...)  All I had to do within Easyshare was to reconnect the files to the previous catalogue entries.  This worked fine for the first lot of files, but when I started on the files that used to be in  "C:\Documents and Settings\All Users\Documents\My Pictures\Kodak Pictures\... ", Easyshare is still listing these photos (as C:\Documents and Settings\All Users\Documents\My Pictures\Kodak Pictures\..."  a directory which does not exist in my new computer setup!)  Consequently I cannot "re-connect" these photos as Easyshare thinks they are still there!  I am not too happy about this as there are several sets of the original photo files (some of which contain damaged files) living on my hard drive and I want to make sure Easyshare only uses the one set so I can delete all the odds and ends and just have one good set and the external drive backups for that set.  I need to do this because Easyshare has an unfix-able bug that sometimes changes the original file date to 1899/12/30 12.00 AM - I have been through and fixed the dates on the new versions of the files, but opening them in Easyshare reverts the dates to 1899/12/30 12.00 AM, whereas re-connecting the new files to the old catalog puts the correct date into the catalog - it is much easier to fix the dates outside of Easyshare and then reconnect the files!

    Please help as this problem is preventing me from working on my book!

    Yours Sincerely, Ms Jacq Felis.

    I did some exploring with the command prompt and found a junction hidden in the root file of my hard drive vis - 2009/07/14  02:38 PM    <JUNCTION>     Documents and Settings [C:\Users] and I am wondering if this is the cause of the problem?  Can I change this? If so, how? Also if I do remove it, will it stuff anything else up?

    END QUOTE OF ORIGINAL QUESTION

    Since then (13th June) I have been doing a bit more exploring and I have discovered the following.  If I MOVE the photos from the new directory (C:\Users\Public\Pictures\Kodak Pictures\... ) to C:\Users\Dell\Desktop\temp photos then I perform a reconnect from within Easyshare to the temp directory (this takes from 30 seconds to 20 minutes for EACH directory depending on the number of photos) the old association from C:\Documents and Settings\All Users\Documents\My Pictures\Kodak Pictures\... goes away, and I can then MOVE the photos back to   C:\Users\Public\Pictures\Kodak Pictures\... 

    Admittedly this works, but it is incredibly slow and tedious and so far I have only managed to fix up 114 of 449 folders.  Also, sometimes the process triggers the redating bug and then I have to go back and get a copy of the safe copy and start again.  ARRGH!  I am tearing my hair out here and would really appreciate some advice.

    Sunday, July 3, 2016 4:02 AM

All replies

  • Hi Kaelkitty13,

    Based on your description, this issue is more related to a third party application Kodak Easyshare provided by Kodak. I am not familiar this third party product.

    For Kodak Easyshare issue, it is recommended to contact Kodak support for help, they may have more resource to help you.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Tuesday, July 5, 2016 5:46 AM

  • I did some exploring with the command prompt and found a junction hidden in the root file of my hard drive vis - 2009/07/14  02:38 PM    <JUNCTION>     Documents and Settings [C:\Users] and I am wondering if this is the cause of the problem?  Can I change this? If so, how? Also if I do remove it, will it stuff anything else up?


    Please re-examine this question!  I have quoted the relevant section, which no-one has yet answered!
    Monday, November 21, 2016 1:57 AM