locked
More MMC problems RRS feed

  • Question

  • Hey Folks.

    I have recently installed Windows Server 2008r2 SP1 several times.  I have eliminated my initial problems with running Windows Updates & avoided the dreaded .NET 3.5.1 updates as they seemed to cause me all sorts of trouble.

    I have installed the Operating System and when the system boots, the Initial Configuration Tasks (oobe) launches.

    When I run the mmc - I get the Console1 windows as normal - but when I attempt to add "specific" snap-ins (server manager, event viewer) MMC crashes.

    I have looked over these forums quite a bit but cannot locate the correct fix.  I have a single instance of mmc.exe running when this occurs.  Diagnostic startup did not help.

    I have been digging through forums & tech articles for about a week now & wanted to see if anyone could help?

    I have been working with systems for about 15 years - but most of my server experience comes from the Debian Linux side.  

    Thanks!

     

    Update:  I ran the System Update Readiness Tool & the CheckSUR log came back with zero errors.  
    Monday, July 4, 2011 6:54 PM

All replies

  • Hi,

     

    Does this issue also occur in Safe Mode?

     

    Please upload the following files to https://sftus.one.microsoft.com/choosetransfer.aspx?key=938cdbf2-abfd-4622-9726-e04a6e178051

     

    Password: O{@v$LqAomEqA3

     

    %windir%\logs\servermanager.log

    %windir%\Logs\CBS \CBS.log

     

    Tim Quan

    Tuesday, July 5, 2011 2:42 AM
  • I just tested safe mode and safe mode with networking.  

    In both cases, the system restarted before I could get to the desktop.  Kinda strange? 

    In normal mode - seems to be fine, I can login under either the Administrator account or my own.  Under my account, I was denied access to the log files, but the Administrator account didn't seem to have any trouble with them.

    Uploaded the logs.

    Thank you for your time & assistance.


    Tuesday, July 5, 2011 5:08 PM
  • Hi,

     

    Thank you for sending the files to me.

     

    There is no error in CBS.log and one error in ServerManager.log is

     

    “Failed to internally open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]”

     

    Usually the issue is caused by a corrupt or missing package.

     

    I know you have run the System Update Readiness Tool and found no error. Can you please run it again and check whether any error appears.

     

    If still no error, I would like to know whether the MMC crash issue occurs in both the Administrator account and your own account.

     

    I also suggest testing this issue in the Clean Boot state:

     

    Clean Boot

    =======

    This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button, type "msconfig" in the search bar and press Enter.

     

    Note: Please click the Continue if the "User Account Control" window pops up.
    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System"

     

    4. Test if we can update the system in Clean Boot.

     

    Note 1: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This shouldn't affect the system or other programs. We may still manually run these programs later.

     

    Note 2: We can check on Normal Startup in the General tab to roll back to Normal Mode after we get this issue resolved.

     

    Tim Quan

    Wednesday, July 6, 2011 3:43 AM
  • Hey there...

    I went ahead & ran the System Update Readiness and the checkSUR.log file is still reporting no errors.  I ran this after a reboot.

    After that - I went and performed the instructions above for the "Clean Boot" - my only service outside of Microsoft is an Adobe Reader service - disabled the service & rebooted.

    I tested the system under both accounts with the same error.  Start -> run -> mmc results in the MMC has stopped working error.

    This is a new install of Server 2008r2 SP1 x64 w/ most of the updates - except the .NET 3.5.1 ones that came out around June 16th forward.

    Just wanted to say thank you for your time reviewing my troubles - I appreciate it and look forward to learning how to solve my own troubles.  I honestly just have very little experience working with the server side of the software by Microsoft. 

    Thursday, July 7, 2011 3:27 AM
  • Hi,

     

    Thank you for the reply.

     

    Then I suggest performing an In-place Upgrade of the system.

     

    To perform an In-place Upgrade of the system, please insert a Windows Server 2008 R2 SP1 disk (If you only have a Windows Server 2008 R2 disk, you need to uninstall SP1 first and then insert the Windows Server 2008 R2 disk) into the running system, double-click setup.exe to run it, choose Upgrade Install and choose your current system. For example, if you are running Windows Server 2008 R2 Enterprise now, choose Windows Server 2008 R2 Enterprise to install over the running system.

     

    Tim Quan

     

    Thursday, July 7, 2011 7:01 AM
  • Mr. Quan,

     

    I wanted to let you know that I performed the instructions that you've given me and I ran into yet another error.  The installation disk claimed that some of the files were corrupt & could not complete install after getting partially into the installation of the operating system.  The error code involved was 0x80070570.

    This is also the disk that I had installed with and had no trouble during the initial installation.  I have inspected the media and it is flawless on it's surface so that part of it is a little confusing to me.

    At this point, I think I am going to re-download the trial version of Server 2008 r2 sp1 from Microsoft and before burning to disk, I am going to CRC check it and re-attempt your instructions.

     

    Thanks!


    Friday, July 8, 2011 2:40 AM
  • I downloaded the disk and burnt the image onto the proper media.  I attempted to reinstall the Operating System and it resulted in the same error as before:

    Windows cannot install required files.  The file may be corrupt or missing.  Make sure all files required for installation are available, and restart the installation.  Error Code: 0x80070570

    I will run a chkdsk and sfc and reattempt - but at this point I am not confident this will solve the problem.

     

     

    Sunday, July 10, 2011 7:22 PM