none
newly scanned documents not inheriting permissions from containing folder RRS feed

  • Question

  •  

    I have four Pcs that all see each other on a local network.  I just bought a new Xerox scanner and my goal is to scan

    documents from it into one of the PCs into a shared directory so that all 4 PCs will then have access to these scanned

    documents.  The host PC is running Vista. The problem I'm having is that the newly scanned documents are not visible or
    accessible to the other three PCs.  The shared directory and any existing files in the directory are accessible.  I have

    included Everyone with Full Control in the permissions for the folder, and set it to give these permissions to all files

    and subfolders.  However, when a new files is scanned in and created, I see that Everyone is not listed there in the

    permissions of the file. I can unshare and reshare the containing folder and then Everyone does appear in the permissions

    list, but that really is inconvenient to have to do that every time I scan a new file in.  I also can copy the new file to

    another folder and then back into the shared folder and the Everyone user will be in the permissions list.
    But can someone please tell me why the newly scanned document just doesn't inherit the exact permissions of the containing

    folder in the first place???  And yes I have tried everyone option there is under the sharing and Security tabs and their

    advanced and customized options for the containing folder and nothing seems to work.

    Sunday, February 15, 2009 1:18 AM

Answers

  • Heya,

    First let's check if the folder is not explicitly blocking inheritance. Open an elevated command prompt and type in icacls c:\folderpath /inheritance:e

    Victor Constantinescu - MVP Security, MCTS
    Sunday, February 15, 2009 4:33 PM

All replies

  • Heya,

    First let's check if the folder is not explicitly blocking inheritance. Open an elevated command prompt and type in icacls c:\folderpath /inheritance:e

    Victor Constantinescu - MVP Security, MCTS
    Sunday, February 15, 2009 4:33 PM
  • I am having the exact same issue here. All files are able to be seen, even all newly created files. The inheritance is set and have looked over all the settings. Scanning from a HP LaserJet CM1312nfi in to shared folders. The only work around that I have found is copying files from folder to folder will fix the issue. Any other created files like I stated are seen if saved to those folders however (i.e. Excel, pictures anything other than scans). Any luck yet?
    Saturday, May 23, 2009 2:03 PM
  • I have had the same problem on an office network.  I host the shared directory from my machine and provide user accounts on my machine that employees use to login to the shared folder and grab newly scanned documents.  Each of their accounts are set as administrator to give max permissions to the files.  My problem was that the new scanned files (PDF) were not inherenting the permissions of the parent directory.  I tried everything I could to resolve the issue and then found this thread.  Here's how I'm currently handling this problem:

    I created a batch file like this:

    :TOP
    @echo off
    icacls c:\tempworks /inheritance:e
    PING 1.1.1.1 -n 1 -w 60000 >NUL
    GOTO TOP

    The ping command forces a 60sec pause in the script.
    The directory you are having problems with needs to be the directory on line 3...

    Throw that batch file on the desktop and let it run.  It requires virtually no system resources to operate and sends a forced inheritance command to the directory every minute to tell it to make any new files visable in the directory to all users.

    I know it's a Jimmy Rig solution, but it works flawlessly and any more time spent on this issue probably would have made me go insane.
    Friday, July 24, 2009 5:48 PM
  • hey I have faced this issue and no matter how I change the permission to everyone, the newly scanned document is locked. To resolve this, you should change the permission of the source of the folder. Check the source (file location) of your share folder. for example: C:/users/'your ID'/desktop/scanned folder

    so you need to edit the permission of the source folder to everyone only then the share folder is able to read/write by everyone.

    Saturday, August 2, 2014 4:34 AM