none
SharePoint ignores outgoing e-mail settings

    Question

  • With the upgrade to SharePoint 2013 we got a new problem. When user A invites user X then SharePoints sends an invitation mail with the FROM address of user A.

    The company ABCD has spoofing software that drops the incoming mail with the invitation as spoofing because the sending servers from www.notrealdomain.com are not approved by company ABCD to send mail for users with @ABCD.com extensions. They have a security policy and will not set our servers as trusted devices.

    With SharePoint 2007/2010 the outgoing e-mails are always send with the outgoing e-mail configuration settings (noreply@notrealdomain.com).

    Is it possible to use the SharePoint outgoing e-mail settings instead of the users mail address?

    SharePoint configurationSharePoint 2013 On-Premise (CU update January 15.0.4893.1001)
    SharePoint domain www.notrealdomain.com

    SharePoint outgoing e-mail settings:
    From address: noreply@notrealdomain.com
    Reply-t address: noreply@notrealdomain.com

    User A usera@ABCD.com
    User X userx@ABCD.com

    Thursday, March 16, 2017 4:08 PM

All replies

  • Yep, this is (unfortunately) expected behavior with no way to change it as far as I'm aware. This is for Access Requests only (e.g. not Alerts).

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, March 16, 2017 4:27 PM
    Moderator
  • First I did see this behavior with the community sites, when someone reacts on a post. And later with invitations. So I think it’s with all mails send out except Alerts

    Friday, March 17, 2017 1:24 PM