none
Cannot Add Storage disks in DPM 2016 RRS feed

  • Question

  • Hi,

    Hope someone can help. I am trying to add storage disks in DPM  2016

    but I come up empty. I tried everything I could find on the web but still not working. See screen shots.  Thanks in advance Marc

    Environment

    Storage Spaces Svr 2012 R2

    NAS Dell NX 3230

    DPM 2016 Rollup 2

    Thursday, July 20, 2017 8:04 PM

All replies

  • You need to create an ReFS formatted volume for DPM 2016 to use as a storage pool.

    This page outlines it fairly well.

    https://docs.microsoft.com/en-us/system-center/dpm/add-storage

    There is a great blog post here about setting up DPM storage and enabling deduplication - but I'd recommend Server 2016 if using data deduplication as it works much better. https://charbelnemnom.com/2016/10/how-to-reduce-dpm-2016-storage-consumption-by-enabling-deduplication-on-modern-backup-storage/ 

    Hope this helps.

    Thursday, July 20, 2017 9:54 PM
  • Danny,

    See setting.

    


    Marc

    Monday, July 24, 2017 4:19 PM
  • Hi Marc,

    If I'm understanding the configuration correctly you have the DPM server connecting to SMB for its storage pool and have created a volume on this using storage spaces. I've also noticed in the Dell NX 3230 that it supports iSCSI as a target - if you connect to the storage as an iSCSI target it will support block level access.

    The NAS Dell NX 3230 supports CIFS, NFS, FTP, SMB3.0, SMB Direct (RDMA). I can't find the same requirement listed in DPM 2016 documentation but in 2012/R2 the following storage requirements applied.

    - Direct attached storage (DAS)

    - Fiber Channel storage area network (SAN)

    - iSCSI storage device or SAN

    DPM has a VSS writer requirement that isn't supported by NAS to my knowledge.

    Alternatively you could try is to virtualize the DPM server and used SMB for the Hyper-V storage location E.g. https://blogs.technet.microsoft.com/canitpro/2013/12/17/step-by-step-deploy-hyper-v-on-smb-3-0/ . The VHDX files would be attached to the VM as local disk and would support the VSS requirements for the storage pool.

    If I've misunderstood the storage config you have please outline this in more detail.


    • Edited by Danny Grasso Monday, July 24, 2017 10:27 PM additional information
    Monday, July 24, 2017 10:13 PM