none
Cannot ping Hyper-V Server after reboot RRS feed

  • Question

  • After installing Hyper-V Server and adding it to our domain,  could ping the server fine.  After a reboot, I can not ping (or remote, or manage) the server by name or address, but I ping from the server fine.

    After trying every suggestion on the net, I reinstalled from scratch.  Same results (I could ping the server, then after a reboot I could not).  

    I have discovered a "work around".  If I remove the computer from the domain, reboot, add it back to the domain, and reboot, I can ping it again until the next reboot.  This is not a viable solution as it does not allow for remote recovery after rebooting.

    Note that at this point I have not even begun to create any server instances, though I have confirmed that I can use the Hyper-V manager when the server is ping-able.

    Kurt
    Thursday, March 18, 2010 1:50 PM

All replies

  • It sounds as if you are having a problem with AD.

    I am guessing that after the reboot the management OS is blocking your ping with the Advanced Firewall as it sees the ping as untrusted traffic.

    Personally - try a different test other than ping.  If, for example, you installed Server Core and added the Hyper-V role - ping is off, period, you will never get a ping reply.

    Back to AD.  Again, it appears that the management OS is not trusting your traffic and therefore blocking your ping.
    Have you tried RDP or a remote management console after the reboot (different ports, different traffic).

    Could be your domain join is failing.
    Have you tried unjoining, deleting the computer account, and the rejoining?
    Or joining the domain under a completely different machine name?

    Have you checked DNS for any strangeness (most AD problems are rooted in DNS).

    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 18, 2010 3:49 PM
    Moderator
  • The only ports that I am able to try (that I'm aware of) are RDP, remote management, and the remote Hyper-V management.  None of them work after the reboot.  All of them (including ping) work after the remove, reboot, add, reboot work around (until the next reboot).  

    I have tried deleting then computer entry in AD and re-adding.  No difference.

    I've tried stopping the firewall and advanced firewall, but I get an error saying that the service is not running. Related?  I can't imagine traffic being blocked because the firewall isn't on.

    I'll try renaming the machine and re-adding it.

    We have about a dozen MS servers of various types that never had this problem.  This is our first Hyper-V Server though.  We don't have any other Server 2008 machines either.

    Thanks for the response.
    Thursday, March 18, 2010 7:55 PM
  • You don't have any other 2008 servers....

    Hmm....

    Have you tried installing Server 2008 full and adding Hyper-V (just for the additional GUI).

    Also, what is the functional level of your domain?
    I think that there is a domain functional level requirement of at least 2003 - I cannot find a reference at this moment though.

    I just found this interesting tidbit:
    http://support.microsoft.com/default.aspx/kb/951020?p=1


    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 18, 2010 10:11 PM
    Moderator
  • I'll have to check on the functional level.  Also, we won't be getting a 2008 license for a few days.  BTW we won't be getting any more until we can resolve this.

    I think that's going down the wrong path anyway.  The server is able to login to the domain with domain accounts and see domain resources.  Its just that any other computers cannot see the server.

    Friday, March 19, 2010 11:57 AM
  • What are your network discovery settings?
    Friday, March 19, 2010 11:59 AM
    Moderator
  • What ever is the default for the Hyper-V Server install.  The only settings I have made (via the hvsetup tool) is naming the computer and joining our domain).  I have tried using a static IP address on our subnet, but this produced the same results and I it is using DHCP again.
    Monday, March 22, 2010 6:13 PM
  • The default is a tight firewall.

    But, I am thinking here - what about Domain policies?  Do you have any AD domain policies in place that might modify the server behavior (possibly a client policy that is being applied to the server).

    Do you ahve an AD group to move machines into for maintenance that does not apply all of the policies, to see if it might be related.

     


    Brian Ehlert (hopefully you have found this useful)
    Monday, March 22, 2010 8:29 PM
    Moderator
  • I'll try this in the next day or so.  I hope this isn't it as it would mean that you could join the domain, reboot and then not be subject to the policies until the next reboot!
    Wednesday, March 24, 2010 3:51 PM
  • Tried this.  Same results.
    Wednesday, March 24, 2010 7:43 PM
  • I have the exact issue now.  Win2008 R2, with Hyper-V joined to a SBS-03 Domain.  Was working on it to try to get Virtual Desktops Served Up and decided to Reboot the Server and now No Pinging of the Server via IP, Server Name, but it gets to the Internet just fine.  If you can't ping it, you are notRDP-ing to it..?

    Interesting that I can Ping the Hosted Virtual Win7 PC that this Hyper-V server is Hosting....so DNS is working fine. 

    It can ping the SBS Server (from Win-08 server) fine as well.  There is just a little bug/switch that needs to be flipped.....only a thousand or million to go thru..?

    Any ideas out there..?

    Thursday, March 25, 2010 2:49 PM
  • It is possible to RDP to a system that does not respond to Ping.

    For example:  If you install Server 2008+ as a "Core" installation instead of a "Full" installaion you will disciver that it will never respond to a Ping (by design) no matter what you do to the Firewall. 

    This is an excellent example of moving away from (stopping using) ping as a measure if a system is 'up'.

    Also - where is the domain controller?  Is it running in a VM?  (once again the Advanced Firewall behavior of it not being able to talk to the DC as soon as it comes up, therefore all incomming traffic is considered untrusted until it can properly talk to the DC again).

    Actually, I have to ask..  Why the requirement to be able to Ping the host?  That is all that has been discussed, pinging the host.

    I really cannot think of any reasons other than the Firewall or a mis-configuration at the networking level (NIC driver even) that would cause the host to drop from the network following a reboot.

    Are you using NIC Teaming drivers?  If so, break the Team and try again.


    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 25, 2010 4:11 PM
    Moderator
  • Ok...Firewall is turned off and now Pings are working again...both Server name and IP address.  But still can't access RDP now.  I am working with and testing out the RDP Connection Manager for Hyper-V and did run thru the manual on how to get it working.  First time though, so I figure something is wrong with that setup.  I am thinking I will remove the Roles for RDP on the HyperV server and try from scratch. :(

     

    Seems easy enough to figure out, but not really...tons of Checklist items to review.  I am glad this is Not a production Server. :)

     

     

    Thursday, March 25, 2010 4:24 PM
  • In my case the ping is irrelevant.  I can't RDP or Hyper-V Manage either after rebooting.
    Thursday, March 25, 2010 4:30 PM
  • Enabling RDP to the Hyper-V host involves a couple things.

    One is enabling RDP, the second is modifying the Advanced Firewall security settings.

    Did you follow these instructions to get RDP tot eh host working:

    http://support.microsoft.com/default.aspx/kb/555964?p=1

    (These apply to a Server Core and a Hyper-V Server installation - Server with Hyper-V (full installation) is different)

    Be sure to set the security for 2003 or XP if you are not using a client that is Vista or higher.


    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 25, 2010 6:03 PM
    Moderator
  • Ok...my findings (note I have not rebooted yet, but all is working for RDP again).

    1. This is using MSDN Licenses, so in reality I don't have CALs for this, so will limp along using Admin to access

    2. I was configuring the Remote Desktop Services prior to all this (again trying to get this Hyper-V to SErver up a couple sessions of Windows 7)

    3. I configured the RD Session Host Configuration during this RDS Setup and told it to use a Redirection Server (basically it is only 1 server box, so was just defaulting to the 1 Server name).

    4. I removed the Redirection piece and now all is fine for RDP again.

     

    How to remove Redirection:

    1. Server Mgt/Roles/RemoteDesktop Servies - Select RD Session Host COnfigurtaion

    2. The Status Pain will populate, then look for Edit Settings Section: Right Click the Member of Farm in RD Connection Broker Section, then select Properties

    3. On the RD COnnection Broker Tab, select Change Settings Button, then select No Farm Membership or Redirection.  It will give you warning and tell you it will open up your RDP.  I chose to go thru all the way.

     

    Now my question is, will this allow me to move forward with my project..?  Not sure since there is so much to do when trying to setup a simple Host that Servers up 1 or 2 Win7 Virtual PCs.

    PS...i was able to turn on again the Win08 Servers' Firewall, so can't ping, but RDP works.

    Good luck all.

    Thursday, March 25, 2010 7:00 PM
  • Not sure if this was in response to me or Gbuc.  If me... I have RDP, Hyper-V management, and even ping working... until the next reboot.
    Thursday, March 25, 2010 7:56 PM
  • But what is the issue.

    Is this a case of setting up RDP tot he host or is this a case of setting up RDS??

    These are distinctly different things.  Do we have two people with two different issues happening in this thread?

    So which is it?  Is this an RDS test environment where you are attempting to set up RDS on the Hyper-V host that is hsoting the VMs?  Or is this a problem with RDP access to the host (more of a general managment problem)?  Or is this a ping / networking going silent problem?

    I guess that as this goes on and I am getting confused at what the desired outcome is (regardless of ping falling off).

    As far as I know, you cannot install the RDS components on Hyper-V Server as the RDS components require the additional services of Shell and other supporting elements of Server 2008.

    Also, RDS is not required to access VMs - only if you want to set up the MSFT VDI stuff (assess control, desktop presentation, etc.)


    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 25, 2010 8:37 PM
    Moderator
  • Kurt:

    The only thing that keeps coming back to me is the advanced firewall.

    You say that you turned it off, can I ask how?

    Also, what version of Hyper-V Server are you running? (v1 or R2)

    And you are running the free Hyper-V Server (if I followed properly).

    I can't think of anything else that would relate to the symptoms - unless there is some really strange networking thing going on.  Have you tried a crossover cable between a client and your host?  Have you tried isolating the physical network with a small workgroup switch?

    My mind is totally drawing a blank.


    Brian Ehlert (hopefully you have found this useful)
    Thursday, March 25, 2010 8:43 PM
    Moderator
  • I hate bumping threads,  but I finally resolved this one:

    • If the Firewall is on, allow response to pings
    • Stop / disable the Base Filtering Engine service

     

    Tuesday, March 22, 2011 11:35 AM