locked
Unable to download 1610 update RRS feed

  • Question

  • Hi everyone, I have problem with new 1610 update. Almost everything have been downloaded but Service Point Connection has problem with download these two files:

    ERROR: Failed to download redist for c43a89e4-b642-4fc8-abf0-255bf5d88d82 with command /RedistUrl http://go.microsoft.com/fwlink/?LinkID=831290 /LnManifestUrl http://go.microsoft.com/fwlink/?LinkID=831291/RedistVersion 112015 /ProxyUri http://IPHERE/ /ProxyUserName /ProxyUserPassword /NoUI "\\FQDN\EasySetupPayload\c43a89e4-b642-4fc8-abf0-255bf5d88d82\redist"

    Almost 1 Gb have been downloaded for this update but there is problem with downloading these two.

    Is this problem is connected with proxy configuration? Im not sure beacuse if remove service point connection and I add this role without proxy he will ends on first step that he cant resolve microsoft.com dns name. 

    Last update have been downloaded and installed without problems. 

    Saturday, November 19, 2016 10:26 AM

All replies

  • Hello,

    This update is only one day old :)

    https://blogs.technet.microsoft.com/enterprisemobility/2016/11/18/now-available-update-1610-for-system-center-configuration-manager/

    I would suggest to try later, since more 25000 organizations is using SCCM 1511 and later.

    Regards,


    Gilles Tremblay
    MCSE Server | Desktop | Messaging | Collaboration | Productivity | Mobility | Cloud Platform and Infrastructure

    Dont forget to mark as Answered if you found this post helpful.

    DISCLAIMER: This post is provided "AS IS" with no warranties of any kind, either expressed or implied, and confers no rights. Always test before!

    • Proposed as answer by Gilles Tremblay Saturday, November 19, 2016 12:38 PM
    • Unproposed as answer by Garth JonesMVP Saturday, November 19, 2016 2:51 PM
    • Proposed as answer by ashim_4398 Sunday, November 20, 2016 2:09 AM
    Saturday, November 19, 2016 12:38 PM
  • Hi,

    I have the same problem this morning, get almost 1GB downloaded for the 1610 update but the redist keeps failing to download. The lines below are straight from my dmpdownloader.log file

    ERROR: Failed to download redist for c43a89e4-b642-4fc8-abf0-255bf5d88d82 with command  /RedistUrl http://go.microsoft.com/fwlink/?LinkID=831290 /LnManifestUrl http://go.microsoft.com/fwlink/?LinkID=831291 /RedistVersion 112015 /ProxyUri http://proxy.wescef.com.au:8088/ /ProxyUserName  /ProxyUserPassword  /NoUI  "D:\Microsoft Configuration Manager\EasySetupPayload\c43a89e4-b642-4fc8-abf0-255bf5d88d82\redist" .

    Failed to download redist for c43a89e4-b642-4fc8-abf0-255bf5d88d82.

    Anyone from Microsoft around that can shed some light onto this problem?

    Monday, November 21, 2016 1:21 AM
  • After a couple of hours of trying different things, finally solved this by disabling the proxy connection details for my site and allowing SCCM to go out without the proxy.
    Monday, November 21, 2016 3:31 AM
  • I don´t even see any 1610 availability in my console, even after running EnableRing PS1.
    Monday, November 21, 2016 3:17 PM
  • 1610 has its on Update Ring PS1 script, previous scripts have no effect.
    Tuesday, November 22, 2016 9:27 AM
  • Hello Experts,

    I have been seeing the same issue: ERROR: Failed to download redist, since 2-3 days. Have restarted SMS_EXECUTIVE SERVICE 2-3 times/day on average. Update 1610 keeps showing "Downloading" status on the console. Have also tried running the UpdateRing PS1. Is there a new PS1 for 1610? Where can i get it? 

    Thursday, November 24, 2016 11:05 AM
  • Please use this new PS: https://gallery.technet.microsoft.com/ConfigMgr-1610-Enable-046cc0e9

    It worked for me two days ago.

    Regards,


    Gilles Tremblay
    MCSE Server | Desktop | Messaging | Collaboration | Productivity | Mobility | Cloud Platform and Infrastructure

    Dont forget to mark as Answered if you found this post helpful.

    DISCLAIMER: This post is provided "AS IS" with no warranties of any kind, either expressed or implied, and confers no rights. Always test before!

    • Proposed as answer by Raviasks Thursday, November 24, 2016 11:27 AM
    Thursday, November 24, 2016 11:10 AM
  • Thanks for quick response Gilles.

    This script worked for me. AWESOME. :) Can see the 1610 update in "Available" status now. Thanks a ton.

    Thursday, November 24, 2016 11:27 AM
  • Hello M4R10s,

    Do you still have the problem ?

    I have had the exact same problem and I finally found the answer.
    Can you check in the  ConfigMgrSetup.log if you have these errors too ?

    INFO: Downloading files to D:\APPS\Microsoft Configuration Manager\EasySetupPayload\91406b1d-7c14-42d8-a68b-484be5c5e9b8\redist  $$<Configuration Manager Setup><12-10-2016 08:34:53.657-60><thread=85628 (0x14E7C)>
    INFO: Downloading component manifest...  $$<Configuration Manager Setup><12-10-2016 08:34:53.663-60><thread=85628 (0x14E7C)>
    INFO: Downloading http://go.microsoft.com/fwlink/?LinkID=831291 as ConfigMgr.LN.Manifest.cab  $$<Configuration Manager Setup><12-10-2016 08:34:53.668-60><thread=85628 (0x14E7C)>
    Using proxy server http://proxy, /ProxyUserPassword  $$<Configuration Manager Setup><12-10-2016 08:34:53.675-60><thread=85628 (0x14E7C)>
    Using proxy credentials  $$<Configuration Manager Setup><12-10-2016 08:34:53.681-60><thread=85628 (0x14E7C)>
    Failed to decrypt the proxy user password. Use the provided password as is  $$<Configuration Manager Setup><12-10-2016 08:34:53.687-60><thread=85628 (0x14E7C)>
    cannot set winhttp proxy password option: 80070057  $$<Configuration Manager Setup><12-10-2016 08:34:53.692-60><thread=85628 (0x14E7C)>
    ERROR: Download() failed with 0x80070057  $$<Configuration Manager Setup><12-10-2016 08:34:53.698-60><thread=85628 (0x14E7C)>
    ERROR: Failed to download language pack manifest (0x80070057)  $$<Configuration Manager Setup><12-10-2016 08:34:53.704-60><thread=85628 (0x14E7C)>
    INFO: Attempting to load resource DLL...  $$<Configuration Manager Setup><12-10-2016 10:50:33.616-60><thread=80368 (0x139F0)>
    INFO: setupdl.exe: Start  $$<Configuration Manager Setup><12-10-2016 10:50:33.622-60><thread=80368 (0x139F0)>
    INFO: Downloading files to D:\APPS\Microsoft Configuration Manager\EasySetupPayload\91406b1d-7c14-42d8-a68b-484be5c5e9b8\redist  $$<Configuration Manager Setup><12-10-2016 10:50:33.627-60><thread=80368 (0x139F0)>
    INFO: Downloading component manifest...  $$<Configuration Manager Setup><12-10-2016 10:50:33.633-60><thread=80368 (0x139F0)>
    INFO: Downloading http://go.microsoft.com/fwlink/?LinkID=831291 as ConfigMgr.LN.Manifest.cab  $$<Configuration Manager Setup><12-10-2016 10:50:33.639-60><thread=80368 (0x139F0)>
    Using proxy server http://proxy, /ProxyUserPassword  $$<Configuration Manager Setup><12-10-2016 10:50:33.646-60><thread=80368 (0x139F0)>
    Using proxy credentials  $$<Configuration Manager Setup><12-10-2016 10:50:33.651-60><thread=80368 (0x139F0)>
    Failed to decrypt the proxy user password. Use the provided password as is  $$<Configuration Manager Setup><12-10-2016 10:50:33.657-60><thread=80368 (0x139F0)>
    cannot set winhttp proxy password option: 80070057  $$<Configuration Manager Setup><12-10-2016 10:50:33.662-60><thread=80368 (0x139F0)>
    ERROR: Download() failed with 0x80070057  $$<Configuration Manager Setup><12-10-2016 10:50:33.668-60><thread=80368 (0x139F0)>
    ERROR: Failed to download language pack manifest (0x80070057)  $$<Configuration Manager Setup><12-10-2016 10:50:33.673-60><thread=80368 (0x139F0)>

    There is a lot more of errors like this in the log.
    The most important part is this one :

    Using proxy credentials  $$<Configuration Manager Setup><12-10-2016 10:50:33.651-60><thread=80368 (0x139F0)>
    Failed to decrypt the proxy user password. Use the provided password as is  $$<Configuration Manager Setup><12-10-2016 10:50:33.657-60><thread=80368 (0x139F0)>
    cannot set winhttp proxy password option: 80070057  $$<Configuration Manager Setup><12-10-2016 10:50:33.662-60><thread=80368 (0x139F0)>

    After some tests I finally found that removing the credentials to use to connect to the proxy server and restarting sms_executive was the answer to the problem.
    The files started to download and.... no more errors.
    The Configuration Manager 1610 is now Available (and not stuck anymore on Downloading).

    I hope this can help you.
    Marc

    Saturday, December 10, 2016 11:53 AM